Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Invité régulier
    Inscrit en
    février 2007
    Messages
    31
    Détails du profil
    Informations personnelles :
    Âge : 57

    Informations forums :
    Inscription : février 2007
    Messages : 31
    Points : 9
    Points
    9

    Par défaut Violation de protection générale inatendue avec PDX8

    Bizarre.
    J'ai un programme qui fonctionne très bien avec Paradox 8 sur des PC sous windows 2000, windows XP et Windows 7 pourvu que les PC ne soient pas équipés de processeur trop puissant.
    Depuis cette année, un nouveau PC est utilisé, il dispose d'un Intel Core i5 760 @ 2.80GH. C'est la seule différence notable avec les autres PC.
    Le problème surgit sur ce pc lors d'une demande d'impression, quelle que soit l'imprimante (réseau, locale, jet d'encre, laser) utlisée.
    Le message d'erreur (voir le titre) apparaît 9 fois sur 10 (et oui ce n'est même pas systématique) et il faut soit "killer" (j'utilise Process Explorer) paradox soit le terminer "normalement" s'il le veut bien.
    Le plus "drôle" (j'utilise bcp les guillemets) : PDOX fonctionne dans une fenêtre sans problème, j'ouvre un autre programme dans une autre fenêtre et imprime avec celui-ci et ... crac PDOX se plante dans l'autre fenêtre !
    Pffff si quelqu'un a une soluce ou un exorcisme ...

  2. #2
    Membre du Club
    Homme Profil pro
    Inscrit en
    mars 2006
    Messages
    84
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Argentine

    Informations forums :
    Inscription : mars 2006
    Messages : 84
    Points : 63
    Points
    63

    Par défaut

    Bonjour YvonG,

    Je suivrai ces pistes:

    Regarder la page de Bertil Isberg, la meilleure liste d'erreurs Pdox qui soit. Voir http://hem.bredband.net/bertilisberg...x/errindex.htm

    Essayer de compiler le module en question sur une version Pdox 10 - Pdox 11 et la faire tourner avec un Runtime actuel R10 - R11.

    Bonne chance!

  3. #3
    Invité régulier
    Inscrit en
    février 2007
    Messages
    31
    Détails du profil
    Informations personnelles :
    Âge : 57

    Informations forums :
    Inscription : février 2007
    Messages : 31
    Points : 9
    Points
    9

    Par défaut

    Bonjour et merci FDR2006 de t'intéresser à mon problème.

    Hélas, il n'y a pas de code d'erreur affiché (voir la pièce jointe).

    L'application fonctionne très bien avec les PC équipés de µP Dual Core mais subit ce problème avec un µP Quad Core.
    Cela aurait-il une influence ?
    Ou cela pourrait-il aussi provenir d'une configuration de BIOS inadéquate ?
    Mais pourquoi un problème intermittant ?

    Beaucoup de questions ...

    Merci d'avance
    Images attachées Images attachées

  4. #4
    Membre du Club
    Homme Profil pro
    Inscrit en
    mars 2006
    Messages
    84
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Argentine

    Informations forums :
    Inscription : mars 2006
    Messages : 84
    Points : 63
    Points
    63

    Par défaut

    Bonjour YvonG,

    Je crois que le pb est à niveau du moteur d'impression de Pdox. Moi aussi j'ai un état qui me fait ce pb.
    Rien trouvé chez Bertil ?
    Il y a une autre source très bonne d'info pour Paradox en France: news.zoo-logique.org, voir la rubrique programmation-paradox.
    Il est possible que tu trouves une solution dans ce news.
    Je vais investiguer un peu plus si je trouve une solution je reviendrai.
    As tu essayé, même le module seul qui fait l'erreur, avec une version plus récente.
    Pour info Paradox 10 possède 4 Service packs. Un d'entre eux change toutes les dlls du moteur d'impression. Ja n'ai pas Paradox 11.
    Essaie le zoo !
    Bonne journée.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •