1. #1
    Invité de passage
    Inscrit en
    novembre 2009
    Messages
    3
    Détails du profil
    Informations forums :
    Inscription : novembre 2009
    Messages : 3
    Points : 2
    Points
    2

    Par défaut debug javascript et php avec eclipse

    Bonjour à tous,
    j'utilise aptana depuis qqs temps mais je n arrive pas a debugger le javascript de mon projet php. En effet lorsque je lance une session de debug 'web browser' le php n'est plus executé. Je reçois en réponse a un POST sur un fichier php, le corps de celui-ci.

    l'adresse ds la barre firefox est celle ci:
    http://127.0.0.1:8000/monProjet/index.html

    xampp 1.7.4 est installé et je débug php avec xdebug ds eclipse sans problème

    j'ai ajouté la ligne : Listen 8000 ds httpd.conf sans résultat.

    Et une question en plus: existe t il une possibilité sous eclipse ou aptana de debugger php et javascript en même temps? et comment?

    Rq: j'utilise firebug aussi mais je préfère de loin eclipse ou aptana pour debugger le javascript. Une dernière question concernant firebug:
    Est il possible de le configurer pour qu il affiche les variables lors d'une erreur? Je n'ai pas trouvé comment faire ça.

  2. #2
    Invité de passage
    Inscrit en
    novembre 2009
    Messages
    3
    Détails du profil
    Informations forums :
    Inscription : novembre 2009
    Messages : 3
    Points : 2
    Points
    2

    Par défaut je progresse

    J'avance mais il me reste des problèmes à résoudre:

    J'ai trouvé pourquoi les points d'arrêts n'étaient pas respectés.

    Depuis plusieurs jours je lutte pour configurer aptana ou ecipse avec le plugin aptana.

    Le problème précédent est du au mauvais choix de l'éditeur ds eclipse. J'ai le plugin JSDT d'installer et je plaçais mes points d'arrêts dans l'éditeur JSDT. La prochaine fois je ferais attention.

    Pour ouvrir un fichier avec l'éditeur de son choix faire un click droit sur le fichier et "open with.."
    Il est possible de configurer l'éditeur par défaut dans:
    windowx->Preferences
    General->editors->files associations.

    Je suis arrivé à cette situations après énormément d'essais j'étais un peu perdu. J'ai encore des soucis avec l’exécution du javascript et du php mais je vais ouvrir une autre discussion.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Debug pas à pas en PHP avec Eclipse ?
    Par lr dans le forum Eclipse PHP
    Réponses: 1
    Dernier message: 06/04/2011, 10h14
  2. Réponses: 2
    Dernier message: 13/01/2009, 21h26
  3. PHP avec Eclipse
    Par Neuromancien2 dans le forum Eclipse PHP
    Réponses: 0
    Dernier message: 27/10/2008, 23h46
  4. Générer PHP avec Eclipse UML
    Par genshijin dans le forum Eclipse Modeling
    Réponses: 3
    Dernier message: 07/10/2008, 13h49
  5. [PHP-JS] Probleme de popup javascript en php avec dreamweaver
    Par wadali_2000 dans le forum JavaScript
    Réponses: 1
    Dernier message: 13/07/2006, 20h00

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo