Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 6 sur 6
  1. #1
    Invité de passage
    Inscrit en
    mai 2007
    Messages
    20
    Détails du profil
    Informations forums :
    Inscription : mai 2007
    Messages : 20
    Points : 4
    Points
    4

    Par défaut [WB12] Problème de reprise saisie

    Bonjour tout le monde

    Voici mon problème

    Derrière une rubrique dans le code navigateur je fais ca :
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    SI (SAIS_CODE<>"") 
    	ExécuteTraitement(BTN_REC_VILLE,trtClic)
    	SI Faux ALORS
    			Info("Code inconnu")
    			RepriseSaisie(SAIS_CODE)
    	SINON	
    			RepriseSaisie(COMBO_LIBELL)	
    	FIN
    FIN
    mon problème est le suivant
    Lorsque je tab sur la rubrique l'execute traitement travail bien mais par contre je voudrai que la reprise saisie soit sur la prochaine ou si faux sur la meme rubrique alors que la il va directement sur la première rubrique de ma page et ne gère pas du tout le retour de mon execute traitement


    Pour info BTN_REC_VILLE est une procédure locale et mon code est en sortie de champs navigateur

    Merci de me venir en aide SVP

  2. #2
    Membre régulier
    Inscrit en
    février 2007
    Messages
    179
    Détails du profil
    Informations forums :
    Inscription : février 2007
    Messages : 179
    Points : 71
    Points
    71

    Par défaut

    Est ce que par hasard, la procédure locale BTN_REC_VILLE renvoie un booleen comme résultat ??

    Il faudrait peut être mettre un RENVOYER (faux ou vrai) à la fin de cette procédure et tester ce booléen ensuite comme vous faites.

    Bonne journée

  3. #3
    Invité de passage
    Inscrit en
    mai 2007
    Messages
    20
    Détails du profil
    Informations forums :
    Inscription : mai 2007
    Messages : 20
    Points : 4
    Points
    4

    Par défaut

    Je viens compléter mon problème

    en fait lorsque je fais un executetraitement dans un sortie de champs (navigateur) et que ce traitement est un code serveur, Webdev me redessine la page (focus) à tous les coups.

    Un petit exemple, j'ai dans ma base la liste des villes et des codes postaux

    sur une rubrique CP je vais donc chercher la ville correspondant au code postal que l'utilisateur à saisie et pour cela je fait donc :

    SI (SAIS_CODEPOST<>"") ALORS
    ExécuteTraitement(BTN_REC_VILLE,trtClic)
    FIN

    Sous le BTN_REC_VILLE (bouton cacher) je charge un combo des villes correspondant au code postal ca marche bien sauf que j'ai un focus et donc je me retrouve sur la première rubrique de saisie.

    Auriez vous svp une solution pour ne pas avoir ce focus donc ne pas ce retrouver sur la première zone de saisie

    Merci d'avance

  4. #4
    Membre habitué
    Inscrit en
    janvier 2007
    Messages
    214
    Détails du profil
    Informations forums :
    Inscription : janvier 2007
    Messages : 214
    Points : 105
    Points
    105

    Par défaut

    Citation Envoyé par nicolash94 Voir le message
    Je viens compléter mon problème

    en fait lorsque je fais un executetraitement dans un sortie de champs (navigateur) et que ce traitement est un code serveur, Webdev me redessine la page (focus) à tous les coups.

    Un petit exemple, j'ai dans ma base la liste des villes et des codes postaux

    sur une rubrique CP je vais donc chercher la ville correspondant au code postal que l'utilisateur à saisie et pour cela je fait donc :

    SI (SAIS_CODEPOST<>"") ALORS
    ExécuteTraitement(BTN_REC_VILLE,trtClic)
    FIN

    Sous le BTN_REC_VILLE (bouton cacher) je charge un combo des villes correspondant au code postal ca marche bien sauf que j'ai un focus et donc je me retrouve sur la première rubrique de saisie.

    Auriez vous svp une solution pour ne pas avoir ce focus donc ne pas ce retrouver sur la première zone de saisie

    Merci d'avance

    Salut
    teste ça :

    1/BTN_REC_VILLE => proc local serveur en mode ajax et renvoi un boolean

    2/depuis code naigateur
    bres est boolean
    bres=AJAXExécute(BTN_REC_VILLE)
    si bres =vrai alors
    sinon
    fin

  5. #5
    Invité de passage
    Inscrit en
    mai 2007
    Messages
    20
    Détails du profil
    Informations forums :
    Inscription : mai 2007
    Messages : 20
    Points : 4
    Points
    4

    Par défaut

    Merci bcp pour ta réponse mais peux tu être plus précis sur ton premier point
    SVP
    1/BTN_REC_VILLE => proc local serveur en mode ajax et renvoi un boolean

  6. #6
    Membre habitué
    Inscrit en
    janvier 2007
    Messages
    214
    Détails du profil
    Informations forums :
    Inscription : janvier 2007
    Messages : 214
    Points : 105
    Points
    105

    Par défaut

    Citation Envoyé par nicolash94 Voir le message
    Merci bcp pour ta réponse mais peux tu être plus précis sur ton premier point
    SVP
    1/BTN_REC_VILLE => proc local serveur en mode ajax et renvoi un boolean
    mettre le code dans le bouton BTN_REC_VILLE dans une procedure local e ajax

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •