Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 9 sur 9
  1. #1
    Invité de passage
    Homme Profil pro zied hrichi
    Étudiant
    Inscrit en
    septembre 2012
    Messages
    27
    Détails du profil
    Informations personnelles :
    Nom : Homme zied hrichi
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Enseignement

    Informations forums :
    Inscription : septembre 2012
    Messages : 27
    Points : 1
    Points
    1

    Par défaut les symboles mathématiques

    Bonjour,

    je suis entrain d'utiliser la version 1.0 de XSLT sous eclipse
    mon problème c'est que j'ai pas trouver une solution pour afficher les symboles mathématique dans un fichier xsl
    avec un output text
    par exemple : le symbole (↔) est affiché ( ↔ )

  2. #2
    Modérateur

    Inscrit en
    septembre 2004
    Messages
    9 858
    Détails du profil
    Informations forums :
    Inscription : septembre 2004
    Messages : 9 858
    Points : 16 319
    Points
    16 319

    Par défaut

    C'est parfaitement correct, seulement ta XSLT écrit du texte en encodage utf-8, et le programme que tu utilises pour lire le texte ne le lit pas en UTF-8.

    D'où affichage bizarre. Configure ton programme de lecture de fichiers textes, pour qu'il ouvre ce texte en utf-8.
    Si tu donnes un poisson à un homme, il mangera un jour. Si tu lui apprends à pêcher du poisson, il videra le lac et au bout de deux ans son village ne mangera plus jamais.
    Partagez vos connaissances, mais aussi comment s'en servir.

  3. #3
    Invité de passage
    Homme Profil pro zied hrichi
    Étudiant
    Inscrit en
    septembre 2012
    Messages
    27
    Détails du profil
    Informations personnelles :
    Nom : Homme zied hrichi
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Enseignement

    Informations forums :
    Inscription : septembre 2012
    Messages : 27
    Points : 1
    Points
    1

    Par défaut

    Merci pour votre réponse ...

    le symbole (∈) ne s'affiche pas ni avec xml ni avec xsl

  4. #4
    Modérateur

    Inscrit en
    septembre 2004
    Messages
    9 858
    Détails du profil
    Informations forums :
    Inscription : septembre 2004
    Messages : 9 858
    Points : 16 319
    Points
    16 319

    Par défaut

    Trop vague. On va pas deviner de quoi tu parles.
    Si tu donnes un poisson à un homme, il mangera un jour. Si tu lui apprends à pêcher du poisson, il videra le lac et au bout de deux ans son village ne mangera plus jamais.
    Partagez vos connaissances, mais aussi comment s'en servir.

  5. #5
    Invité de passage
    Homme Profil pro zied hrichi
    Étudiant
    Inscrit en
    septembre 2012
    Messages
    27
    Détails du profil
    Informations personnelles :
    Nom : Homme zied hrichi
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Enseignement

    Informations forums :
    Inscription : septembre 2012
    Messages : 27
    Points : 1
    Points
    1

    Par défaut

    lorsque je fait un copier coller du symbole (appartient), (flèche droit) ou (flèche gauche) dans un fichier xml ou dans un fichier xsl, j'obtient un petit carreau vide a la place du symbole

  6. #6
    Modérateur

    Inscrit en
    septembre 2004
    Messages
    9 858
    Détails du profil
    Informations forums :
    Inscription : septembre 2004
    Messages : 9 858
    Points : 16 319
    Points
    16 319

    Par défaut

    Parce que l'endroit où tu le colles ne gère pas ces caractères. Ça peut être pour différentes raisons : pas géré par la fonte, ou bien utilise un encodage où ces caractères n'existent pas. (Autre chose que utf-8, donc.)
    Si tu donnes un poisson à un homme, il mangera un jour. Si tu lui apprends à pêcher du poisson, il videra le lac et au bout de deux ans son village ne mangera plus jamais.
    Partagez vos connaissances, mais aussi comment s'en servir.

  7. #7
    Invité de passage
    Homme Profil pro zied hrichi
    Étudiant
    Inscrit en
    septembre 2012
    Messages
    27
    Détails du profil
    Informations personnelles :
    Nom : Homme zied hrichi
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Enseignement

    Informations forums :
    Inscription : septembre 2012
    Messages : 27
    Points : 1
    Points
    1

    Par défaut

    évidement je suis entrain d'utiliser l'encodage UTF-8
    est ce que vous avez une idée ?

  8. #8
    Modérateur

    Inscrit en
    septembre 2004
    Messages
    9 858
    Détails du profil
    Informations forums :
    Inscription : septembre 2004
    Messages : 9 858
    Points : 16 319
    Points
    16 319

    Par défaut

    Bah ça peut être la fonte qui connaît pas ces caractères. Tu colles où, précisément ?
    Si tu donnes un poisson à un homme, il mangera un jour. Si tu lui apprends à pêcher du poisson, il videra le lac et au bout de deux ans son village ne mangera plus jamais.
    Partagez vos connaissances, mais aussi comment s'en servir.

  9. #9
    Invité de passage
    Homme Profil pro zied hrichi
    Étudiant
    Inscrit en
    septembre 2012
    Messages
    27
    Détails du profil
    Informations personnelles :
    Nom : Homme zied hrichi
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Enseignement

    Informations forums :
    Inscription : septembre 2012
    Messages : 27
    Points : 1
    Points
    1

    Par défaut

    dans l'éditeur XSL sous eclipse

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •