Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 2 sur 2
  1. #1
    Membre éprouvé Avatar de Katachana
    Profil pro
    Inscrit en
    avril 2007
    Messages
    755
    Détails du profil
    Informations personnelles :
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations forums :
    Inscription : avril 2007
    Messages : 755
    Points : 474
    Points
    474

    Par défaut Perte de la référence

    Bonjour,

    Je suis confronté à ce problème: mon application est installé sur WAS. Au restart du node manager dans websphere la ref de mon remote ejb ne semble plus valide. Comment faire pour effectuer une revérification ou faire un test permettant de savoir que les ref n'est plus bonne ?

    Le principe mis en place :

    1 - Le lookup a l'init de la classe
    2 - La méthode permettant de récup l'ejbHome fait un create() à chaque fois, mais ne refait pas de lookup.


    Merci d'avance !

  2. #2
    Membre du Club
    Homme Profil pro Thomas Segismont
    Développeur Java
    Inscrit en
    mai 2012
    Messages
    31
    Détails du profil
    Informations personnelles :
    Nom : Homme Thomas Segismont
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur Java
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2012
    Messages : 31
    Points : 63
    Points
    63

    Par défaut

    Qu'est-ce que tu reçois comme exception à l'appel de create ? Si elle est assez explicite tu peux toujours l'attraper et déclencher un nouveau lookup.

    ++

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •