p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Invité de passage
    Homme Profil pro
    Inscrit en
    juin 2012
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : juin 2012
    Messages : 1
    Points : 0
    Points
    0

    Par défaut [gVim][Windows] Problème en écrivant par sftp avec netRW

    Bonjour,

    Je suis de niveau débutant.
    Je m'excuse par avance si ce n'est pas exactement le meilleur endroit pour poster ce message. Auquel cas qq'un pourrait-il m'aiguiller vers ailleurs ?...

    ma conf :
    Vista SP2
    J'utilise Putty (plink, pscp...)
    J'ai la version maj 142 de NetRW sur gVim7.3 (version portable)

    Mon problème : je peux Lister ou Lire mais pas Ecrire un fichier sur un serveur unix.
    Ce n'est pas un pb de droits : je peux réaliser la commande d'écriture classique depuis un console CMD windows.

    shell : cmd.exe /C

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    if ($OS =~ "Windows")
    
    """ NetRW vars :
    let g:netrw_cygwin=0
    let g:netrw_mousemaps=0
    let g:netrw_preview=1 
    "let g:netrw_silent=1
    "let g:netrw_ftpextracmd="passive"
    
    " use no -batch to Debug :
    " use -v  for verbose
    "let g:netrw_ssh_cmd='"C:\Progra~1\PuTTY\plink.exe" -batch -l sik -pw tald7Pom'
    "let g:netrw_scp_cmd='"C:\Progra~1\PuTTY\pscp.exe" -q -sftp -l sik -pw tald7Pom'
    let g:netrw_sftp_cmd='"C:\Progra~1\PuTTY\pscp.exe" -v -q -sftp -l sik -pw tald7Pom'
    let g:netrw_list_cmd='"C:\Progra~1\PuTTY\plink.exe" -l sik -pw [aPassword] HOSTNAME ls -Fa'

    ce que je fais exactement :

    :e sftp://zer332o2/ => OK
    [VISUAL] o sur fichier test => OK (cf. line 376)
    écrire dedans et :wq! => KO : shell returned 1 (cf. line 460-461)

    cf le Debug log dans fichier attaché DBG.txt

    Je pense donc que c'est un bug provenant du fichier netRw.vim : si qq'un sait débugger ce fichier, cela me serait en effet très utile...

    Merci de votre aide.

    edit :
    .évidemment, je précise que les :help netrw_putty ou :help netrw_p8 ne m'ont pas été utiles. les :help netrw en général...
    .je viens juste d'upgrader en v145 de netrw (lien sur site du DrChip) non plus.
    .winscp fonctionne très bien en écriture mais ne représente pas ma solution

    -Kermit
    Fichiers attachés Fichiers attachés

Discussions similaires

  1. Problème d'encodage par défaut avec Eclipse/Pydev
    Par Tryph dans le forum Eclipse
    Réponses: 2
    Dernier message: 12/07/2014, 23h48
  2. Réponses: 12
    Dernier message: 29/04/2014, 05h47
  3. Problème de test par défaut avec Maven
    Par Smix007 dans le forum Maven
    Réponses: 10
    Dernier message: 12/05/2012, 05h05
  4. Réponses: 1
    Dernier message: 27/01/2010, 12h00

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo