1. #1
    Membre éprouvé Avatar de speedev
    Développeur Web
    Inscrit en
    mai 2006
    Messages
    1 051
    Détails du profil
    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2006
    Messages : 1 051
    Points : 406
    Points
    406

    Par défaut mysqld_multi problème connection autre user que root

    Bonjour,

    J'ai deux instances mysql et je rencontre l'impossibilité de me connecter avec un utilisateur créé sur les 2. Je ne peux me connecter qu'en root. J'ai finis par attribuer tous les droits à ce user (idem que pour root donc) mais rien y fait. Et par contre, en console, je me loggue sans problème avec ce nouveau user et sur chacune des instances...le problème vient donc très probablement de phpmyadmin. Le code erreur affiché est #2000 mais google ne m'a rien appris.

    Alors voici une portion de ma config :
    (le blowfish secrets est bien présent en haut du fichier)
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
     
    /*
     * First server
     */
    $i++;
    /* Authentication type */
    $cfg['Servers'][$i]['auth_type'] = 'cookie';
    /* Server parameters */
    $cfg['Servers'][$i]['host'] = '127.0.0.1';
    $cfg['Servers'][$i]['port'] = '3306';
    $cfg['Servers'][$i]['connect_type'] = 'socket';
    $cfg['Servers'][$i]['compress'] = false;
    /* Select mysql if your server does not have mysqli
    $cfg['Servers'][$i]['extension'] = 'mysqli';*/
    $cfg['Servers'][$i]['AllowNoPassword'] = false;
    $cfg['Servers'][$i]['socket'] = '/tmp/mysqld1.sock';
     
    /* Storage database and tables */
     $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
     $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
     $cfg['Servers'][$i]['relation'] = 'pma_relation';
     $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
     $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
     $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
     $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
     $cfg['Servers'][$i]['history'] = 'pma_history';
     $cfg['Servers'][$i]['table_uiprefs'] = 'pma_table_uiprefs';
     $cfg['Servers'][$i]['tracking'] = 'pma_tracking';
     $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
     $cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';
     $cfg['Servers'][$i]['recent'] = 'pma_recent';
     
    $i++;
     
    /* Authentication type */
    $cfg['Servers'][$i]['auth_type'] = 'cookie';
    /* Server parameters */
    $cfg['Servers'][$i]['host'] = '127.0.0.1';
    $cfg['Servers'][$i]['port'] = '3307';
    $cfg['Servers'][$i]['connect_type'] = 'socket';
    $cfg['Servers'][$i]['compress'] = false;
    /* Select mysql if your server does not have mysqli */
    /*$cfg['Servers'][$i]['extension'] = 'mysqli';*/
    $cfg['Servers'][$i]['AllowNoPassword'] = false;
    $cfg['Servers'][$i]['socket'] = '/tmp/mysqld2.sock';
    A tout hasard j'ai testé avec l'host "localhost" mais que nenni...
    Mes sockets répondent bien, tout est opérationnel en commande.

    Je remarque une chose qui m'intrigue, les mots de passe des 2 users que j'ai créé (mdp générés par interface phpmyadmin, bouton "générer") ne semblent pas cryptés de la même façon que les autres dans la table "user" de la bdd "mysql" (voir pj).

    Un coup de main svp ?!

    Merci
    Images attachées Images attachées  
    Vieux-jeune développeur Web qui tient tranquillement son petit blog http://blog.ikonenn.com

  2. #2
    Membre éprouvé Avatar de speedev
    Développeur Web
    Inscrit en
    mai 2006
    Messages
    1 051
    Détails du profil
    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2006
    Messages : 1 051
    Points : 406
    Points
    406

    Par défaut

    Problème résolu.
    Cela provenait du flag old_password de mon my.cnf qui était actif (bêtement dé-commenté) au moment où je créais mes users. Les passwords (comme je le présentais - cf PJ) n'était pas hashés de la même façon. J'ai pu le remarquer en testant une authentification http, le message d'erreur (code #2000) était cette fois beaucoup plus explicite et m'a bien tuyauté.

    J'ai donc supprimé les users, supprimé le flag old_password, redémarré mes instances et finalement recréé mes users.

    cqfd.
    Vieux-jeune développeur Web qui tient tranquillement son petit blog http://blog.ikonenn.com

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Impossible de se connecter en tant que root
    Par lala2000 dans le forum Sécurité
    Réponses: 11
    Dernier message: 05/05/2012, 20h31
  2. Réponses: 2
    Dernier message: 07/10/2011, 15h17
  3. [RedHat] Super utilisateur autre que root
    Par sebhm dans le forum RedHat / CentOS / Fedora
    Réponses: 10
    Dernier message: 08/08/2008, 02h58
  4. lancer une commande avec un user autre que root
    Par rootdaoud dans le forum Unix
    Réponses: 2
    Dernier message: 26/03/2008, 16h43
  5. problème navigateur autre que IE
    Par beabea dans le forum ASP.NET
    Réponses: 3
    Dernier message: 06/12/2007, 15h05

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo