p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Membre du Club
    Inscrit en
    janvier 2005
    Messages
    231
    Détails du profil
    Informations forums :
    Inscription : janvier 2005
    Messages : 231
    Points : 45
    Points
    45

    Par défaut SOAP-Uncaught SoapFault exception: [HTTP] Could not connect to host

    Bonjour à tous, j'ai essayé d'installer un simple webservice SOAP sur notre serveur de prod ubuntu, et j'obtiens l'erreur suivante

    Fatal error: in /serveur/ws/wsc/WSBRF.php

    Nous appelons le webservice par le protocole http et non https, est-ce cela un possible cas d'erreur?

    OpenSSL, CURL et SOAP sont pourtant bien activé. Je ne sais plus comment faire, sur notre serveur de preprod et en localhost, nous n'avons aucun soucis, tout fonctionne très bien

    Est-ce que quelqu'un pourrait m'aider?

    d'avance merci

  2. #2
    Expert Confirmé Sénior
    Avatar de Benjamin Delespierre
    Profil pro
    Développeur Web
    Inscrit en
    février 2010
    Messages
    3 930
    Détails du profil
    Informations personnelles :
    Âge : 27
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : février 2010
    Messages : 3 930
    Points : 8 158
    Points
    8 158

    Par défaut

    Heu, t'as au moins testé que le serveur SOAP répondait ?

  3. #3
    Membre du Club
    Inscrit en
    janvier 2005
    Messages
    231
    Détails du profil
    Informations forums :
    Inscription : janvier 2005
    Messages : 231
    Points : 45
    Points
    45

    Par défaut

    heu, je ne sais pas comment tester si le serveur soap repond ou non, par contre, on a juste essayé un hello word en soap sur la prod, et ça ne fonctionnait pas

  4. #4
    Expert Confirmé Sénior

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 641
    Points
    10 641

    Par défaut

    montre ton code

  5. #5
    Membre du Club
    Inscrit en
    janvier 2005
    Messages
    231
    Détails du profil
    Informations forums :
    Inscription : janvier 2005
    Messages : 231
    Points : 45
    Points
    45

    Par défaut

    ci-après un exemple de code simple qu'on a fait pour le test,
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    ini_set("display_errors",1);
    $client = new SoapClient(null, array('location' => "http://urlserveurdistant/ws/wss/WSTest.php",
                                         'uri'      => "http://201.125.153.52/ws/wss/"));
    echo $client->add(5,6);
    on a des resultats sur notre serveur de preprod, mais on a le message d'erreur cité en haut sur la prod. Remarque: l'url utilisé ci-dessous n'est qu'un exemple, mais en réel, c'est un autre IP pour le prod

  6. #6
    Expert Confirmé Sénior

    Inscrit en
    septembre 2010
    Messages
    7 957
    Détails du profil
    Informations forums :
    Inscription : septembre 2010
    Messages : 7 957
    Points : 10 641
    Points
    10 641

    Par défaut

    les deux URL sont accessibles ? (dans ton navigateur par exemple)

  7. #7
    Membre du Club
    Inscrit en
    janvier 2005
    Messages
    231
    Détails du profil
    Informations forums :
    Inscription : janvier 2005
    Messages : 231
    Points : 45
    Points
    45

    Par défaut

    oui, les sites sont accessibles sur navigateur, le serveur de prod est sur ubuntu, c'est peut-être un pb de chemin? ou de proxy? tout aide serait le bienvenu, on est mal ici

  8. #8
    Expert Confirmé Sénior
    Avatar de Benjamin Delespierre
    Profil pro
    Développeur Web
    Inscrit en
    février 2010
    Messages
    3 930
    Détails du profil
    Informations personnelles :
    Âge : 27
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : février 2010
    Messages : 3 930
    Points : 8 158
    Points
    8 158

    Par défaut

    Et depuis le serveur web qui effectue les requêtes client, il est accessible ? Essaie voir avec wget par exemple.

  9. #9
    Membre du Club
    Inscrit en
    janvier 2005
    Messages
    231
    Détails du profil
    Informations forums :
    Inscription : janvier 2005
    Messages : 231
    Points : 45
    Points
    45

    Par défaut

    ok, nous avons pu finalement résoudre le problème en support avec notre hébergeur, ce n'était pas le bon IP qu'on a appelé, il y avait un proxy. En tout cas, merci à tous

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. soap Fatal error: Uncaught SoapFault exception:
    Par piotrowski-s dans le forum Débuter
    Réponses: 1
    Dernier message: 03/10/2012, 08h17
  2. [PHP - SOAP - SSL]Could not connect to host
    Par SupraLalu dans le forum Services Web
    Réponses: 1
    Dernier message: 03/11/2011, 18h12
  3. Réponses: 6
    Dernier message: 21/04/2011, 14h56
  4. Php, Soap, SSL, Proxy => Could not connect to host
    Par madevilts dans le forum Services Web
    Réponses: 1
    Dernier message: 02/12/2009, 15h52
  5. [MAMP] Error: Could not connect to MySQL server!
    Par midiweb dans le forum Outils
    Réponses: 4
    Dernier message: 22/10/2007, 11h07

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo