Bonjour à tous.

Lors de mes tests unitaires avec phpunit, j'obtiens une erreur concernant File_Iterator_Facade. Après recherche avec mon grand ami Google, çà serait dû à une incompatibilité entre File_Iterator_Facade (Ver 1.3.0) et phpUnit (Ver 3.6.3). https://github.com/sebastianbergmann...rator/issues/9

Donc je me dit qu'en faisant un update de tout çà, j'aurais les dernières vesions et donc plus de problèmes d'incompatibilité.

Mes dépots étant mis à jour avant chaque action d'install ou d'upgrade.

-> pear upgrade phpunit
Et çà me sort ceci :
Code :
1
2
3
4
5
6
7
8
9
10
Did not download optional dependencies: phpunit/PHP_Invoker, use --alldeps to download automatically
phpunit/PHPUnit requires PEAR Installer (version >= 1.9.4), installed version is 1.9.1
phpunit/PHPUnit can optionally use package "phpunit/PHP_Invoker" (version >= 1.1.0)
phpunit/File_Iterator requires PEAR Installer (version >= 1.9.2), installed version is 1.9.1
phpunit/PHP_CodeCoverage requires PEAR Installer (version >= 1.9.4), installed version is 1.9.1
phpunit/PHP_CodeCoverage can optionally use PHP extension "xdebug" (version >= 2.0.5)
phpunit/PHPUnit_MockObject requires PEAR Installer (version >= 1.9.4), installed version is 1.9.1
phpunit/PHP_TokenStream requires PEAR Installer (version >= 1.9.4), installed version is 1.9.1
No valid packages found
install failed
Ma version de pear étant la 1.9.1, il me faut donc la mettre à jour aussi.
-> apt-get install php-pear
OK

-> pear install pear (ou pear install pear/PEAR)
pear/pear is already installed and is the same as the released version 1.9.4
install failed

-> pear version
PEAR Version: 1.9.1

Vous voyez l'erreur ? Pourquoi il ne veut pas me le mettre à jour en pré-textant qu'il l'est déjà alors que c'est pas le cas XD ?

Merci d'avance pour votre aide.