Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3

Discussion: dump via php

  1. #1
    Membre régulier
    Inscrit en
    décembre 2006
    Messages
    232
    Détails du profil
    Informations forums :
    Inscription : décembre 2006
    Messages : 232
    Points : 84
    Points
    84

    Par défaut dump via php

    Bonjour,

    Je souhaite réaliser une sauvegarde de ma base via php.

    Code :
    1
    2
    3
    4
     
    chdir('C:\Program Files\postgresql\9.0\bin');	
    echo getcwd() . "\n";
    exec('pg_dump -U postgres -w -n mon_schema mabase > E:\sauvegarde\sauv'.$date.'.sql');
    ce code semble fonctionner, j'obiens un fichiers nommé correctement dans le répertoire E:\sauvegarde cependant, le fichier obtenu est vide.
    J'ai créé un fichier pg_pass dans le répertoire de l'utilisateur cependant, cela ne change rien.

    Merci d'avance pour votre aide.

  2. #2
    Membre régulier
    Inscrit en
    décembre 2006
    Messages
    232
    Détails du profil
    Informations forums :
    Inscription : décembre 2006
    Messages : 232
    Points : 84
    Points
    84

    Par défaut

    Le problème ne semble pas venir du code php.

    J'ai supprimé le fichier pgpass.conf.
    Ouvert les possibilités de connexion via pg_hba.conf.

    Code :
    1
    2
    3
    4
    # IPv4 local connections:
    host	 all	 all	 127.0.0.1/32	 trust
    # IPv6 local connections:
    host	 all	 all	 ::1/128	 trust
    Avec ces entrées, cela fonctionne. Par contre, pour les connexions IPv6, si je mets "md5" ou que je désactive l'entrée, cela ne fonctionne plus.
    On dirait que c'est la partie IPv6 qui prime ???

    ps : Ces entrées avec la méthode md5 et un fichier pgpass.conf ne fonctionne pas !!

  3. #3
    Membre du Club
    Homme Profil pro
    Inscrit en
    mars 2005
    Messages
    67
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations forums :
    Inscription : mars 2005
    Messages : 67
    Points : 59
    Points
    59

    Par défaut

    -Je ne suis pas familier de PostgreSQL sous Windows, mais il faut sans doute définir un host via l'option -h qui correspond à la valeur du fichier .pgpass .
    -attention au nom du fichier qui est par défaut "pgpass?conf" sous Windows (et pas "pg_pass")
    -Je ne suis pas non plus sûr de l'option "-w". Normalement elle s'écrit en majuscule quand on veut au contraire forcer un prompt pour insérer la mot de passe manuellement? Mais .pgpass devrait justement la rendre caduque et il faut sans doute la supprimer.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •