IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Index du forum

Recherche:

Type: Messages; Utilisateur: 69Pierre

Page 1 sur 27 1 2 3 4

Recherche: Recherche effectuée en 0,04 secondes.

  1. Votes reçus
    +0 -0
    Réponses
    4
    Affichages
    198

    Bonjour chrtophe. Oui cette page est en fond...

    Bonjour chrtophe.

    Oui cette page est en fond d'écran sur mon PC.

    Mais pas moyen de copier d'un serveur à un autre.
    le src par défaut pour ansible, c'est mes sources gitlab.
  2. Votes reçus
    +0 -0
    Réponses
    4
    Affichages
    198

    Bonjour. Que ce soit win_robocopy: ou copy:,...

    Bonjour.

    Que ce soit win_robocopy: ou copy:, le résultat est le même : ERROR! 'win_robocopy' is not a valid attribute for a Play ou ERROR! 'copy' is not a valid attribute for a Play
  3. Votes reçus
    +0 -0
    Réponses
    14
    Affichages
    286

    [Batch] Bonjour. En fait il y a un problème que je...

    Bonjour.

    En fait il y a un problème que je n'avait vu.

    il y a bien plusieurs (2) "objets" qui commence par dossier\repertoire : un repertoire : repertoire5468454gcd et un fichier zip :...
  4. Votes reçus
    +0 -0
    Réponses
    4
    Affichages
    198

    [Ansible] : commande windows pour copier un repertoire d'un serveur à un autre

    Bonjour.

    Je n'ai pas trouvé d'Ansible pour windows, du coup, j'ai posté ici.

    Je cherche, avec ansible à copier un répertoire vers un autre :

    j'ai tenté :

    - name: Sync Files
    hosts:...
  5. Votes reçus
    +0 -0
    Réponses
    1
    Affichages
    130

    [Batch] Tester l'extension d'un fichier

    Bonjour je souhaiterai tester si l'extension d'un fichier est .zip :

    if extension_de(mon_fichier)=="*.zip*" echo mon_fichier
    Comment puis je faire ?
  6. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] Merci Barnabé. Mon problème était le "1" au...

    Merci Barnabé.

    Mon problème était le "1" au lieu du "l".
    tout rentre dans l’ordre.

    Je ferai un test de bout en bout demain.
  7. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] Du coup. Je retombe un peu sur mes pattes : ...

    Du coup.
    Je retombe un peu sur mes pattes :

    ECHO.!strl! | FIND /I "%versionOld%" > Nul && (
    Echo "%versionOld%" existe >> %logs%
    ) || (
    Echo "%versionOld%" n'existe pas >> %logs%
    )
  8. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] Désolé. Une fois la tête dans le guidon, je n'ai...

    Désolé.
    Une fois la tête dans le guidon, je n'ai pas vu que je partais en vrille.
    Merci.

    Mon
    set strl=%strl:%versionOld%=%versionNew%% me renvoie toujours la dernière ligne.
  9. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] C'est un truc de fou ce langange batch. ...

    C'est un truc de fou ce langange batch.

    Impossible de faire mes echo pour voir le contenu des variables : Commande ECHO d‚sactiv‚e.
    Sauf pour le echo %%A >> %logs%.

    incapable de modifier ma...
  10. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] Et oui. @echo off REM set /a i=0 set...

    Et oui.


    @echo off
    REM set /a i=0

    set logs="logs_creat.txt"
    if exist %logs% (del %logs%)

    REM variables pour modifier le fichier INTEGRATION.pubxml
  11. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] OK. Bon désolé, du coup ça fait le code à...

    OK.

    Bon désolé, du coup ça fait le code à re-tester :


    @echo off
    REM set /a i=0
    setlocal enabledelayedexpansion
    set logs="logs_creat.txt"
    if exist %logs% (del %logs%)
  12. Votes reçus
    +0 -0
    Réponses
    8
    Affichages
    173

    [Batch] En fait il faut mettre le setlocal en dehors de...

    En fait il faut mettre le setlocal en dehors de la boucle, au début de ton script comme l'a dit Barnabe
  13. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] C'est une horreur mon echo !str1! >> %logs%...

    C'est une horreur mon echo !str1! >> %logs% renvoie toujours Commande ECHO d‚sactiv‚e.
  14. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] Bon il y a un problème dans for /f "usebackq" %%A...

    Bon il y a un problème dans for /f "usebackq" %%A in ('type %PLversion_dev%') , echo %%A renvoie type
  15. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] Ah non! Ca renvoie : Commande ECHO d‚sactiv‚e.

    Ah non!
    Ca renvoie : Commande ECHO d‚sactiv‚e.
  16. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] C'est poussif. for /f "usebackq" %%A in ('type...

    C'est poussif.

    for /f "usebackq" %%A in ('type "%PLversion_dev%"') do (

    setlocal enabledelayedexpansion
    set "strl=%%A"

    echo !str1! >> %logs%

    endlocal
  17. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] Oui mais là, je n'ai pas encore compris comment...

    Oui mais là, je n'ai pas encore compris comment faire :
    for /f "usebackq" %%A in ('type "%PLversion_dev%"') do (

    set "strl=%%A"

    echo !str1! >> %logs%
    renvoie

    Et aprés pour faire mon
    IF...
  18. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] Je merdouille. Je parcours les lignes de mon...

    Je merdouille.

    Je parcours les lignes de mon fichier : OK

    Pour chacune des lignes, je veux :
    1-Tester si une chaine de caractères est présente
    2-Si elle est présente, remplacer cette chaine...
  19. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] OK, premiere partie réglée, je continue. if...

    OK, premiere partie réglée, je continue.


    if exist %PLversionREMtmp% del %PLversionREMtmp%
    for /f "usebackq delims=" %%A in ("%PLversion_dev%") do (

    echo.%%A >> %PLversionREMtmp%

    )
  20. Votes reçus
    +0 -0
    Réponses
    20
    Affichages
    273

    [Batch] Modifier une chaine de caractères

    Bonjour.

    Je pensais avoir compris mais je n'ai rien compris du tout.
    J'ai un fichier %PLversion_dev% dont je veux parcourir les lignes pour chercher la valeur %versionOld% puis :
    -copier la...
  21. Votes reçus
    +0 -0
    Réponses
    8
    Affichages
    173

    [Batch] Merci, j'apprends que !variable! est une variable...

    Merci, j'apprends que !variable! est une variable retardée mais j'arrive au même résultat.
    C'est pas le endlocal qui me supprime la variable ?
  22. Votes reçus
    +0 -0
    Réponses
    8
    Affichages
    173

    [Batch] [batch] : augmenter de 1 une variable dans une boucle For

    Je suis vraiment nul.
    Mon i passe 0 à 1 puis de 0 à 1, etc, il est réinitialisé à chaque tour.

    setlocal enabledelayedexpansion
    (if /i "!%1:~5,10!"=="%debut%" (echo %file_line_replace%) else...
  23. Votes reçus
    +0 -0
    Réponses
    30
    Affichages
    421

    [Batch] Ca marche, encore merci barnabe!

    Ca marche, encore merci barnabe!
  24. Votes reçus
    +0 -0
    Réponses
    8
    Affichages
    173

    [Batch] Augmenter de 1 une variable dans une boucle For

    Bonjour.

    Je ne pensais pas butter sur une valeur aussi simple :

    set /a i=0
    for /f "usebackq delims=" %%A in ("%INTEGRATIONpubxml%") do (


    echo "A32%i%" >> %logs%
  25. Votes reçus
    +0 -0
    Réponses
    30
    Affichages
    421

    [Batch] Super merci. Le résultat est bon. J'ai toujours...

    Super merci.
    Le résultat est bon.
    J'ai toujours cette erreur malgré tout.
    Je vais refaire des tests cet après midi.
Affichage des résultats 1 à 25 sur 656
Page 1 sur 27 1 2 3 4