IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Actualités Discussion :

Exécuter IE6 dans IE 8, possible grâce à un nouveau plug-in

  1. #1
    Responsable .NET

    Avatar de Hinault Romaric
    Homme Profil pro
    Consultant
    Inscrit en
    janvier 2007
    Messages
    4 570
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Consultant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : janvier 2007
    Messages : 4 570
    Points : 252 332
    Points
    252 332
    Billets dans le blog
    118
    Par défaut Exécuter IE6 dans IE 8, possible grâce à un nouveau plug-in
    Exécuter IE6 dans IE 8 ?
    C'est possible grâce à Unibrows


    La start-up Browsium a dévoilé un nouveau plug-in pour Internet Explorer 8 qui devrait permettre d’exécuter IE6 dans un onglet du navigateur.

    Le produit, baptisé « Unibrows », a été mis au point par des anciens de Microsoft.

    Unibrows a pour but de permettre aux entreprises de passer à des technologies modernes comme Windows 7 et IE8 tout en maintenant la compatibilité avec les applications Web ou métiers qui s'appuient sur IE6. Le tout, bien sûr, sans changer une seule ligne de code.

    « Les entreprises ont besoin de quelque chose de simple qui n’est pas fondée sur la virtualisation » croit savoir Matthew Heller, le PDG fondateur de Browsium.

    Selon Gartner Research, les problèmes de rétro-compatibilité avec IE6 devraient retarder la migration des projets sur Windows 7 de 20 % des entreprises. Ils devraient également engendrer des frais plus élevés que le budget prévu. Environ 40% des applications Web utilisées par les entreprises encore en cours sur IE6 ne fonctionneront pas sur IE8, navigateur livré par défaut avec Windows 7.

    Pour résoudre ces problèmes, « Unibrows s’exécute comme un processus local sur la machine », explique Matt Crowley. « Unibrows est un processus lié à IE8 qui est déclenché sur la machine suivant des règles définies par les administrateurs, à ce moment-là Unibrows swaps dans les DLL IE6 pour afficher la page ou l’application dans l’onglet IE8 ».

    Unibrows peut fonctionner sur n’importe quelle version de Windows qui supporte IE8 et prend en charge toutes les fonctionnalités d'IE6 y compris les contrôles ActiveX.

    Le beta du plug-in est disponible après inscription sur cette page


    Source : Browsium


    Et vous ?

    Ce plug-in va-t-il encourager la migration sur Windows 7 ?
    Allez-vous l'essayer (ou tenter de le faire essayer) dans votre entreprise ?


    En collaboration avec Gordon Fowler
    Vous souhaitez participer aux rubriques .NET ? Contactez-moi

    Si déboguer est l’art de corriger les bugs, alors programmer est l’art d’en faire
    Mon blog, Mes articles, Me suivre sur Twitter
    En posant correctement votre problème, on trouve la moitié de la solution

  2. #2
    Membre du Club
    Profil pro
    Développeur Java
    Inscrit en
    juin 2008
    Messages
    86
    Détails du profil
    Informations personnelles :
    Âge : 39
    Localisation : Belgique

    Informations professionnelles :
    Activité : Développeur Java

    Informations forums :
    Inscription : juin 2008
    Messages : 86
    Points : 69
    Points
    69
    Par défaut
    Mauvaise idée !!
    Il faudrait interdire ie6. Si on continue à supporter ce langage on aide à ce qu'il persiste chez les utilisateurs.
    Les obliger à faire un upgrade du browser, vers le 8 ou le 9.

    Sinon il continuera à pourrir la vie aux développeurs pendant des années.

  3. #3
    Membre habitué
    Profil pro
    Inscrit en
    juin 2004
    Messages
    72
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2004
    Messages : 72
    Points : 150
    Points
    150
    Par défaut
    Citation Envoyé par Manau2000 Voir le message
    Mauvaise idée !!
    Il faudrait interdire ie6. Si on continue à supporter ce langage on aide à ce qu'il persiste chez les utilisateurs.
    Les obliger à faire un upgrade du browser, vers le 8 ou le 9.

    Sinon il continuera à pourrir la vie aux développeurs pendant des années.
    Le principe de ce plugin n'est pas d'aider les développeurs à développer pour IE6.

    Ça va au contraire, selon moi, inciter les migrations vers les Windows les plus récents.
    Ceci permettra au entreprise de continuer à utiliser les applications compatibles IE6 sans devoir refaire ces applications, donc pas de coût supplémentaire.

    En tant que développeur Web, tu es gagnant. On s'en fou qu'ils utilisent encore des trucs pour IE6, le principal est qu'ils aient un navigateur à jour. ce qui te permet de ne plus développer en faisant attention à ce que sous IE6 tout fonctionne.

  4. #4
    Nouveau membre du Club
    Inscrit en
    février 2010
    Messages
    12
    Détails du profil
    Informations forums :
    Inscription : février 2010
    Messages : 12
    Points : 26
    Points
    26
    Par défaut
    très très très bonne chose

    ça pourrait permettre aux entreprises d'enfin migrer leur parc informatique sans devoir débourser des millions pour refondre leurs applications ne tournant que sur ie6

    j'adore les anciens de microsoft qui vont se faire des thunes sur le dos de leur ancien employeur

  5. #5
    Membre habitué

    Homme Profil pro
    Concepteur d'applications web
    Inscrit en
    avril 2003
    Messages
    102
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 46
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Concepteur d'applications web
    Secteur : Communication - Médias

    Informations forums :
    Inscription : avril 2003
    Messages : 102
    Points : 133
    Points
    133
    Par défaut
    Excellente îdée, comme ça on gardera les super backdoors d'IE6 sur windows 7.
    Et en plus, rien ne garantie la sécurité d'unibrows...

  6. #6
    Membre actif
    Homme Profil pro
    Développeur
    Inscrit en
    décembre 2008
    Messages
    101
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur

    Informations forums :
    Inscription : décembre 2008
    Messages : 101
    Points : 255
    Points
    255
    Par défaut modernité
    "des technologies modernes comme Windows 7 et IE8"

    Ha! Ha !....

    --------> []

  7. #7
    Membre chevronné Avatar de Hellwing
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    avril 2008
    Messages
    537
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : avril 2008
    Messages : 537
    Points : 2 031
    Points
    2 031
    Par défaut
    Citation Envoyé par rebolon Voir le message
    Excellente îdée, comme ça on gardera les super backdoors d'IE6 sur windows 7.
    Et en plus, rien ne garantie la sécurité d'unibrows...
    J'ose espérer que justement les contrôles d'IE8 serviront de filet de sécurité à ce plugin pour empêcher les failles d'IE6 d'être exploitées.

    M'enfin je me doute bien que c'est bien plus facile à dire qu'à faire.

  8. #8
    Nouveau membre du Club
    Profil pro
    Inscrit en
    septembre 2007
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : septembre 2007
    Messages : 12
    Points : 30
    Points
    30
    Par défaut
    Je vois pas ou est le problème du cout, rien n'empêche quelqu'un de charger une nouvelle version d'IE sans changer de machine...

    Mais c'est vrai que mise à part ça, je pense que ce n'est pas une bonne idée... les gens vont trainer des brouettes et se plaindre en disant, "Tiens, je comprend pas, ça fonctionne pas !!"

  9. #9
    Membre averti
    Inscrit en
    novembre 2006
    Messages
    120
    Détails du profil
    Informations forums :
    Inscription : novembre 2006
    Messages : 120
    Points : 314
    Points
    314
    Par défaut
    « Les entreprises ont besoin de quelque chose de simple qui n’est pas fondée sur la virtualisation » croit savoir Matthew Heller, le PDG fondateur de Browsium.
    lol, il a pas tort pourtant
    Développeur / Formateur
    Tutoriels AngularJS / Node.js sur ma chaîne Youtube : http://www.youtube.com/user/DevDuFutur

  10. #10
    Membre chevronné Avatar de Hellwing
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    avril 2008
    Messages
    537
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : avril 2008
    Messages : 537
    Points : 2 031
    Points
    2 031
    Par défaut
    Citation Envoyé par Jonathan38 Voir le message
    Je vois pas ou est le problème du cout, rien n'empêche quelqu'un de charger une nouvelle version d'IE sans changer de machine..."
    Non, le coût vient de l'adaptation des applications IE6 existantes aux normes et exigences d'IE8, pas au changement des postes de travail.

    Mon client effectue actuellement une étude sur le passage d'IE6 vers IE8. Nous en tant que développeurs on doit s'assurer que les applications tourneront toujours aussi bien... Et évidemment on va devoir les remettre à niveau, tout retester, repasser sur tous les écrans etc., ce qui risque de prendre du temps et de coûter cher.
    Ce plugin permettrait dans ce cas-là de garder les applications existantes sous IE6, MAIS de développer les futures applications sous IE8.

    Comme ça on ne s'embête pas avec a compatibilité de l'existant et on a accès aux technologies plus récentes pour les applications à venir (au lieu de les créer sciemment pour un navigateur obsolète)

  11. #11
    ILP
    ILP est déconnecté
    Membre confirmé
    Avatar de ILP
    Homme Profil pro
    Analyste programmeur
    Inscrit en
    mai 2002
    Messages
    257
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Finistère (Bretagne)

    Informations professionnelles :
    Activité : Analyste programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2002
    Messages : 257
    Points : 574
    Points
    574
    Par défaut
    Euh, pourquoi réinventer la roue ? Cette fonction existe déjà dans Internet Explorer. Il suffit de mettre la balise :
    Code HTML : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    <!-- Mimic Internet Explorer 7 -->
    <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" >
     
    <meta http-equiv="X-UA-Compatible" content="IE=4">   <!-- IE5 mode -->
    <meta http-equiv="X-UA-Compatible" content="IE=7.5"> <!-- IE7 mode -->
    <meta http-equiv="X-UA-Compatible" content="IE=100"> <!-- IE8 mode -->
    <meta http-equiv="X-UA-Compatible" content="IE=a">   <!-- IE5 mode -->
    dans l'en-tête HTML.

  12. #12
    Nouveau Candidat au Club
    Inscrit en
    juillet 2009
    Messages
    15
    Détails du profil
    Informations forums :
    Inscription : juillet 2009
    Messages : 15
    Points : 0
    Points
    0
    Par défaut
    Très mauvaise idée, IE6 est obsolète et ne devrait donc plus etre suporté. Ce genre d'initiative ne fera que retarder la migration.

    Ce plugin rencontrera surement un peu de succès, pour les devs voulant une "parfaite" compatibilité, et si ce plugin n'est pas compatible IE9, alors se sera encore plus difficile de faire migrer les personnes utilisant IE8, qui est déjà légèrement obsolète ...

  13. #13
    Membre éprouvé
    Profil pro
    Inscrit en
    juillet 2010
    Messages
    657
    Détails du profil
    Informations personnelles :
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : juillet 2010
    Messages : 657
    Points : 1 237
    Points
    1 237
    Par défaut
    intéressant , merci !
    Très mauvaise idée, IE6 est obsolète et ne devrait donc plus etre suporté. Ce genre d'initiative ne fera que retarder la migration.
    je pense que le métier de dev n'est pas de choisir sur quel navigateur le client doit regarder son app , mais plus d'être compatible avec le plus grand nombre de nav pour toucher le plus de monde, si ta cible tourne sous ie6 , il faut faire en sorte que ... maintenant si tu cibles du geek sur ipad, tu t'en fous bien évidement. Je me souviens d'un projet de refonte ou 20% des 10 000 visiteurs quotidiens utilisaient ie6 voir 5.5 ... on fait faire perdre 20% de chiffre à la boite qui paie le projet parce qu'on est IN et qu'on fait que du nec plus ultra HTML5 ? non bien sur.

  14. #14
    Modérateur
    Avatar de Flaburgan
    Homme Profil pro
    Développeur Web
    Inscrit en
    avril 2010
    Messages
    1 229
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : avril 2010
    Messages : 1 229
    Points : 3 551
    Points
    3 551
    Par défaut
    Je pense que ce n'est pas une si mauvaise chose. J'ai eu la surprise de recevoir dernièrement un pc neuf de mon entreprise (STMicroelectronics), qui a été reformaté de windows 7 a Xp avec ie6. Quand j'ai posé la question, on m'a répondu que certaines appli de développé à la boite nécessitait IE6 pour fonctionner. Comme on a pas le temps et le budget pour redev ces applis, on garde IE6, et donc on garde Xp. Conclusion, tout est retardé pour une histoire de compatibilité, qui pourrait être résolu par ce plugin.

    Après effectivement si c'est pour garder les failles de sécurité d'IE6...
    "Historiquement, techniquement, économiquement et moralement, Internet ne peut pas être contrôlé. Autant s’y faire." Laurent Chemla

    Je soutiens Diaspora*, le réseau social libre.

    Veillez à porter une attention toute particulière à l'orthographe...

    Blog collaboratif avec des amis : http://geexxx.fr

    Mon avatar a été fait par chiqitos, merci à lui !

Discussions similaires

  1. PB exécution insertion dans sql server
    Par Yanmeunier dans le forum VB 6 et antérieur
    Réponses: 3
    Dernier message: 21/11/2005, 17h44
  2. [HTML] Charger une page dans un tableau? Possible?
    Par mec.nimois dans le forum Balisage (X)HTML et validation W3C
    Réponses: 4
    Dernier message: 17/10/2005, 12h32
  3. Réponses: 4
    Dernier message: 01/02/2005, 22h08
  4. 2 champs dans un where , possible en sql server ?
    Par voyageur dans le forum MS SQL Server
    Réponses: 10
    Dernier message: 19/10/2004, 06h01
  5. Réponses: 5
    Dernier message: 03/02/2004, 15h20

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo