IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

OpenCL Discussion :

Installation Windows avec MinGW


Sujet :

OpenCL

  1. #1
    Membre habitué
    Avatar de Aladore
    Profil pro
    Étudiant
    Inscrit en
    avril 2009
    Messages
    70
    Détails du profil
    Informations personnelles :
    Âge : 34
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : avril 2009
    Messages : 70
    Points : 144
    Points
    144
    Par défaut Installation Windows avec MinGW
    Bonjour!

    Est-ce que quelqu'un a déjà réussi à installer OpenCL sous Windows avec MinGW ? Parce que j'ai cherché sur le net, mais je ne trouve pas le .a, juste le .lib. J'ai vu qu'on pouvait convertir un .lib en .a via les tools de MinGW, cependant je ne dispose pas de OpenCL.dll ...

    J'ai regardé dans le SDK de CUDA (que j'ai installé), mais pas moyen de trouver cette DLL!

    Bref, quelqu'un a déjà réussi à l'installer ?

  2. #2
    Membre confirmé Avatar de TNT89
    Inscrit en
    juillet 2007
    Messages
    358
    Détails du profil
    Informations personnelles :
    Âge : 33

    Informations forums :
    Inscription : juillet 2007
    Messages : 358
    Points : 613
    Points
    613
    Par défaut
    Salut,

    Oui et ça a l'air de fonctionner (Win 7 - x64)...

    Alors pour l'installation avec une NVidia, il suffit d'installer le SDK de CUDA.

    Ensuite, j'ai utilisé reimp.exe qui se trouve dans MingW/bin avec :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    reimp.exe C:\CUDA\lib\OpenCL.lib
    (enfin selon le répertoire d'installation de CUDA)

    Deux nouveaux fichiers seront créés : OpenCL.def & libopencl.a
    que j'ai remis dans C:\CUDA\lib\.

    Enfin :
    et d'inclure la librairie à la compilation...

    Par contre la DLL est inconnue au bataillon, mais ça ne doit pas être embêtant pour une Lib statique...

    Voili voilou...

  3. #3
    Membre habitué
    Avatar de Aladore
    Profil pro
    Étudiant
    Inscrit en
    avril 2009
    Messages
    70
    Détails du profil
    Informations personnelles :
    Âge : 34
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : avril 2009
    Messages : 70
    Points : 144
    Points
    144
    Par défaut
    Hello TNT89,

    Ouais je suis tombé sur un site proposant ta solution (utiliser reimp), le soucis c'est que chez moi reimp.exe me sort une belle erreur et donc je suis bloqué à cette étape:

    reimp.exe: C:\Cuda\lib\OpenCL.lib: invalid or corrupt import library.

    Je suis également sous Win64 -x64, est-ce que ça te dérangerait de me filer le .a et le .def que t'a généré reimp.exe ? Je ne sais pas si ça peut marcher, mais qui ne tente rien n'a rien.

    Merci d'avance!


    Edit:
    -----

    Bon après avoir eu une idée que j'aurais du avoir avant: télécharger une ancienne version de reimp, ça marche j'ai mon .a. Par contre j'ai bien l'erreur suivante que je redoutais: OpenCL.dll manquante.
    J'avais lu que normalement sur une carte graphique NVIDIA c'était la DLL responsable de Cuda qui devait être utilisé, est-ce que ça peut provenir de la version de mon SDK ?

  4. #4
    Membre confirmé Avatar de TNT89
    Inscrit en
    juillet 2007
    Messages
    358
    Détails du profil
    Informations personnelles :
    Âge : 33

    Informations forums :
    Inscription : juillet 2007
    Messages : 358
    Points : 613
    Points
    613
    Par défaut
    Essaye peut-être de réinstaller Cuda seul, puis le SDK (je ne pense pas que ce soit le SDK qui apporte la DLL)...


    (personnellement, j'ai bien cette DLL sur mon C: mais je n'arrive pas à la retrouver dans les appels de mes programmes tests)

  5. #5
    Membre habitué
    Avatar de Aladore
    Profil pro
    Étudiant
    Inscrit en
    avril 2009
    Messages
    70
    Détails du profil
    Informations personnelles :
    Âge : 34
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : avril 2009
    Messages : 70
    Points : 144
    Points
    144
    Par défaut
    Bon j'ai trouvé la solution, je la poste ici même si ça va concerner qu'un faible nombre de personne.

    Je possède un laptop qui a la technologie Optimus, c'est une technologie qui permet de switcher entre une carte graphique de faible performance et une NVIDIA. Bref, si on essaye d'exécuter du code Cuda, le switch se fait automatiquement. Par contre pour OpenCL ce n'est pas si automatique que ça: il faut exécuter l'application en spécifiant qu'on utilise bien la carte graphique NVIDIA.

    Du coup je pense que ça vient bien du driver qui lorsqu'il voit un appel à OpenCL.dll va switcher sur du Cuda non ? Je mets le thread en résolu!

  6. #6
    Membre habitué
    Profil pro
    Inscrit en
    février 2011
    Messages
    147
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations forums :
    Inscription : février 2011
    Messages : 147
    Points : 180
    Points
    180
    Par défaut
    Bonjour,

    J'ai moi aussi un problème avec libopencl.a.
    Au moment du link, le compilateur me sort : file not recognized: File truncated.
    J'ai pourtant bien créé ces deux fichiers avec reimp.exe de Mingw, mais pas moyen de résoudre ce message d'erreur.

    Comme je suis sur un windows 7/64 j'ai deux répertoires dans cuda\lib, un pour les 32 bits et un pour les 64, j'ai effectuer le test avec les deux avec le même résultat.

    Mon IDE est codeblock, mais je doute que le problème vienne de là.

    Si quelqu'un a une idée.
    Merci d'avance.

    [edit] Je n'avais pas fait attention, mais le fichier libopencl.a est vide, alors que reimp.exe dit l'avoir créé sans problème.
    [/edit]

  7. #7
    Membre à l'essai
    Profil pro
    Inscrit en
    avril 2007
    Messages
    21
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 21
    Points : 21
    Points
    21
    Par défaut
    Salut !

    Je ne sais pas si çà peut te convenir, mais j'ai fais un petit tuto pour préparer Code::Blocks à la compilation OpenCL. Je l'ai fait avec les lib ATI, mais il semble que les différences ne soient que dans les dossiers. Voici le lien http://www.alexandreobellianne.fr/tu...codeblocks.php

    S'il y a des questions, n'hésite pas ;-)

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Installer SDL avec MinGW et la console Windows
    Par doowy38 dans le forum SDL
    Réponses: 1
    Dernier message: 05/10/2009, 06h29
  2. Installer Boost avec Mingw
    Par Mawine dans le forum Autres éditeurs
    Réponses: 1
    Dernier message: 10/12/2008, 11h19
  3. Installation Windows avec double coeur
    Par helios77 dans le forum Composants
    Réponses: 4
    Dernier message: 18/07/2008, 09h24
  4. Installation SDL avec minGW et Eclipse
    Par Shadow-rebirth dans le forum Eclipse C & C++
    Réponses: 4
    Dernier message: 27/03/2008, 20h55

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo