IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Ruby on Rails Discussion :

Sortie de Redmine 1.0.5, le gestionnaire de projet basé sur Ruby on Rails


Sujet :

Ruby on Rails

  1. #21
    Membre expert
    Avatar de Klaim
    Homme Profil pro
    Développeur de jeux vidéo
    Inscrit en
    août 2004
    Messages
    1 717
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur de jeux vidéo
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 1 717
    Points : 3 290
    Points
    3 290
    Par défaut
    Est-ce qu'ils comptent améliorer un jour les modifications de hierarchie de ticket?

  2. #22
    Responsable Qt & Livres


    Avatar de dourouc05
    Homme Profil pro
    Ingénieur de recherche
    Inscrit en
    août 2008
    Messages
    26 168
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur de recherche
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2008
    Messages : 26 168
    Points : 185 922
    Points
    185 922
    Par défaut
    Qu'est-ce qui ne te plaît pas dans la version actuelle ?
    Vous souhaitez participer aux rubriques Qt (tutoriels, FAQ, traductions) ou HPC ? Contactez-moi par MP.

    Créer des applications graphiques en Python avec PyQt5
    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

  3. #23
    Membre expert
    Avatar de Klaim
    Homme Profil pro
    Développeur de jeux vidéo
    Inscrit en
    août 2004
    Messages
    1 717
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur de jeux vidéo
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 1 717
    Points : 3 290
    Points
    3 290
    Par défaut
    N'importe quel ticket ne peut pas devenir parent ou fils de n'importe quel autre ticket, du moins pas dans l'interface que j'ai sous les yeux...
    Il y a des tickets qui disent que c'est dans l'interface mais je n'ai jamais vu le champs dont ils parlent.

    Je me trompe? (j'espere...)

  4. #24
    Rédacteur

    Avatar de Matthieu Brucher
    Profil pro
    Développeur HPC
    Inscrit en
    juillet 2005
    Messages
    9 810
    Détails du profil
    Informations personnelles :
    Âge : 40
    Localisation : France, Pyrénées Atlantiques (Aquitaine)

    Informations professionnelles :
    Activité : Développeur HPC
    Secteur : Industrie

    Informations forums :
    Inscription : juillet 2005
    Messages : 9 810
    Points : 20 967
    Points
    20 967
    Par défaut
    Je crois que je vais faire migrer ma 0.9 vers cette version dans les prochains jours...
    Merci pour la news !

  5. #25
    Responsable Qt & Livres


    Avatar de dourouc05
    Homme Profil pro
    Ingénieur de recherche
    Inscrit en
    août 2008
    Messages
    26 168
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur de recherche
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2008
    Messages : 26 168
    Points : 185 922
    Points
    185 922
    Par défaut
    Redmine 1.0.2 vient de sortir, il s'agit de la première série de correction de bogues depuis la sortie de la version finale, la 1.0.1.

    Au menu de cette version, la correction d'une série de bogues (53 précisément) : cette version est donc "très stable", pour reprendre les mots d'Éric Davis, Release Manager de Redmine, qui n'ont pas changé depuis Redmine 1.0.1.

    Notez qu'il n'y a pas encore de correction prévue pour Redmine 1.0.3, alors que certaines étaient prévues depuis un an et sont finalement arrivées pour Redmine 1.0.2.

    Source : http://www.redmine.org/news/44

    Voir aussi

    La rubrique Ruby & Ruby on Rails de Developpez.com
    L'hébergement des projets Developpez.com

    Et vous ?

    Êtes-vous toujours sur Redmine 0.9.x ? Pourquoi restez-vous sur cette vieille version ?
    Vous souhaitez participer aux rubriques Qt (tutoriels, FAQ, traductions) ou HPC ? Contactez-moi par MP.

    Créer des applications graphiques en Python avec PyQt5
    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

  6. #26
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    223
    Détails du profil
    Informations personnelles :
    Localisation : France, Isère (Rhône Alpes)

    Informations forums :
    Inscription : mars 2002
    Messages : 223
    Points : 450
    Points
    450
    Par défaut
    moi je trouvais la v0.9.x deja très stable, alors là ... ça semble impec !

    La migration de la v0.9.x à la V1.01 n'avait pas posée de problème, je vais franchir le pas cette semaine, ce sera fait

    Ca fait du bien de voir des produits "finis" et stable qui respecte la roadmap (le contenu j'entends).
    Ca change des jeux video (paf le troll).
    Delphi + JavaDoc = DelphiCodeToDoc
    http://dephicodetodoc.sourceforge.net/

    TridenT Dev blog
    http://tridentjob.blogspot.fr/

  7. #27
    Membre régulier
    Homme Profil pro
    Inscrit en
    septembre 2006
    Messages
    64
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : septembre 2006
    Messages : 64
    Points : 78
    Points
    78
    Par défaut
    Erf, je viens d'effectuer une migration 0.8.* à 1.0.1... et la 1.0.2 sort
    A part 2 plugins incompatibles (Graph je crois et un autre qui est maintenant intégré à Redmine, pas trop d'incompatibilité). Avoir les versions requises de Ruby et autres libs sur CentOS et la config apache avec fastcgi c'est par contre une autre histoire

    J'ai beaucoup utilisé Assembla et Trac, je dois dire que Redmine c'est vraiment le must en comparaison.

  8. #28
    Responsable Qt & Livres


    Avatar de dourouc05
    Homme Profil pro
    Ingénieur de recherche
    Inscrit en
    août 2008
    Messages
    26 168
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur de recherche
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2008
    Messages : 26 168
    Points : 185 922
    Points
    185 922
    Par défaut
    Redmine 1.0.3 est sorti il y a peu, début novembre. Comme les versions précédentes, il ne s'agit ici que d'une correction de bogues... 35, comme compte si bien Eric Davis, Release Manager de Redmine.

    Cependant, quelque chose d'un peu étonnant était à remarquer lors de la sortie de cette version... Étant donné que je suis l'actualité de Redmine d'assez loin, je n'ai pas regardé l'avancement des tâches tous les jours... mais je fus assez étonné de remarquer que, quelques jours avant la sortie de cette version, aucune tâche n'était marquée résolue ! Faut-il y voir un signe ? Les développeurs s'orienteraient-ils plus vers Redmine 1.1.0, version toujours prévue pour la fin décembre 2010 ?

    Petite note en passant : juste après la sortie de Redmine 1.0.3, un nouveau répertoire de plug-ins a été mis en place sur le site, remplaçant la vieillissante liste de plug-ins. Il était bien temps, Redmine disposant de plus en plus de plug-ins à afficher... Comment remarquer les nouveautés ? Ce problème est maintenant résolu !

    Remarquez que les scripts Redmine.pm et reposman.rb ont été mis à jour ; si vous les utilisez pour une intégration avancée avec Subversion (qui permet la création de repositories depuis Redmine, notamment), vérifiez bien que vous mettez tout ce qu'il faut bien à jour.

    Sources : http://www.redmine.org/news/45 et http://www.redmine.org/news/46

    Voir aussi

    La rubrique Ruby & Ruby on Rails de Developpez.com
    L'hébergement des projets Developpez.com
    Vous souhaitez participer aux rubriques Qt (tutoriels, FAQ, traductions) ou HPC ? Contactez-moi par MP.

    Créer des applications graphiques en Python avec PyQt5
    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

  9. #29
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    223
    Détails du profil
    Informations personnelles :
    Localisation : France, Isère (Rhône Alpes)

    Informations forums :
    Inscription : mars 2002
    Messages : 223
    Points : 450
    Points
    450
    Par défaut
    Merci dourouc05 pour ces infos.
    La liste des plugins est bien fournies ... c'est bon signe
    Delphi + JavaDoc = DelphiCodeToDoc
    http://dephicodetodoc.sourceforge.net/

    TridenT Dev blog
    http://tridentjob.blogspot.fr/

  10. #30
    Membre expérimenté Avatar de Firwen
    Profil pro
    Inscrit en
    juin 2009
    Messages
    472
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations forums :
    Inscription : juin 2009
    Messages : 472
    Points : 1 539
    Points
    1 539
    Par défaut
    Toujours aussi bon

    Seul problème inhérant à Rubis et non à redmine, ça supporte assez mal la charge
    It's not a bug, it's a feature

  11. #31
    Membre expert
    Avatar de Klaim
    Homme Profil pro
    Développeur de jeux vidéo
    Inscrit en
    août 2004
    Messages
    1 717
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur de jeux vidéo
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 1 717
    Points : 3 290
    Points
    3 290
    Par défaut
    Même avec la derniere implémentation de ruby?

  12. #32
    Responsable Qt & Livres


    Avatar de dourouc05
    Homme Profil pro
    Ingénieur de recherche
    Inscrit en
    août 2008
    Messages
    26 168
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur de recherche
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2008
    Messages : 26 168
    Points : 185 922
    Points
    185 922
    Par défaut
    Redmine n'est compatible qu'avec Ruby 1.8.{6,7}, ce qui limite fortement les possibilités. Ce n'est pourtant pas Rails qui est limitant à ce niveau, apparemment... Une idée si Redmine 1.1.x va supporter Ruby 1.9 ? Ça risque pourtant d'être utile, niveau perfs, apparemment, pour des gros utilisateurs...
    Vous souhaitez participer aux rubriques Qt (tutoriels, FAQ, traductions) ou HPC ? Contactez-moi par MP.

    Créer des applications graphiques en Python avec PyQt5
    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

  13. #33
    Responsable Qt & Livres


    Avatar de dourouc05
    Homme Profil pro
    Ingénieur de recherche
    Inscrit en
    août 2008
    Messages
    26 168
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur de recherche
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2008
    Messages : 26 168
    Points : 185 922
    Points
    185 922
    Par défaut
    Redmine 1.0.4 vient de sortir, il y a à peine quelques heures. Quinze bogues ont été corrigés, sept traductions ont été mises à jour ; selon la formule désormais consacrée... eh non, cette fois, c'est Jean-Philippe Lang, initiateur du projet, qui a fait l'annonce de cette version, nous n'aurons donc pas de « so this this should be a very stable release. Upgrading is recommended for all 0.9.x and 1.0.0 users. ». Il était assez absent ces derniers mois, a fait surface lors de la sortie précédente de Redmine et semble maintenant vouloir se remettre dans le projet.

    Pour le meilleur comme pour le pire ?

    Source : http://www.redmine.org/news/47 et http://www.redmine.org/news/46

    Voir aussi

    La rubrique Ruby & Ruby on Rails de Developpez.com
    L'hébergement des projets Developpez.com
    Vous souhaitez participer aux rubriques Qt (tutoriels, FAQ, traductions) ou HPC ? Contactez-moi par MP.

    Créer des applications graphiques en Python avec PyQt5
    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

  14. #34
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    223
    Détails du profil
    Informations personnelles :
    Localisation : France, Isère (Rhône Alpes)

    Informations forums :
    Inscription : mars 2002
    Messages : 223
    Points : 450
    Points
    450
    Par défaut
    j'aime les developpements aussi réactifs !
    Et la v1.1.0 arrive bienôt ... ~70% de fini !
    Delphi + JavaDoc = DelphiCodeToDoc
    http://dephicodetodoc.sourceforge.net/

    TridenT Dev blog
    http://tridentjob.blogspot.fr/

  15. #35
    Responsable Qt & Livres


    Avatar de dourouc05
    Homme Profil pro
    Ingénieur de recherche
    Inscrit en
    août 2008
    Messages
    26 168
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur de recherche
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2008
    Messages : 26 168
    Points : 185 922
    Points
    185 922
    Par défaut
    La veille de Noël, le 23 décembre, est sortie une nouvelle version de Redmine 1.0, la 1.0.5. Qu'apportait donc Jean-Philippe Lang dans sa hotte ? Peu de choses : onze bogues corrigés, l'incompatibilité avec i18n 0.5.0 est corrigée (la version 0.4.2 est maintenant requise), en plus de trois failles de sécurité corrigées.

    Notons également que Redmine 1.1, initialement prévu pour le 31 de ce mois, a été reporté de neuf jours, soit le 9 janvier de la nouvelle année. 95 % du total sont déjà achevés, la nouvelle version arrivera-t-elle comme prévu ?

    En avril, nous devrions avoir droit à Redmine 1.2, qui devrait changer un peu les prérequis car elle passera à Rails 2.3.10 - à quand Rails 3 ?

    Source : http://www.redmine.org/news/49

    Voir aussi

    La rubrique Ruby & Ruby on Rails de Developpez.com
    L'hébergement des projets Developpez.com
    Vous souhaitez participer aux rubriques Qt (tutoriels, FAQ, traductions) ou HPC ? Contactez-moi par MP.

    Créer des applications graphiques en Python avec PyQt5
    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

Discussions similaires

  1. Réponses: 24
    Dernier message: 18/02/2015, 13h05
  2. Réponses: 0
    Dernier message: 10/01/2011, 16h51

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo