Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eclipse Platform Discussion :

Erreur lors de "Export Product"


Sujet :

Eclipse Platform

  1. #1
    Membre du Club
    Profil pro
    Inscrit en
    septembre 2009
    Messages
    49
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : septembre 2009
    Messages : 49
    Points : 43
    Points
    43
    Par défaut Erreur lors de "Export Product"
    Bonjour,

    J'aimerais générer un produit RCP pour win32*86 et linux gtk36*86.
    Pour cela j'ai ajouté dans ma target Platform le delta-pack correspondant à ma version eclipse (3.5SR1).
    Pour générer le produit j'ai coché :
    - Export source (Include source in exported plugins)
    - Export for multiple platforms.

    J'ai l'erreur suivante :

    D:\Projet_V2\BUILD_WS\.metadata\.plugins\org.eclipse.pde.core\temp\org.eclipse.pde.container.feature\assemble.org.eclipse.pde.container.feature.linux.gtk.x86.xml:98: java.lang.NullPointerException
    at org.eclipse.pde.internal.build.tasks.BrandTask.execute(BrandTask.java:48)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
    at sun.reflect.GeneratedMethodAccessor1231.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.Task.perform(Task.java:348)
    at org.apache.tools.ant.Target.execute(Target.java:357)
    at org.apache.tools.ant.Target.performTasks(Target.java:385)
    at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
    at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
    at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
    at org.eclipse.ant.internal.core.ant.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:32)
    at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
    at org.eclipse.ant.internal.core.ant.InternalAntRunner.run(InternalAntRunner.java:622)
    at org.eclipse.ant.internal.core.ant.InternalAntRunner.run(InternalAntRunner.java:455)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.eclipse.ant.core.AntRunner.run(AntRunner.java:378)
    at org.eclipse.pde.internal.core.exports.FeatureExportOperation.runScript(FeatureExportOperation.java:422)
    at org.eclipse.pde.internal.core.exports.FeatureExportOperation.doExport(FeatureExportOperation.java:279)
    at org.eclipse.pde.internal.core.exports.ProductExportOperation.run(ProductExportOperation.java:105)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
    Caused by: java.lang.NullPointerException
    at java.io.FileInputStream.<init>(FileInputStream.java:103)
    at org.eclipse.pde.internal.build.Utils.copy(Utils.java:408)
    at org.eclipse.pde.internal.build.BrandingIron.brandLinux(BrandingIron.java:106)
    at org.eclipse.pde.internal.build.BrandingIron.brand(BrandingIron.java:74)
    at org.eclipse.pde.internal.build.tasks.BrandTask.execute(BrandTask.java:46)
    ... 24 more
    --- Nested Exception ---
    java.lang.NullPointerException
    at java.io.FileInputStream.<init>(FileInputStream.java:103)
    at org.eclipse.pde.internal.build.Utils.copy(Utils.java:408)
    at org.eclipse.pde.internal.build.BrandingIron.brandLinux(BrandingIron.java:106)
    at org.eclipse.pde.internal.build.BrandingIron.brand(BrandingIron.java:74)
    at org.eclipse.pde.internal.build.tasks.BrandTask.execute(BrandTask.java:46)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
    at sun.reflect.GeneratedMethodAccessor1231.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.Task.perform(Task.java:348)
    at org.apache.tools.ant.Target.execute(Target.java:357)
    at org.apache.tools.ant.Target.performTasks(Target.java:385)
    at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
    at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
    at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
    at org.eclipse.ant.internal.core.ant.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:32)
    at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
    at org.eclipse.ant.internal.core.ant.InternalAntRunner.run(InternalAntRunner.java:622)
    at org.eclipse.ant.internal.core.ant.InternalAntRunner.run(InternalAntRunner.java:455)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.eclipse.ant.core.AntRunner.run(AntRunner.java:378)
    at org.eclipse.pde.internal.core.exports.FeatureExportOperation.runScript(FeatureExportOperation.java:422)
    at org.eclipse.pde.internal.core.exports.FeatureExportOperation.doExport(FeatureExportOperation.java:279)
    at org.eclipse.pde.internal.core.exports.ProductExportOperation.run(ProductExportOperation.java:105)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
    Avez-vous une idée de ce qui peut entrainer cette erreur (plugin manquant ....) ?

    Merci

  2. #2
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 468
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 46
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 468
    Points : 17 033
    Points
    17 033
    Par défaut
    Bonjour,

    As-tu bien indiqué un icône pour tes deux plate-formes cibles ?
    Il me semble bien que c'est ce même problème que j'ai eu également, simplement à cause de l'icône manquant.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  3. #3
    Membre du Club
    Profil pro
    Inscrit en
    septembre 2009
    Messages
    49
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : septembre 2009
    Messages : 49
    Points : 43
    Points
    43
    Par défaut
    Merci, il manquait bien une icône pour linux.

  4. #4
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 468
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 46
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 468
    Points : 17 033
    Points
    17 033
    Par défaut
    Ben t'as de la chance parce que moi, j'ai cherché pendant longtemps sans rien trouver et c'est de façon empirique que j'ai fini par trouver
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [RCP]Erreur lors de l'export du product
    Par Cpt Anderson dans le forum Eclipse Platform
    Réponses: 3
    Dernier message: 12/12/2006, 16h07
  2. erreur lors d'un export simple d'Access vers Excel
    Par Armagnak dans le forum Access
    Réponses: 4
    Dernier message: 18/08/2006, 09h33
  3. Réponses: 3
    Dernier message: 07/12/2005, 14h28
  4. [msg d'erreur] lors d'un export
    Par Cyber@l dans le forum Eclipse Java
    Réponses: 4
    Dernier message: 01/07/2004, 09h55

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo