Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Dvp.NET Discussion :

Quels sont les pré-requis ?


Sujet :

Dvp.NET

  1. #1
    Rédacteur

    Quels sont les pré-requis ?
    Salut,
    j'aimerais connaître les pré-requis pour utiliser ces classes.

    N'ayant pas pris le temps de le tester, est-il possible d'utiliser une seule classe, par exemple ReadOnlyDictionary, sans avoir à charger + assemblies dépendents (usage sous PowerShell) ?
    Merci.

  2. #2
    Rédacteur/Modérateur

    Citation Envoyé par Laurent Dardenne Voir le message
    est-il possible d'utiliser une seule classe, par exemple ReadOnlyDictionary, sans avoir à charger + assemblies dépendents (usage sous PowerShell) ?
    Salut,

    Cette classe est définie dans l'assembly "principal" Developpez.Dotnet.dll, qui ne dépend d'aucun autre assembly (mis à part ceux du .NET framework bien sûr). Donc tu n'as rien d'autre à charger que cet assembly

    Si c'est déjà trop, tu peux prendre le code de la classe et le mettre ailleurs...

  3. #3
    Rédacteur

    Merci.
    Citation Envoyé par tomlev

    Si c'est déjà trop, tu peux prendre le code de la classe et le mettre ailleurs...
    C'est une possibilité, mais en cas de correction je dois refaire le travail.

    Et pour cette question :
    Citation Envoyé par Laurent Dardenne Voir le message

    j'aimerais connaître les pré-requis pour utiliser ces classes.
    Quelle version minimum du framework et du compilateur C# sont nécessaires ?

  4. #4
    Rédacteur/Modérateur

    Citation Envoyé par Laurent Dardenne Voir le message
    Merci.

    C'est une possibilité, mais en cas de correction je dois refaire le travail.

    Et pour cette question :

    Quelle version minimum du framework et du compilateur C# sont nécessaires ?
    Ben la lib est compilée en 3.5 et utilise assez massivement Linq, donc il faut au moins la version 3.5 si tu veux l'utiliser telle quelle. Si tu récupères juste la classe qui t'intéresse, elle doit fonctionner sans problème en 2.0 a priori

  5. #5
    Rédacteur

    Merci.

###raw>template_hook.ano_emploi###