IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

EDI Discussion :

Hello World compile pas [Eclipse]


Sujet :

EDI

  1. #1
    Membre du Club
    Inscrit en
    mars 2008
    Messages
    63
    Détails du profil
    Informations forums :
    Inscription : mars 2008
    Messages : 63
    Points : 43
    Points
    43
    Par défaut Hello World compile pas
    Bon voila, ça va faire 2 jours que j'essaye de faire compiler un hello world sur Eclipse alors je lance un nouveau projet Qt et voila ce que ca me sort :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
     
    mingw32-make debug 
    mingw32-make -f Makefile.Debug
    mingw32-make[1]: Entering directory `D:/Mes Documents/workspace/QtWizardEclipse'
    c:\Qt\2010.02.1\qt\bin\uic.exe qtwizardeclipse.ui -o ui_qtwizardeclipse.h
    g++ -c -g -frtti -fexceptions -mthreads -Wall -DUNICODE -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN -I"c:\Qt\2010.02.1\qt\include\QtCore" -I"c:\Qt\2010.02.1\qt\include\QtGui" -I"c:\Qt\2010.02.1\qt\include" -I"c:\Qt\2010.02.1\qt\include\ActiveQt" -I"debug" -I"." -I"c:\Qt\2010.02.1\qt\mkspecs\default" -o debug\main.o main.cpp
    g++ -c -g -frtti -fexceptions -mthreads -Wall -DUNICODE -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN -I"c:\Qt\2010.02.1\qt\include\QtCore" -I"c:\Qt\2010.02.1\qt\include\QtGui" -I"c:\Qt\2010.02.1\qt\include" -I"c:\Qt\2010.02.1\qt\include\ActiveQt" -I"debug" -I"." -I"c:\Qt\2010.02.1\qt\mkspecs\default" -o debug\qtwizardeclipse.o qtwizardeclipse.cpp
    C:/Qt/2010.02.1/qt/bin\moc.exe -DUNICODE -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN -I"c:\Qt\2010.02.1\qt\include\QtCore" -I"c:\Qt\2010.02.1\qt\include\QtGui" -I"c:\Qt\2010.02.1\qt\include" -I"c:\Qt\2010.02.1\qt\include\ActiveQt" -I"debug" -I"." -I"c:\Qt\2010.02.1\qt\mkspecs\default" -D__GNUC__ -DWIN32 qtwizardeclipse.h -o debug\moc_qtwizardeclipse.cpp
    g++ -c -g -frtti -fexceptions -mthreads -Wall -DUNICODE -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN -I"c:\Qt\2010.02.1\qt\include\QtCore" -I"c:\Qt\2010.02.1\qt\include\QtGui" -I"c:\Qt\2010.02.1\qt\include" -I"c:\Qt\2010.02.1\qt\include\ActiveQt" -I"debug" -I"." -I"c:\Qt\2010.02.1\qt\mkspecs\default" -o debug\moc_qtwizardeclipse.o debug\moc_qtwizardeclipse.cpp
    g++ -enable-stdcall-fixup -Wl,-enable-auto-import -Wl,-enable-runtime-pseudo-reloc -mthreads -Wl -Wl,-subsystem,windows -o debug\QtWizardEclipse.exe debug/main.o debug/qtwizardeclipse.o debug/moc_qtwizardeclipse.o  -L"c:\Qt\2010.02.1\qt\lib" -lmingw32 -lqtmaind -lQtGuid4 -lQtCored4 
    c:\Qt\2010.02.1\qt\lib/libqtmaind.a(qtmain_win.o): dans la fonction « WinMain@16 »:
    C:\qt-greenhouse\Trolltech\Code_less_create_more\Trolltech\Code_less_create_more\Troll\4.6\qt\src\winmain/qtmain_win.cpp:93: référence indéfinie vers « _Unwind_Resume »
    mingw32-make[1]: Leaving directory `D:/Mes Documents/workspace/QtWizardEclipse'
    C:\qt-greenhouse\Trolltech\Code_less_create_more\Trolltech\Code_less_create_more\Troll\4.6\qt\src\winmain/qtmain_win.cpp:135: référence indéfinie vers « _Unwind_Resume »
    c:\Qt\2010.02.1\qt\lib/libqtmaind.a(qtmain_win.o):C:\qt-greenhouse\Trolltech\Code_less_create_more\Trolltech\Code_less_create_more\Troll\4.6\qt\src\winmain/../../include/QtCore/../../src/corelib/tools/qvector.h:482: référence indéfinie vers « _Unwind_Resume »
    c:\Qt\2010.02.1\qt\lib/libqtmaind.a(qtmain_win.o):C:\qt-greenhouse\Trolltech\Code_less_create_more\Trolltech\Code_less_create_more\Troll\4.6\qt\src\winmain/../../include/QtCore/../../src/corelib/tools/qvector.h:483: référence indéfinie vers « _Unwind_Resume »
    c:\Qt\2010.02.1\qt\lib/libqtmaind.a(qtmain_win.o):qtmain_win.cpp:(.eh_frame+0x12): référence indéfinie vers « __gxx_personality_v0 »
    collect2: ld returned 1 exit status
    mingw32-make[1]: *** [debug\QtWizardEclipse.exe] Error 1
    mingw32-make: *** [debug] Error 2
    Voila j'y comprend rien.
    C'est quoi ca C:\qt-greenhouse\Trolltech j'ai jamais indiqué ou crée un truc du genre cela commence à me désespérer.

    Si quelqu'un sait comment ca marche merci d'avance.

  2. #2
    Responsable Qt & Livres


    Avatar de dourouc05
    Homme Profil pro
    Ingénieur de recherche
    Inscrit en
    août 2008
    Messages
    25 805
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur de recherche
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2008
    Messages : 25 805
    Points : 181 153
    Points
    181 153
    Par défaut
    Ça me rappelle des trucs... Essaye de désinstaller complètement Qt, puis de le réinstaller. C'est un bug dans l'installateur, mais il devrait être résolu dans les dernières versions... Si ça ne suffit pas, un build perso, un build de Dvp ou bien l'application du patch (quoique peu sûr...). (http://qt.developpez.com/binaires/).
    Vous souhaitez participer aux rubriques Qt (tutoriels, FAQ, traductions) ou HPC ? Contactez-moi par MP.

    Créer des applications graphiques en Python avec PyQt5
    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

  3. #3
    Membre du Club
    Inscrit en
    mars 2008
    Messages
    63
    Détails du profil
    Informations forums :
    Inscription : mars 2008
    Messages : 63
    Points : 43
    Points
    43
    Par défaut
    ok thx.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Hello World marche pas
    Par stevchen dans le forum Struts 2
    Réponses: 0
    Dernier message: 08/12/2010, 23h30
  2. Hello ne compile pas.
    Par Pierre8r dans le forum Scala
    Réponses: 2
    Dernier message: 01/09/2009, 18h36
  3. Hello world : pas hello
    Par Mister Nono dans le forum JSF
    Réponses: 3
    Dernier message: 05/07/2007, 17h50
  4. Réponses: 15
    Dernier message: 24/05/2007, 06h13
  5. [C++] Hello world ne compile pas
    Par thargos dans le forum C++
    Réponses: 9
    Dernier message: 25/09/2006, 19h45

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo