IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut [SSAS] [2K5Comment Exposer les données d'Analysis services sur Internet: Securité, authentification, connexion
    Bonjour,

    J'ai un serveur sur Internet qui héberge Analysis Services.
    Nativement depuis Excel il est proposé de se connecter à Analysis Services, Quel est le port par défaut du serveur ?

    Niveau sécurité existe-il une méthode avec authentification ?

    Y a t il une solution HTTP qui fournit depuis un plugin Excel + un service sur le serveur une connexion HTTP?

    Que me conseillez vous de pratiquer comme bonne pratique pour sécuriser Analysis Services à travers le web ?

    merci

  2. #2
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Bon pour le port je crois que c'est le 2383
    http://msdn.microsoft.com/en-us/library/cc966526.aspx

  3. #3
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Arf...

    Mode d'authentification


    Cette page définit le fournisseur d'authentification pour le Moteur de base de données. SQL Server Analysis Services ne prend en charge que l'authentification Windows.
    http://technet.microsoft.com/fr-fr/l...SQL.90%29.aspx

    Visiblement c'est donc pas possible de se connecter sur Analysis Service à travers internet ?

    Quel est l'astuce? Y a bien quelqu'un ici qui a déjà eu cette problématique...

    A bientôt

  4. #4
    Membre chevronné Avatar de Jinroh77
    Homme Profil pro
    Consultant en Business Intelligence
    Inscrit en
    février 2006
    Messages
    1 964
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : France, Seine et Marne (Île de France)

    Informations professionnelles :
    Activité : Consultant en Business Intelligence

    Informations forums :
    Inscription : février 2006
    Messages : 1 964
    Points : 2 145
    Points
    2 145
    Par défaut
    Si mes souvenirs sont bons, tu trouveras une manière de faire sur le blog de François .
    Si ce n'est pas là, j'essayerai de retrouver.
    Alexandre Chemla - Consultant MS BI chez Masao

  5. #5
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Jinroh77
    Ahaha on peut pas dire que c'est une solution "user friendly" ce que tu me proposes, j'en rigole d'avance! Enfin elle a le mérite d'exister, et toi de la connaitre... donc je vais lire ca !

    J'ai l'impression que rien n'est évident à faire sous Annalysis Services, je galère vraiment... je suppose que c'est due au fait que je ne maitrise pas la techno

    Merci encore !

  6. #6
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Jinroh77
    Désolé de revenir à la charge mais je ne vois très bien quel article pourrait m'aider à créer une connexion over Internet utilisable sous Excel 2007 à Analysis Services ?

  7. #7
    Membre chevronné Avatar de Jinroh77
    Homme Profil pro
    Consultant en Business Intelligence
    Inscrit en
    février 2006
    Messages
    1 964
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : France, Seine et Marne (Île de France)

    Informations professionnelles :
    Activité : Consultant en Business Intelligence

    Informations forums :
    Inscription : février 2006
    Messages : 1 964
    Points : 2 145
    Points
    2 145
    Par défaut
    Avec ce genre de chose et ça tu ne pourrais pas trouver ton bonheur ?
    Ensuite ton serveur est accessible de l'extérieur. Tu devrais pouvoir te brancher dessus via Excel ou tout autre client.
    Alexandre Chemla - Consultant MS BI chez Masao

  8. #8
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Jinroh77
    hum en effet j'avais mal cherché, ca semble bien correspondre, je vais tester ca d'ici quelque jours, je te remercie !

    Bonne fin de journée à toi

  9. #9
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Je me suis remis sur ce probleme aujourd'hui, j'ai suivi ce tuto:
    http://fjehl.blogspot.com/2008/06/ou...trieur-en.html


    Et je ne comprend pas du tout la partie:
    Retournez dans la console d'admin IIS. Ajoutez une web service extension sur votre DLL, nommez la comme bon vous semble et activez là. Validez.
    Comprends tu ce que je dois faire ?
    Je suis sous windows XP (machine de dev, le srv de prod sera un 2003), j'ai ajouté un répertoire virtuel avec la dll "msmdpump.dll", dans "configuration de l'application" j'ai ajouté cette DLL, j'ai mis en connexion mon login/mdp (je suis admin), mais là "ajouter un WS extension sur votre DLL": je ne comprend pas !

    // A vue de nez c'est peut etre pas une fonctionnalité d'XP... jvais lancer un 2003 pour voir

  10. #10
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Zut c'est ce que je redoutais, ce n'est présent que sur les versions serveurs de Windows.... grrr pour tester sur un post de dev c'est vraiment embattant

  11. #11
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Hum, j'essaye d'installer ma base Analysis Services sur une machine virtuelle, Windows 2003 srv + SQL 2005 full developper edition

    depuis ma machine de dev XP sp3 (à jours) avec SQL 2005 full developper, depuis management studio, je me connecte au moteur analysis service, je sauvegarde ma base.

    Depuis la machine virtuelle, j'essaye de restaurer ma base precedement sauvegardée: et la c'est le drame, il me sort une erreur "erreur du gestionnaire de métadonnées", ma base est visible mais est complètement morte, j'essaye alors de la supprimer même message:
    "impossible d'afficher la boite de dialogue, erreur du gestionnaire de métadonnées, la dimension d'ID "Fact compteur" et de nom "Fact compteur" référencé par le cube n'existe pas..."

    grrr:
    Ma machine virtuelle n'est pas vraiment à jour, est ce que ce probleme peut venir de ca ?
    Comment puis-je supprimé ma base créé qui ne marche pas ?

  12. #12
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Je viens de mettre à jours ma machine virtuelle, et j'ai toujours la même erreur.

    Sur le moteur de base de données, je n'ai pas mis ma DB sur lequel Analysis Services se base: C'est grave ?
    Quelqu'un peut me confirmer que la DB SQL et la DB SSAS sont bien indépendante l'une de l'autre ?

    J'ai simplement fait un restaure de ma bases SSAS rien d'autre... il faut peut être déployer d'autre chose...

  13. #13
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Je fais un Up de mon probleme,

    Je ne sais pas trop comment l'expliquer plus clairement, je ne comprend pas pourquoi je n'ai pas de réponse car c'est un probleme d'ordre général que de vouloir faire un backup/restaure d'une base...

    Donc si y a un truc qui ne vous parait pas clair, dites le

    Bonne journée à tous

  14. #14
    Membre émérite Avatar de FrancoisJehl
    Homme Profil pro
    BI Engineer
    Inscrit en
    juillet 2009
    Messages
    1 485
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : BI Engineer
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : juillet 2009
    Messages : 1 485
    Points : 2 884
    Points
    2 884
    Par défaut
    Les problèmes de Metadata Manager il y en avait en SP1 et SP2, à ma connaissance depuis SP2 CU7 la plupart des "connus" sont résolus. Tu es en SP3 sur ta VM? (9.0.4035 a minima)
    François JEHL
    BI Engineer | MVP SQL Server
    http://fjehl.wordpress.com
    Pour me contacter, par MP ou ici, mais pas pour des questions techniques.

    /*
    Avant de poster cherchez dans la FAQ et utilisez la fonction "Rechercher" du forum.
    Au moment de poster, posez votre question dans le bon sous-forum (Débuter, SSAS, SSRS, SSIS), en utilisant les TAGs prédéfinis ([2K], [2K5], [2K8], [2K8R2]).
    */

  15. #15
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Je te remercie FrancoisJehl

    Sur ma machine de dev XP (ma machine source donc ou je fais un backup):
    9.00.4053.00 SP3 Developer Edition

    Sur la machine virtuelle 2003 (ou je fais un restaure):
    9.00.1399.06 RTM Developer Edition

    Hum... Ok donc une Maj est necessaire (pourtant j'etais persuadé d'avoir tout updaté...)

  16. #16
    Membre émérite Avatar de FrancoisJehl
    Homme Profil pro
    BI Engineer
    Inscrit en
    juillet 2009
    Messages
    1 485
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : BI Engineer
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : juillet 2009
    Messages : 1 485
    Points : 2 884
    Points
    2 884
    Par défaut
    Ah ouaiiiiiis. Oui mets à jour je te confirme!
    François JEHL
    BI Engineer | MVP SQL Server
    http://fjehl.wordpress.com
    Pour me contacter, par MP ou ici, mais pas pour des questions techniques.

    /*
    Avant de poster cherchez dans la FAQ et utilisez la fonction "Rechercher" du forum.
    Au moment de poster, posez votre question dans le bon sous-forum (Débuter, SSAS, SSRS, SSIS), en utilisant les TAGs prédéfinis ([2K], [2K5], [2K8], [2K8R2]).
    */

  17. #17
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Je suis passé par démarrer / tous les programmes / windows update


    Là j'ai bien l'impression qu'il ne veut pas trouver les MAJ de SQL, je vais essayer via Microsoft Update
    http://update.microsoft.com/microsof...ult.aspx?ln=fr

    histoire de voir

  18. #18
    Membre chevronné Avatar de Jinroh77
    Homme Profil pro
    Consultant en Business Intelligence
    Inscrit en
    février 2006
    Messages
    1 964
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : France, Seine et Marne (Île de France)

    Informations professionnelles :
    Activité : Consultant en Business Intelligence

    Informations forums :
    Inscription : février 2006
    Messages : 1 964
    Points : 2 145
    Points
    2 145
    Par défaut
    Ou une recherche google, ça fonctionne encore mieux.
    Alexandre Chemla - Consultant MS BI chez Masao

  19. #19
    Membre confirmé
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 002
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 002
    Points : 552
    Points
    552
    Par défaut
    Ok c'était bien un probleme de MAJ
    Merci !

  20. #20
    Membre émérite Avatar de FrancoisJehl
    Homme Profil pro
    BI Engineer
    Inscrit en
    juillet 2009
    Messages
    1 485
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : BI Engineer
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : juillet 2009
    Messages : 1 485
    Points : 2 884
    Points
    2 884
    Par défaut
    De rien! Un ptit passage à "Résolu"?
    François JEHL
    BI Engineer | MVP SQL Server
    http://fjehl.wordpress.com
    Pour me contacter, par MP ou ici, mais pas pour des questions techniques.

    /*
    Avant de poster cherchez dans la FAQ et utilisez la fonction "Rechercher" du forum.
    Au moment de poster, posez votre question dans le bon sous-forum (Débuter, SSAS, SSRS, SSIS), en utilisant les TAGs prédéfinis ([2K], [2K5], [2K8], [2K8R2]).
    */

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Parcourir les données dans analysis manager
    Par killua86 dans le forum MS SQL Server
    Réponses: 0
    Dernier message: 19/02/2010, 20h04
  2. Réponses: 5
    Dernier message: 21/10/2009, 16h10
  3. Réponses: 5
    Dernier message: 08/05/2009, 16h42
  4. Réponses: 3
    Dernier message: 06/08/2008, 10h17
  5. Réponses: 2
    Dernier message: 29/11/2007, 23h29

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo