IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Contribuez Discussion :

Envoi de SMS à partir d'un modem GSM ou d'un modem exécutant les commandes AT


Sujet :

Contribuez

  1. #1
    Membre régulier Avatar de bruce207
    Inscrit en
    novembre 2007
    Messages
    319
    Détails du profil
    Informations forums :
    Inscription : novembre 2007
    Messages : 319
    Points : 124
    Points
    124
    Par défaut Envoi de SMS à partir d'un modem GSM ou d'un modem exécutant les commandes AT
    Bonjour,
    Voici le code pour envoyer des sms à partir d'un modem GSM ou d'un modem exécutant les commandes AT. Les paramètres et certains élémnts peuvent changer:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    bMonPort est un booléen
    nNbreOctet est un entier
    sMess est une chaîne
     
    //Ouverture du port COM
    bMonPort = sOuvre(1, 1024, 1024, sTimeoutDéfaut)
    SI bMonPort = Vrai ALORS
    	//On renseigne les paramètres du modem
    	sFixeParamètre(1, 9600, 0, 8, 1, Vrai, Vrai, Faux)
    	//On teste le modem
    	sEcrit(1, "AT" + Caract(13))
    	//On laisse au moden le temps de répondre
    	Temporisation(100)
    	nNbreOctet = sDansFileEntrée(1)
    	sMess = sLit(1, nNbreOctet)
    	//Si la réponse (qui est en fonction du modem) est différente Entrée_OK_Entrée...
    	SI Majuscule(sMess) <> Caract(13) + Caract(10) + "OK" + Caract(13) + Caract(10) ALORS
    		Info("Communication avec le terminal impossible !" + RC + " Réseau mauvais ou revérifiez les branchements du modem et sa configuration !")
    	SINON
    		//Selon le pays le nombre de chiffre pour composer un numéro
    		//Pour moi c'est 8, pour la France c'est supérieur dont à changeren fonction
    		//du pays (ici SAI_N_Téléphone est le champ qui contient le N° de tél
    		SI Taille(SAI_N_Téléphone) <> 8 ALORS
    			Info("Numéro de Téléphone érronné ! Vérifier le SVP !")
    		SINON
    			Temporisation(100)
    			//Pour les commandes AT chercher la syntaxe sur le net
    			sEcrit(1, "AT+CMGS=" + Caract(34) + Droite(SAI_N_Téléphone, 8) + Caract(34) + Caract(13))
    			Temporisation(100)
    			nNbreOctet = sDansFileEntrée(1)
    			sMess = sLit(1, nNbreOctet)
    			SI Majuscule(sMess) <> Caract(13) + Caract(10) + "> " ALORS
    				Info("Mauvaise initialisation du Modem !")
    			SINON
    				Temporisation(100)
    				sEcrit(1, SAI_Message + Caract(26))
    //				Temporisation(100)
    				Info("Message envoyer avec succès !")
    			FIN
    		FIN
    	FIN
    	//On ferme le port
    	sFerme(1)
    SINON
    	Erreur("Erreur d'ouverture du COM1")
    FIN
    Merci

  2. #2
    Nouveau Candidat au Club
    Inscrit en
    août 2006
    Messages
    1
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 1
    Points : 1
    Points
    1
    Par défaut Quelque soit le Modem GSM
    Salut Bruce,

    J'aimerais savoir si ce code fonctionne quelque soit le modem gsm. Merci

  3. #3
    Membre régulier Avatar de bruce207
    Inscrit en
    novembre 2007
    Messages
    319
    Détails du profil
    Informations forums :
    Inscription : novembre 2007
    Messages : 319
    Points : 124
    Points
    124
    Par défaut
    Bonjour,
    je l'ai testé avec un modem wavecom fastrack et je crois que pour tous les modems du genre ça marche. Essaye et tu me diras

  4. #4
    Futur Membre du Club
    Profil pro
    Inscrit en
    janvier 2004
    Messages
    4
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : janvier 2004
    Messages : 4
    Points : 5
    Points
    5
    Par défaut
    Bon, je voudrais juste ajouté que j'ai fait le test avec un modem GSM TM2... et que sa fonctionne parfaitement.... et surtout un grand merci au forum et aux participant, parce que j'ai un bouquin Interface GSM 2eme edition qui a oublier de préciser qu'il faut des guillemets qui encadre le numero de tel....

  5. #5
    Membre régulier Avatar de bruce207
    Inscrit en
    novembre 2007
    Messages
    319
    Détails du profil
    Informations forums :
    Inscription : novembre 2007
    Messages : 319
    Points : 124
    Points
    124
    Par défaut
    Citation Envoyé par marie eva
    lorsque j'exécute le code voici le message d'erreur : Communication avec le terminal impossible!Réseau mauvais ou revérifiez les branchements du modem et sa configuration!
    Il faut d'abord tester le modem pour savoir si ta machine le reconnait pour ce faire sous XP tu vas as Démarrer--Tous les programmes--Accéssoires--Communications--HyperTerminal. Pour des OS superieures c-a-d Vista ou Seven faudra chercher. Donc après avoir lancer HyperTerminal et paramétrer avac les informations demandées, une console s'affiche et là après le prompt du curseur tu tapes AT et si le modem est bien connecté et reconnu par la machine tu auras comme reponse OK. Fais déjà ceci et tiens moi informer

  6. #6
    Membre éprouvé Avatar de b_reda31
    Homme Profil pro
    Développeur informatique
    Inscrit en
    avril 2007
    Messages
    878
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : Algérie

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : avril 2007
    Messages : 878
    Points : 940
    Points
    940
    Par défaut
    Un Grand Merci. Très beau travail
    « Il est assez difficile de trouver une erreur dans son code quand on la cherche. C’est encore bien plus dur quand on est convaincu que le code est juste!!»

  7. #7
    Nouveau Candidat au Club
    Inscrit en
    janvier 2011
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : janvier 2011
    Messages : 5
    Points : 0
    Points
    0
    Par défaut probléme
    salut je suis buté au méme probléme si quelqu'un peut avoir une source fonctionnelle s'il vous plait, je voulais envoyé des messages depuis un modem de la marque huawei à partir de mon application windev. s'il vous plait aidé moi, j'essaie toute les sources mais en vain. mon port est COM5

  8. #8
    Nouveau Candidat au Club
    Inscrit en
    janvier 2011
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : janvier 2011
    Messages : 5
    Points : 0
    Points
    0
    Par défaut
    déja resolut, merci bien

  9. #9
    Membre à l'essai
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    août 2012
    Messages
    17
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Transports

    Informations forums :
    Inscription : août 2012
    Messages : 17
    Points : 14
    Points
    14
    Par défaut
    bonjour

    je reprend cette discussion afin de ladapter a un modem gSM IP

    est ce que vous avez deja essayer de le faire

    merci de votre retour

  10. #10
    Membre à l'essai
    Inscrit en
    décembre 2010
    Messages
    20
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 20
    Points : 19
    Points
    19
    Par défaut Possibilité de personnaliser l'emetteur
    Bonjour,

    Est-il possible de personnaliser l’émetteur lors de l'envoie d'un SMS avec les commandes AT?


    Merci

  11. #11
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2015
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : novembre 2015
    Messages : 13
    Points : 13
    Points
    13
    Par défaut
    merci des solutions je suis en train de tester je reviens vers pour vous donnez le resultat

  12. #12
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2015
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : novembre 2015
    Messages : 13
    Points : 13
    Points
    13
    Par défaut
    J'ai testé et l'erreur est : ("Communication avec le terminal impossible ! Réseau mauvais ou revérifiez les branchements du modem et sa configuration !")

  13. #13
    Membre éprouvé Avatar de b_reda31
    Homme Profil pro
    Développeur informatique
    Inscrit en
    avril 2007
    Messages
    878
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : Algérie

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : avril 2007
    Messages : 878
    Points : 940
    Points
    940
    Par défaut
    Si vous ne disposez pas d'un modem gsm bien installé et bien configuré sur votre machine, il serai tout à fait normal que vous ne puissiez exécuter ce code.
    Sinon vérifiez si le numéro de port de votre modem correspond à celui utilisé dans le programme
    « Il est assez difficile de trouver une erreur dans son code quand on la cherche. C’est encore bien plus dur quand on est convaincu que le code est juste!!»

  14. #14
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2015
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : novembre 2015
    Messages : 13
    Points : 13
    Points
    13
    Par défaut
    j'ai un mon huawei installer et connecter.
    mon numéro de port est bon .
    dans mon terminal ma commande AT reponds ok

  15. #15
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2015
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : novembre 2015
    Messages : 13
    Points : 13
    Points
    13
    Par défaut
    j'ai toujours la meme erreur

  16. #16
    Membre éprouvé Avatar de b_reda31
    Homme Profil pro
    Développeur informatique
    Inscrit en
    avril 2007
    Messages
    878
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : Algérie

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : avril 2007
    Messages : 878
    Points : 940
    Points
    940
    Par défaut
    Citation Envoyé par omed23 Voir le message
    j'ai toujours la meme erreur
    Bonjour, ne me prenez surtout pas mal, mais il ne suffit pas de prendre un code existant de le copier / coller sans rien comprendre , de l'exécuter et s'étonner que ça ne fonctionne pas...
    Il faut un minumum d'effort de compréhension afin d'adapter le code à votre matériel :

    Pas besoin d'être un génie pour comprendre que le message d'erreur affiché provient de la condition suivante :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    SI Majuscule(sMess) <> Caract(13) + Caract(10) + "OK" + Caract(13) + Caract(10) ALORS
    Je vois pour cela deux cas de figure : (On supposant que le modem est bien installé et configuré et que vous utilisez le bon port)
    1- Dans le code, la réponse attendu par le modem est
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Caract(13) + Caract(10) + "OK" + Caract(13)
    ce qui correspond à un format bien précis de message de retour
    il est possible, que le modem que vous utilisez, réponde d'un message quelque peu différent, mais je pense que dans la majorité des cas, le message de retour du modem contient la chaine "OK",
    essayer donc d'assouplir un peu la condition, un peu du genre "Si le message du modem contient la sous chaine "OK" "
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
     
    SI Contient(Majuscule(sMess), "OK") = Vrai ALORS
    ...
    2- Le modem ne renvoie pas le message OK, essayez d'afficher le message de retour et voir ce qu'il en est. Vous ne donnez peut être pas assez de temps au modem pour répondre, essayez donc d'augmenter le délai dans les fonction de temporisation.

    Je vous conseille vivement de bien relire le code de cette contribution, je trouve qu'il est très bien écrit et très bien commenté. J'en remercie encore son Auteur Bruce207.
    « Il est assez difficile de trouver une erreur dans son code quand on la cherche. C’est encore bien plus dur quand on est convaincu que le code est juste!!»

  17. #17
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2015
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : novembre 2015
    Messages : 13
    Points : 13
    Points
    13
    Par défaut
    merci pour vos contributions les développeurs.
    jusque la je n'y parviens j'ai l'impression que mon problème se situe à un autre niveau..
    en allégant b_reda31 maintenant ce sont mes port qui ne souvrent plus. donnez mooi le temps de me concentrer sur mon code et je reviendrai vers vous pour vous donnez le resultat s'il vous plait.
    merci encore.

  18. #18
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2015
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : novembre 2015
    Messages : 13
    Points : 13
    Points
    13
    Par défaut
    merci les développeurs pour l'aide et les astuces ce n'est que maintenant que je peux envoyer des messages.
    il fallait déclarer la variable sch en chaine (ansi) et après avoir fixer les parametres convertir en utf8

  19. #19
    Candidat au Club
    Homme Profil pro
    Ingénieur sécurité
    Inscrit en
    octobre 2011
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Ingénieur sécurité
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : octobre 2011
    Messages : 10
    Points : 3
    Points
    3
    Par défaut
    Bonjour, j'ai besoin d'aide

    J'ai testé et l'erreur dans le cas ou mon SMS contient des caractères accentués Ou taille(sch)>70.

  20. #20
    Membre régulier
    Homme Profil pro
    Étudiant
    Inscrit en
    juin 2014
    Messages
    114
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Guinée

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Finance

    Informations forums :
    Inscription : juin 2014
    Messages : 114
    Points : 100
    Points
    100
    Par défaut
    Salut, je trouve très intéressant ce code.
    Etant débutant, comment je dois l'utiliser.
    J'ai une clé orange. le Code reconnait-il au branchement directement, ou bien il faut des manip ?
    Merci d'avance.........

Discussions similaires

  1. Réponses: 3
    Dernier message: 13/04/2015, 21h11
  2. Envoi de SMS à partir d'une application
    Par rafleboss dans le forum Android
    Réponses: 2
    Dernier message: 25/02/2015, 09h10
  3. Réponses: 3
    Dernier message: 07/04/2014, 09h05
  4. envoi d un sms à partir d une application web
    Par siwar dans le forum Développement
    Réponses: 1
    Dernier message: 07/07/2012, 20h38
  5. Réponses: 3
    Dernier message: 28/05/2012, 22h08

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo