Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Excel Discussion :

Format conditionnel ne fonctionne pas


Sujet :

Excel

  1. #1
    Nouveau membre du Club
    Format conditionnel ne fonctionne pas
    j'ai aussi un autre problème..

    J'ai mis une mise en forme conditionnelle sur une cellule qui est :

    Si la case à coté (ex A1) est vide, cette case(B1) doit rester blanche, mais ca ne marche pas ! Je n'arrive pas à représenter le mot "vide"

    voici ce que j'ai mis :


  2. #2
    Responsable
    Office & Excel

    Dans le format conditionnel, tu dois garder à l'esprit que si tu saisis une formule avec des références relatives, elles sont relatives à la cellule active au moment de la création de la MFC. Pour pouvoir tester si la cellule à gauche de la cellule active est vide ou pas, tu dois te placer dans une cellule et saisir la référence de la cellule de gauche dans la mfc.

    choisis le test sur une formule, et comme formule, saisis ceci, après t'être placé en O21
    =(N21="")
    "Plus les hommes seront éclairés, plus ils seront libres" (Voltaire)
    ---------------
    Mes remarques et critiques sont purement techniques. Ne les prenez jamais pour des attaques personnelles...
    Une fois pour toutes, je donne mon avis. Je ne vais pas le répéter à chaque message...
    Si je propose une solution générique sur votre solution spécifique, c'est parce que, fainéant de nature, je privilégie le réutilisable...
    Le VBA ne palliera jamais une mauvaise conception de classeur ou un manque de connaissances des outils natifs d'Excel...
    Ce ne sont pas des bonnes pratiques parce que ce sont les miennes, ce sont les miennes parce que ce sont des bonnes pratiques
    VBA pour Excel? Pensez D'ABORD en EXCEL avant de penser en VBA...
    ---------------

  3. #3
    Nouveau membre du Club


    choisis le test sur une formule, et comme formule, saisis ceci, après t'être placé en O21
    Je n'ai pas vraiment compris... Alors j'ai essayé, dans ma MFC j'ai mis
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    =(N21="")

    mais ca ne change absolument rien..
    Pouvez-vous me ré expliquer?

  4. #4
    Responsable
    Office & Excel

    Voici deux illustrations

    Excel 2007






    Excel 2003 et antérieurs


    "Plus les hommes seront éclairés, plus ils seront libres" (Voltaire)
    ---------------
    Mes remarques et critiques sont purement techniques. Ne les prenez jamais pour des attaques personnelles...
    Une fois pour toutes, je donne mon avis. Je ne vais pas le répéter à chaque message...
    Si je propose une solution générique sur votre solution spécifique, c'est parce que, fainéant de nature, je privilégie le réutilisable...
    Le VBA ne palliera jamais une mauvaise conception de classeur ou un manque de connaissances des outils natifs d'Excel...
    Ce ne sont pas des bonnes pratiques parce que ce sont les miennes, ce sont les miennes parce que ce sont des bonnes pratiques
    VBA pour Excel? Pensez D'ABORD en EXCEL avant de penser en VBA...
    ---------------

  5. #5
    Membre éclairé
    selectionne la cellule ou la plage de cellule qui doit changer de couleur

    va dans la mise en forme conditionnel, tape dans l'endroit qui propose une formule =cellule="" et fait bien attention que ca soit écrit sans $ et que ca correspondent bien a la cellule du haute de la zone que tu as selectionné

    Par exemple, si tu veux que la plage C20 a C30 se colorie en fonction de si la cellule correspondante de la plage F20 a F30 est vide ou non, il faut selectionnée C20:C30 et puis taper =F20="" (et choisir une mise en forme)

    Si tu tapes =$F$20="", toute ta plage C20:C30 va se colorioer ou non d'un coup selon si F20 est vide ou non (et ne jamais regarde F21:F30)
    Si tu tapes =F21="", tes cellules vont se colorier selon si la cellule une ligne plus bas est vide ou non

    Je t'ai mit un exemple en piece jointe (va voir les MFC de la colonne B)

  6. #6
    Nouveau membre du Club
    Ok, c'est bien ce que j'ai fait. En fait ca ne fonctionne pas car j'ai deux MFC qui se contredisent dans la même cellule..

    La première :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    =SI(N25="";1;0)


    La deuxième :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    =SI(N25<=K25;1;0)


    Je vous explique ce que je fais :

    Je compare deux dates de la forme jj/mm/aaaa en colonne N et K
    La colonne K est déja remplie alors que la colonne N se remplie au fur à mesure des missions.
    Le problème est que la condition 2 se calcule à chaque fois même si la case est vide donc ma condition 1 n'a plus lieu d'être.

    Je pense que pour solder mon problème il faudrait que je dise quelque part que la condition 2 n'est valable que si la valeur de la cellule N est de la forme jj/mm/aaaa, non?

    Si oui, comment je peux faire ca?

    Merci !!

  7. #7
    Membre éclairé
    Il y a un ordre d'application pour les MFC, inverse le

  8. #8
    Nouveau membre du Club
    Effectivement, en inversant ça marche..

    Merci beaucoup à vous 2!