IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eclipse Java Discussion :

Fausses erreurs de compilation des JSP


Sujet :

Eclipse Java

  1. #1
    Candidat au Club
    Profil pro
    Inscrit en
    novembre 2009
    Messages
    5
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : novembre 2009
    Messages : 5
    Points : 4
    Points
    4
    Par défaut Fausses erreurs de compilation des JSP
    Bonjour à tous,

    J'ai parcouru avec attention et acharnement le web et ce forum en particulier à la recherche d'une solution à mon problème, malheureusement en vain.
    Je poste maintenant dans l'espoir que quelqu'un aura une solution.
    Le sujet a déjà été abordé sans qu'une réelle solution ne soit trouvée (ou alors c'est moi qui suis passée à côté ;-))

    Mon problème est exactement celui abordé dans cette discussion :
    http://www.developpez.net/forums/d27...-derreur-gogo/

    Il y a donc un problème de correspondance entre les variables déclarées dans des tags et leur utilisation dans des scriplets.
    Par exemple :
    <bean:define id="monClient" name="clientForm" property="client" scope="session"/>
    puis plus loin
    <%=monClient.getNom()%> utilisé quelque part dans la jsp. On obtient une erreur sur "monClient" qui n'est pas reconnu, alors qu'à l'exécution, ça passe bien.

    J'insiste sur le fait que ça ne pose pas de problème à l'exécution. La gêne est plutôt lors du développement, puisqu'on se retrouve avec plus de 115 erreurs qui n'en sont pas et qui polluent l'IDE par rapport à d'autres vraies erreurs potentielles, que ce soit dans les JSP ou dans le reste du projet.

    Comme dans d'autres discussions semblables, la "solution" proposée est de filtrer les erreurs.
    Mais je ne souhaite pas masquer les erreurs sur les JSP car il peut effectivement y en avoir des "vraies".

    Or, je sais qu'il existe une solution quelque part (préférences, paramétrage, librairie, ...) puisque je n'avais pas le problème sur un précédent projet.

    Je travaille sur RSA (Rational Software Architect d'IBM) basé sur Eclipse. Sur mon projet précédent, je n'avais pas du tout ce problème. Je précise que j'utilise exactement le même outil, mais le workspace est différent.
    J'ai vraiment cherché partout pour trouver une différence de paramétrage, de préférence, de validation, d'écriture de JSP, mais je n'ai rien trouvé.

    Si quelqu'un a une idée d'où cela peut venir, je l'en remercie par avance !

    Merci à tous :-)

  2. #2
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 468
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 468
    Points : 17 035
    Points
    17 035
    Par défaut
    Bonjour,

    Est-ce que ton projet est de même nature que celui où tu n'avais pas le problème ? C'est-à-dire, est-il bien un projet Web (cf. .project), a-t-il la même arborescence avec les mêmes répertoires WebContent (ou quelque chose dans le style) ?

    Je ne crois pas que le changement de workspace y soit pour quelque chose mais bon ce n'est pas impossible non plus...
    Essaye de faire l'équivalent de eclipse -clean en ligne de commande à tout hasard.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  3. #3
    Candidat au Club
    Profil pro
    Inscrit en
    novembre 2009
    Messages
    5
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : novembre 2009
    Messages : 5
    Points : 4
    Points
    4
    Par défaut
    Bonjour,

    Merci de m'avoir répondu.
    Oui, les deux projets sont de nature identique. Ils sont tous deux la partie web d'un projet J5EE (mais pas le même). Ils ont également la même arborescence.

    J'ai comparé les .project et il y avait une différence au niveau des validateurs utilisés. J'ai modifié le .project de mon projet qui pose problème pour qu'il ressemble à celui du projet où il n'y a pas le problème. (et aussi ceux des projets dont il dépend au cas où)
    Mais ça n'a rien changé, après avoir relancé mon IDE et fait un clean et une recompilation des projets.
    Par contre, j'ai modifié le fichier directement sans passer par l'IDE car je ne savais pas quoi changer dans l'IDE pour que ça se répercute sur le .project. Est ce que ça pourrait poser problème ? Ca agit comme un fichier de conf non ?

    Donc toujours pas de solution pour le moment...

Discussions similaires

  1. Erreur de compilation des JSP apparue
    Par Arnard dans le forum Eclipse Java
    Réponses: 2
    Dernier message: 23/03/2007, 12h20
  2. Compilation des jsp
    Par danyboy85 dans le forum Servlets/JSP
    Réponses: 10
    Dernier message: 09/02/2006, 14h42
  3. Réponses: 3
    Dernier message: 13/01/2006, 12h00
  4. [JSP][Tomcat] : forcer la compilation des jsp.
    Par Ekros dans le forum Tomcat et TomEE
    Réponses: 5
    Dernier message: 29/04/2004, 12h27
  5. [ECLIPSE]Compilation des JSP
    Par partyboy dans le forum Eclipse Java
    Réponses: 6
    Dernier message: 03/09/2003, 22h37

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo