Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Composants VCL Delphi Discussion :

Problème d'installation Indy 10


Sujet :

Composants VCL Delphi

  1. #1
    Membre régulier
    Profil pro
    Inscrit en
    juin 2005
    Messages
    111
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2005
    Messages : 111
    Points : 75
    Points
    75
    Par défaut Problème d'installation Indy 10
    Bonjour à tous,

    Je voulais faire une petit client FTP avec support SSL. J'ai d'abord essayer avec Indy 9 et le composant OpenSSL mais vu que je comprenais pas comment l'utiliser, je me suis dit, je vais passer a Indy 10 qui intègre la gestion du SSL. J'ai donc téléchargé http://indy.fulgan.com/ZIP/indy10.zip, j'ai dézipper tout ca dans Delphi\Indy10 et j'ai enlevé Indy 9. J'ai ensuite suivit les instructions qui se trouvent ici: http://www.indyproject.org/Sockets/D...lation.de.aspx et tout semblait s'être bien passé. Pourtant, en tapant idFTP1., j'ai eu une première erreur:

    [Fatal Error] Unit1.pas(8): File not found: 'IdExplicitTLSClientServerBase.dcu'
    [Pascal Error] Unit1.pas(1): Unable to invoke Code Completion due to errors in source code

    Ensuite, j'ai voulu compilé:

    [Fatal Error] Unit1.pas(7): Unit IdTCPConnection was compiled with a different version of IdException.TClassIdException

    Ou encore

    [Fatal Error] Unit1.pas(7): Unit IdIOHandler was compiled with a different version of IdComponent.TIdComponent

    J'ai aussi essayé de mettre le répertoire Delphi\Indy10\Lib\ en tous premier dans la liste des librairies (Tools>Env>Lib) mais ca ne règle pas le problème. (l'erreur change toutefois et il me dit qu'il me manque des .dcu qui sont pourtant dans le répertoire. --> [Fatal Error] Unit1.pas(7): File not found: 'IdExplicitTLSClientServerBase.dcu' ou mm erreur avec IdIOHandlerStack.dcu en fonction de si j'ai déjà ajouté le composant SSL ou non)

    Ou ai-je fais une erreur ? Et comment contourner ce problème ?

    Merci d'avance,
    Boo

  2. #2
    Nouveau membre du Club
    Inscrit en
    novembre 2002
    Messages
    26
    Détails du profil
    Informations forums :
    Inscription : novembre 2002
    Messages : 26
    Points : 29
    Points
    29
    Par défaut
    Avec Delphi 7
    Pour réinstaller indy10 il faut d'abord aller DANS L'INSTALLATION DE DELPHI et supprimer les composant indy9 en le décochant (ajouter/supprimer des programmes).
    Après tu installes Indy10 sans problème.

  3. #3
    Membre expérimenté
    Avatar de ouiouioui
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    août 2006
    Messages
    964
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : août 2006
    Messages : 964
    Points : 1 382
    Points
    1 382
    Par défaut
    Tu devrais prendre Indy directement dans le svn si tu veux la plus récente.
    Il existe 3 sortes de gens: ceux qui savent compter et ceux qui ne savent pas.

  4. #4
    Membre chevronné

    Homme Profil pro
    Étudiant
    Inscrit en
    juin 2009
    Messages
    935
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 29
    Localisation : France, Aveyron (Midi Pyrénées)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : juin 2009
    Messages : 935
    Points : 1 765
    Points
    1 765
    Par défaut
    Salut

    J'ai du plusieurs fois réinstaller Indy10, parce que je changeais de PC, et en suivant ces instructions, j'ai réussi a chaque fois sans problemes ... Je ne sais pas si cela marche sur une autre version de Delphi par contre ...

    Bonne chance

Discussions similaires

  1. [Lazarus] Problème d'installation d'INDY
    Par fsimondi dans le forum Lazarus
    Réponses: 1
    Dernier message: 19/10/2013, 17h40
  2. [Lazarus] Problème pour installer Indy 10.2.0.3 pour Lazarus
    Par [ZiP] dans le forum Lazarus
    Réponses: 1
    Dernier message: 13/03/2013, 19h23
  3. [Lazarus] [Indy] Problème d'installation sous Windows 7
    Par fsimondi dans le forum Lazarus
    Réponses: 4
    Dernier message: 25/09/2010, 19h08
  4. Problème pour installer les composants Indy
    Par ChPr dans le forum Composants VCL
    Réponses: 4
    Dernier message: 23/10/2008, 00h38
  5. Réponses: 3
    Dernier message: 27/07/2002, 00h02

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo