IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Qualimétrie Discussion :

[maven] probleme génération de report checkstyle [Checkstyle]


Sujet :

Qualimétrie

  1. #1
    Membre à l'essai
    Inscrit en
    septembre 2009
    Messages
    29
    Détails du profil
    Informations forums :
    Inscription : septembre 2009
    Messages : 29
    Points : 19
    Points
    19
    Par défaut [maven] probleme génération de report checkstyle
    Bonjour,

    j'ai un problème de génération de report checkstyle sous maven.
    quand je lance mvn site il me genere le site avec le report PMD mais sans celui de checkstyle

    voici le code au niveau du pom:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    <reporting>
        <plugins>
          <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-checkstyle-plugin</artifactId>
            <version>2.3</version>
    	<configuration>
              <configLocation>sun_checks.xml</configLocation>
            </configuration>
    
            
          </plugin>
    	  
    	  
    	  <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-pmd-plugin</artifactId>
            <version>2.3</version>
            <configuration>
              <linkXref>true</linkXref>
              <sourceEncoding>utf-8</sourceEncoding>
              <minimumTokens>100</minimumTokens>
              <targetJdk>1.5</targetJdk>
              
            </configuration>
          </plugin>
    	  
        </plugins>
    
      </reporting>
    
    <build>
     <plugins>
          <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-checkstyle-plugin</artifactId>
            <version>2.3</version>
            <configuration>
              <enableRulesSummary>false</enableRulesSummary>
            </configuration>
    		 
    
          </plugin>
    	  
    	        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-pmd-plugin</artifactId>
            <version>2.3</version>
          </plugin>
    
    	    
        </plugins>
      </build>

    le resultat de la commande mvn site:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    [INFO] Scanning for projects...
    [INFO] ------------------------------------------------------------------------
    [INFO] Building Unnamed - ToWeb:ToWeb:ear:0.0.1-SNAPSHOT
    [INFO]    task-segment: [site]
    [INFO] ------------------------------------------------------------------------
    [INFO] [site:site {execution: default-site}]
    [WARNING] No URL defined for the project - decoration links will not be resolved
    
    [INFO] artifact org.apache.maven.skins:maven-default-skin: checking for updates
    from central
    [INFO] Generating "Issue Tracking" report.
    [INFO] Generating "Project Summary" report.
    [INFO] Generating "Mailing Lists" report.
    [INFO] Generating "CPD Report" report.
    [WARNING] Unable to locate Source XRef to link to - DISABLED
    [INFO] Generating "Source Repository" report.
    [INFO] Generating "Plugin Management" report.
    [INFO] Generating "Continuous Integration" report.
    [INFO] Generating "About" report.
    [INFO] Generating "Dependencies" report.
    [INFO] Generating "Project License" report.
    [INFO] Generating "Project Team" report.
    [INFO] Generating "PMD Report" report.
    [WARNING] Unable to locate Source XRef to link to - DISABLED
    [INFO] Generating "Project Plugins" report.
    [INFO] ------------------------------------------------------------------------
    [INFO] BUILD SUCCESSFUL
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 30 seconds
    [INFO] Finished at: Thu Sep 10 13:21:20 GMT 2009
    [INFO] Final Memory: 25M/47M
    [INFO] ------------------------------------------------------------------------

    je ne comprend pas pourquoi je n'ai pas de report checkstyle :s pourtant j'ai tout fait

    merci d'avance pour votre aide

  2. #2
    Membre à l'essai
    Inscrit en
    septembre 2009
    Messages
    29
    Détails du profil
    Informations forums :
    Inscription : septembre 2009
    Messages : 29
    Points : 19
    Points
    19
    Par défaut
    Bonjour,

    j'ai trouvé ou est le problème, je n'ai pas indiqué le repertoire de mes sources... apaprement maven check par defaut le rep src/main

    voici la balise a ajouter dans le pom:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    <project>
        ...
        <build>
            ...
            <sourceDirectory>mon/repertoire/de/src</sourceDirectory>
        <build>
        ...
    </project>
    merci

  3. #3
    Membre régulier

    Inscrit en
    novembre 2007
    Messages
    121
    Détails du profil
    Informations forums :
    Inscription : novembre 2007
    Messages : 121
    Points : 104
    Points
    104
    Par défaut
    Salut,

    Normalement il est censé utiliser la valeur de $(project.build.sourceDirectory) par défaut.

    Cf. : http://maven.apache.org/plugins/mave...ourceDirectory

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [Maven] Génération des reports avec site
    Par xxaragornxx dans le forum Maven
    Réponses: 2
    Dernier message: 28/07/2011, 17h59
  2. probleme avec rave report
    Par barucca dans le forum Delphi
    Réponses: 3
    Dernier message: 23/11/2006, 17h34
  3. [Maven 2] Junit Test Report
    Par ange bleu dans le forum Maven
    Réponses: 2
    Dernier message: 28/08/2006, 10h46
  4. Réponses: 3
    Dernier message: 24/07/2006, 15h54
  5. probleme avec rave report
    Par lassmust dans le forum Bases de données
    Réponses: 5
    Dernier message: 10/10/2005, 18h22

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo