IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Zend PHP Discussion :

Exception : SQLSTATE[HY093]: Invalid parameter number: no parameters were bound


Sujet :

Zend PHP

  1. #1
    Membre habitué Avatar de JQueen
    Inscrit en
    Octobre 2008
    Messages
    214
    Détails du profil
    Informations personnelles :
    Âge : 37

    Informations forums :
    Inscription : Octobre 2008
    Messages : 214
    Points : 126
    Points
    126
    Par défaut Exception : SQLSTATE[HY093]: Invalid parameter number: no parameters were bound
    bonjour,
    je suis en train de travailler sous l'environnement suivant : wamp + MVC + Zend
    je suis en train de developper une application de gestion de projets.
    en ce moment, je suis en train de créer les pages de gestions des clients (ajout, modificatio, suppression ), j'ai ecrit les formulaires. Ils s'affiche bien.Lorsque j'effectue les modifications que je veus faire sur un client bien donné et je valide, le message suivant s'affiche :

    Exception information:
    Message:SQLSTATE[HY093]: Invalid parameter number: no parameters were bound


    et voila la trace de la pile:
    #0 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Db\Statement.php(283): Zend_Db_Statement_Pdo->_execute(Array)
    #1 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Db\Adapter\Abstract.php(464): Zend_Db_Statement->execute(Array)
    #2 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Db\Adapter\Pdo\Abstract.php(232): Zend_Db_Adapter_Abstract->query(Object(Zend_Db_Select), Array)
    #3 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Db\Adapter\Abstract.php(721): Zend_Db_Adapter_Pdo_Abstract->query(Object(Zend_Db_Select), Array)
    #4 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Validate\Db\Abstract.php(128): Zend_Db_Adapter_Abstract->fetchRow(Object(Zend_Db_Select), Array, 2)
    #5 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Validate\Db\NoRecordExists.php(44): Zend_Validate_Db_Abstract->_query('slim@hotmail.co...')
    #6 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Form\Element.php(1318): Zend_Validate_Db_NoRecordExists->isValid('slim@hotmail.co...', Array)
    #7 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Form.php(2002): Zend_Form_Element->isValid('slim@hotmail.co...', Array)
    #8 C:\wamp2.0\www\workspace\GestionProjet\application\controllers\ClientController.php(79): Zend_Form->isValid(Array)
    #9 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Controller\Action.php(512): ClientController->modifierAction()
    #10 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Controller\Dispatcher\Standard.php(288): Zend_Controller_Action->dispatch('modifierAction')
    #11 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Controller\Front.php(945): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
    #12 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Application\Bootstrap\Bootstrap.php(77): Zend_Controller_Front->dispatch()
    #13 C:\wamp2.0\www\workspace\GestionProjet\library\Zend\Application.php(328): Zend_Application_Bootstrap_Bootstrap->run()
    #14 C:\wamp2.0\www\workspace\GestionProjet\public\index.php(26): Zend_Application->run()
    #15 {main}
    Je crois que c un problème au niveau de l'accés à la base mais je ne sais pas c quoi exactement.
    Si quelqu'un peus aider, je serais reconnaissante
    cordialement

  2. #2
    Membre habitué Avatar de JQueen
    Inscrit en
    Octobre 2008
    Messages
    214
    Détails du profil
    Informations personnelles :
    Âge : 37

    Informations forums :
    Inscription : Octobre 2008
    Messages : 214
    Points : 126
    Points
    126
    Par défaut
    salut,
    j'ai essayé de resoudre mon problème toute seule vu qu'il n'ya aucune réponse.
    J'ai diminué le nombre de champ a remplir dans le formulaire et j'ai effectué une modification.
    Le message d'erreur ne s'affiche plus.
    Le problème maintenant est que j'ai besoin d'afficher tous les champs pour donner la possibilité à l'utilisateur de modifier l'info qu'il veut.
    Quoi faire alors ?
    S'il y'as des suggestions je serais reconnaissantes
    Merci
    Cordialement

  3. #3
    Rédacteur
    Avatar de Yoshio
    Homme Profil pro
    Inscrit en
    Septembre 2005
    Messages
    1 732
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : Belgique

    Informations forums :
    Inscription : Septembre 2005
    Messages : 1 732
    Points : 2 853
    Points
    2 853
    Par défaut
    Montre nous ton code et nous pourrons peut-être t'aider.

    L'erreur que tu as, est sans doute que tu as ajouter un paramètre dans ta requête SQL mais tu ne l'a pas spécifié dans les bindParams() ou le tableaux de paramètres dans l'execute(). Ou l'inverse, tu as mis un paramètre en trop dans avec bindParams ou execute.

  4. #4
    Membre habitué Avatar de JQueen
    Inscrit en
    Octobre 2008
    Messages
    214
    Détails du profil
    Informations personnelles :
    Âge : 37

    Informations forums :
    Inscription : Octobre 2008
    Messages : 214
    Points : 126
    Points
    126
    Par défaut
    salut,
    le problème était d'un manque d'attention, j'ai oublié de passer l'argument $id de la méthode d'ajout, c'est pourquoi il m'affiche ce message d'erreur.
    Merci pour l'aide ...

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 2
    Dernier message: 08/04/2015, 20h59
  2. [PDO] Erreur execute(): SQLSTATE[HY093]: Invalid parameter number: number of bound variables
    Par Aaymeric91 dans le forum PHP & Base de données
    Réponses: 10
    Dernier message: 30/09/2013, 17h27
  3. Réponses: 3
    Dernier message: 22/05/2013, 13h06
  4. [Doctrine] SQLSTATE[HY093]: Invalid parameter number
    Par fastone650 dans le forum ORM
    Réponses: 6
    Dernier message: 09/07/2011, 20h41
  5. Réponses: 6
    Dernier message: 03/06/2010, 10h09

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo