1. #1
    Membre du Club
    Inscrit en
    novembre 2006
    Messages
    80
    Détails du profil
    Informations forums :
    Inscription : novembre 2006
    Messages : 80
    Points : 67
    Points
    67

    Par défaut Changer le nom de l'interface réseau eth0

    Bonjour,
    Je suis sous linux Centos 5, je retrouve que l'interface reseau qui est censé avoir le nom eth0, a changé de nom et son nom est dev27683.
    Je voudrais changer dev27683 par eth0. J'ai cherché dans tous les fichier de conf rezo pour chercher où se trouve l'écriture dev27683 mais je n'ai pas toruvé.

    Voici quelques information sur la conf de ma machine :

    dev27683 Link encap:Ethernet HWaddr 00:14:4F:40:A7:F8
    inet6 addr: fe80::214:4fff:fe40:a7f8/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:1163 errors:0 dropped:0 overruns:0 frame:0
    TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:74432 (72.6 KiB) TX bytes:398 (398.0 b)
    Base address:0x9c00 Memory:fbfe0000-fc000000

    eth1 Link encap:Ethernet HWaddr 00:14:4F:40:A7:F9
    inet addr:192.168.175.240 Bcast:192.168.175.255 Mask:255.255.255.0
    inet6 addr: fe80::214:4fff:fe40:a7f9/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:1586674 errors:0 dropped:0 overruns:0 frame:0
    TX packets:756531 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1042301550 (994.0 MiB) TX bytes:163346736 (155.7 MiB)
    Base address:0x9800 Memory:fbfc0000-fbfe0000


    [root@localhost dev]# ethtool dev27683
    Settings for dev27683:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: umbg
    Wake-on: d
    Current message level: 0x00000007 (7)
    Link detected: yes

    [root@localhost dev]# cat /etc/modprobe.conf
    alias eth0 e1000
    alias eth1 e1000
    alias eth2 e1000
    alias eth3 e1000
    alias scsi_hostadapter mptbase
    alias scsi_hostadapter1 mptscsih
    alias usb-controller ohci-hcd
    alias bond0 bonding
    options bond0 mode=active-backup miimon=100 max_bonds=2
    Merci de votre aide.

  2. #2
    Membre averti
    Profil pro
    Inscrit en
    juillet 2008
    Messages
    406
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2008
    Messages : 406
    Points : 379
    Points
    379

    Par défaut

    Salut,
    édite le fichier suivant en mode administrateur.
    Par exemple, avec "vi" :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    #vi /etc/udev/rules.d/70-persistent-net.rules
    Dans le fichier, tu verras l'attribut "NAME" que tu pourras changer.

  3. #3
    Membre du Club
    Inscrit en
    novembre 2006
    Messages
    80
    Détails du profil
    Informations forums :
    Inscription : novembre 2006
    Messages : 80
    Points : 67
    Points
    67

    Par défaut

    Citation Envoyé par zakaria84 Voir le message
    Salut,
    édite le fichier suivant en mode administrateur.
    Par exemple, avec "vi" :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    #vi /etc /udev/rules.d/70-persistent-net.rules
    Dans le fichier, tu verras l'attribut "NAME" que tu pourras changer.

    Salut,

    ce fichier n'existe pas dans cet emplacement? je me demande d'où est ce que le system récupère la valeur de cet interface rezo.

    Merci

  4. #4
    Membre averti
    Profil pro
    Inscrit en
    juillet 2008
    Messages
    406
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2008
    Messages : 406
    Points : 379
    Points
    379

    Par défaut

    Il y avait un espace qui traînait, j'ai modifié!
    Regarde si l'adresse existe ou pas ... (je l'ai testé sur Ubuntu et ça existe bel et bien)

  5. #5
    Membre du Club
    Inscrit en
    novembre 2006
    Messages
    80
    Détails du profil
    Informations forums :
    Inscription : novembre 2006
    Messages : 80
    Points : 67
    Points
    67

    Par défaut

    Je ne suis pas sur ubunto, je suis sur Centos, c'est la même chose que Fedora ou Redhat ...j'ai pas ce fichier ...

  6. #6
    Membre averti
    Profil pro
    Inscrit en
    juillet 2008
    Messages
    406
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2008
    Messages : 406
    Points : 379
    Points
    379

    Par défaut

    Je sais que tu es sur Centos ...
    Essaie de voir d'avoir si tu as le répertoire "/etc/udev"
    Si oui, tu auras certainement un truc qui ressemble à "70-persistent-net.rules", "10-vboxdrv.rules" ou "60-vboxdrv.rules" ... ça dépend de la version du noyau que tu as!

  7. #7
    Membre du Club
    Inscrit en
    novembre 2006
    Messages
    80
    Détails du profil
    Informations forums :
    Inscription : novembre 2006
    Messages : 80
    Points : 67
    Points
    67

    Par défaut Une regression redhat

    C'est un bug redhat connu (regression after 4u4), regardez les deux liens suivants sur le site de redhat :

    http://kbase.redhat.com/faq/docs/DOC-1315
    http://kbase.redhat.com/faq/docs/DOC-15331

    Merci

  8. #8
    Nouveau membre du Club
    Homme Profil pro
    Technicien réseaux et télécoms
    Inscrit en
    septembre 2006
    Messages
    42
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Technicien réseaux et télécoms
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : septembre 2006
    Messages : 42
    Points : 37
    Points
    37

    Par défaut

    Hello tout le monde,

    J'ai suivi ce fil de discussion et suis dans le même cas, suis sous Debian 9 et aucun fichier dans mon répertoire /etc/udev/rules.d/

    Il est vide !

  9. #9
    Membre actif Avatar de Lekno
    Femme Profil pro
    Étudiant
    Inscrit en
    septembre 2010
    Messages
    515
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 28
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : septembre 2010
    Messages : 515
    Points : 265
    Points
    265

    Par défaut

    Citation Envoyé par Silverscott Voir le message
    Hello tout le monde,

    J'ai suivi ce fil de discussion et suis dans le même cas, suis sous Debian 9 et aucun fichier dans mon répertoire /etc/udev/rules.d/

    Il est vide !
    Les fichiers de configuration Debian ne sont pas au même endroit que sous Centos, c'est pour cela que tu ne les trouve pas

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 1
    Dernier message: 09/07/2012, 11h49
  2. Réponses: 5
    Dernier message: 19/10/2009, 04h02
  3. Changer l'interface réseau pour smtplib ? ( VIPs)
    Par Cypra dans le forum Réseau/Web
    Réponses: 0
    Dernier message: 13/05/2009, 22h13
  4. Changer le Nom de la SUSE Sur le réseau
    Par kfmystik dans le forum SUSE
    Réponses: 1
    Dernier message: 15/07/2008, 17h54
  5. Réponses: 2
    Dernier message: 26/06/2002, 13h16

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo