IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

SAS Base Discussion :

erreur Connect: Classe non enregistrée [FAQ]


Sujet :

SAS Base

  1. #1
    Nouveau membre du Club
    Profil pro
    Inscrit en
    avril 2009
    Messages
    29
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2009
    Messages : 29
    Points : 29
    Points
    29
    Par défaut erreur Connect: Classe non enregistrée
    Bonjour à tous,

    J'essaye d'importer un fichier Excel via l'assistant d'importation et le journal me donne l'erreur suivante :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    ERROR: Connect: Classe non enregistrée
    Quelqu'un aurait-il une idée de la manière de remédier à ce problème.
    Merci d'avance

  2. #2
    Expert confirmé
    Avatar de olivier.decourt
    Homme Profil pro
    Formateur R/SAS/statistiques
    Inscrit en
    avril 2008
    Messages
    1 974
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 43
    Localisation : France

    Informations professionnelles :
    Activité : Formateur R/SAS/statistiques
    Secteur : Conseil

    Informations forums :
    Inscription : avril 2008
    Messages : 1 974
    Points : 4 332
    Points
    4 332
    Par défaut
    Bonjour.
    La cause de ce message, c'est souvent le moteur de discussion Microsoft Jet (qui fait l'interface entre SAS et Excel) qui n'est pas bien installé.
    Détails sur le site du support de l'éditeur : ici.
    En espérant que c'est bien dû à ça.
    Olivier
    Bon courage.
    Olivier

  3. #3
    Nouveau membre du Club
    Profil pro
    Inscrit en
    avril 2009
    Messages
    29
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2009
    Messages : 29
    Points : 29
    Points
    29
    Par défaut
    La mise à jour a été tentée,un message a signalé que la version de mise à jour était plus ancienne. Le problème persiste....

  4. #4
    Nouveau membre du Club
    Profil pro
    Inscrit en
    avril 2009
    Messages
    29
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2009
    Messages : 29
    Points : 29
    Points
    29
    Par défaut
    Je vais tenter de réinstaller SAS sur le champ.

  5. #5
    Rédacteur

    Homme Profil pro
    SAS ALLIANCE SILVER. Consultant et formateur SAS et Cognos.
    Inscrit en
    avril 2009
    Messages
    2 497
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : SAS ALLIANCE SILVER. Consultant et formateur SAS et Cognos.
    Secteur : Conseil

    Informations forums :
    Inscription : avril 2009
    Messages : 2 497
    Points : 6 064
    Points
    6 064
    Par défaut
    Tu as pris le lien envoyé par Olivier, tu as mis à jour le PC mais tu obtiens un message indiquant que ta version de MSJet est plus ancienne ?

    Réinstaller tout SAS ne t'amènera pas forcément une solution, ACCESS to PC FILES interface simplement le MSJet. Tu pourrais retrouver la même situation

    Stéphane.
    N'oubliez pas de cliquer sur lorsque votre problème est réglé !

  6. #6
    Nouveau membre du Club
    Profil pro
    Inscrit en
    avril 2009
    Messages
    29
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2009
    Messages : 29
    Points : 29
    Points
    29
    Par défaut
    A titre informatif le problème a été résolu en lançant l'éxécutable

    AccessDatabaseEngine.exe

    Se trouvant dans :

    products\sysreqwizard__92210__prt__xx__sp0__1\redist\ace\en

  7. #7
    Membre du Club
    Profil pro
    Inscrit en
    avril 2009
    Messages
    31
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2009
    Messages : 31
    Points : 41
    Points
    41
    Par défaut
    Bonjour,
    On vient d'installer SAS9.2 et j'ai exactement le même message dans la log lorsque j'essaie d'effectuer un proc export dans Excel

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    ERROR: Connect: Classe non enregistrée
    ERROR: Erreur dans l'instruction LIBNAME.
    Echec de la connexion.  Consultez le Journal pour plus d'informations.
    On a essayé de faire la mise à jour de MS Jet mais à priori la version que l'on a est plus récente !

    Je n'ai pas très bien compris le dernier message de chrisbdx.

    Qq'un pourrait m'éclairer s'il vous plait ?

    Merci bien.

  8. #8
    Membre du Club
    Profil pro
    Inscrit en
    avril 2009
    Messages
    31
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2009
    Messages : 31
    Points : 41
    Points
    41
    Par défaut
    Une informaticienne de la société est venue exécuter le fichier AccessDatabaseEngine.exe et effectivement ça marche !

  9. #9
    Membre du Club
    Inscrit en
    décembre 2009
    Messages
    90
    Détails du profil
    Informations forums :
    Inscription : décembre 2009
    Messages : 90
    Points : 55
    Points
    55
    Par défaut
    Bonjour,

    et où trouvez-vous ces fichier AccessDatabaseEngine.exe et product\...... ?

  10. #10
    Rédacteur

    Homme Profil pro
    SAS ALLIANCE SILVER. Consultant et formateur SAS et Cognos.
    Inscrit en
    avril 2009
    Messages
    2 497
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : SAS ALLIANCE SILVER. Consultant et formateur SAS et Cognos.
    Secteur : Conseil

    Informations forums :
    Inscription : avril 2009
    Messages : 2 497
    Points : 6 064
    Points
    6 064
    Par défaut
    dans ton dépôt.
    N'oubliez pas de cliquer sur lorsque votre problème est réglé !

  11. #11
    Membre du Club
    Inscrit en
    décembre 2009
    Messages
    90
    Détails du profil
    Informations forums :
    Inscription : décembre 2009
    Messages : 90
    Points : 55
    Points
    55
    Par défaut
    qu'est-ce que tu apelles dépôt ?

  12. #12
    Rédacteur

    Homme Profil pro
    SAS ALLIANCE SILVER. Consultant et formateur SAS et Cognos.
    Inscrit en
    avril 2009
    Messages
    2 497
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : SAS ALLIANCE SILVER. Consultant et formateur SAS et Cognos.
    Secteur : Conseil

    Informations forums :
    Inscription : avril 2009
    Messages : 2 497
    Points : 6 064
    Points
    6 064
    Par défaut
    bon... disons que ce sont tes CD.
    N'oubliez pas de cliquer sur lorsque votre problème est réglé !

  13. #13
    Futur Membre du Club
    Profil pro
    Inscrit en
    juin 2009
    Messages
    7
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2009
    Messages : 7
    Points : 7
    Points
    7
    Par défaut
    Je confirme, apres passer de la version 9.1 à la 9.2, j'ai eu le même message d'erreur du à une mauvaise installation de AccessDatabaseEngine.exe (lecteur DVD : "products\sysreqwizard__92210__prt__xx__sp0__1\redist\ace\en ")
    merci a vous ! Tout est rentré dans l'ordre !

    JB

  14. #14
    Futur Membre du Club
    Profil pro
    Inscrit en
    décembre 2009
    Messages
    5
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2009
    Messages : 5
    Points : 5
    Points
    5
    Par défaut
    Merci à tous,
    Vous venez de me sauver la vie en moins de 10mn ...
    J'ai remis la main sur mon CD (1/3) d'installation et ai exécuté le AccessDatabaseEngine.exe comme spécifié et çà à re-fonctionné du 1er coup.

    Encore merci,
    Dave

  15. #15
    Membre expérimenté
    Inscrit en
    novembre 2009
    Messages
    698
    Détails du profil
    Informations forums :
    Inscription : novembre 2009
    Messages : 698
    Points : 1 300
    Points
    1 300
    Par défaut erreur Connect: Classe non enregistrée
    Bonjour,

    Je viens de rencontrer le même message d'erreur lors de l'import d'un fichier Excel, cette fois dû à la migration d’un environnement où SAS et Excel étaient installés dans le même adressage (c’est-à-dire étaient tous les deux en 32-bit, ou tous les deux en 64-bit) vers un environnement où SAS et Excel sont dans des adressages différents.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    ERROR: Connect: Classe non enregistrée
    ERROR: Error in the LIBNAME statement.
    Echec de la connexion.  Consultez le Journal pour plus d'informations.
    Le document du support SAS ci-joint explique bien les différentes solutions d'import / export :

    Qu’apporte la version 9.4 de sas pour écrire/lire des fichiers Excel et créer des rapports Excel ?

    Cordialement,

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [Flash Pascal] Erreur Classe non enregistrée
    Par Roland Chastain dans le forum Flash Pascal
    Réponses: 10
    Dernier message: 07/11/2012, 19h55
  2. Erreur : Classe non enregistré
    Par thomasaurelien dans le forum VB.NET
    Réponses: 5
    Dernier message: 13/09/2012, 21h58
  3. Erreur Classe non enregistrée
    Par xps1616 dans le forum Framework .NET
    Réponses: 3
    Dernier message: 09/09/2012, 11h36
  4. Erreur « Classe Non Enregistrée »
    Par Chri8De dans le forum Autres Logiciels
    Réponses: 3
    Dernier message: 22/08/2011, 08h04
  5. Erreur Classe non enregistrée
    Par nassoft dans le forum Delphi
    Réponses: 13
    Dernier message: 26/05/2007, 12h56

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo