Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Autres hébergeurs Discussion :

Activer l'URL rewriting chez Belgacom-skynet (Belgique)


Sujet :

Autres hébergeurs

  1. #1
    Nouveau membre du Club
    Inscrit en
    octobre 2006
    Messages
    49
    Détails du profil
    Informations forums :
    Inscription : octobre 2006
    Messages : 49
    Points : 31
    Points
    31
    Par défaut Activer l'URL rewriting chez Belgacom-skynet (Belgique)
    hello

    J'ai un site en php hébergé chez Belgacom (Belgique) et j'aurais besoin d'activer l'url rewriting pour le référencement.
    J'ai appelé Belgacom et ils me disent 'oui, c'est possible' et 'on ne le fait pas mais vous pouvez le faire vous-même' ...sans me dire plus ... glups...
    Alors me voilà penaud .... comment faire??
    Je fais appel à vos précieux conseils

    merci everybody

  2. #2
    Expert éminent
    Avatar de 12monkeys
    Homme Profil pro
    Webmaster
    Inscrit en
    novembre 2006
    Messages
    4 093
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : France, Puy de Dôme (Auvergne)

    Informations professionnelles :
    Activité : Webmaster
    Secteur : Service public

    Informations forums :
    Inscription : novembre 2006
    Messages : 4 093
    Points : 9 049
    Points
    9 049
    Vous souhaitez participer à la rubrique (X)HTML/CSS, contactez moi.
    débutez avec les CSS
    Pas de MP pour des questions techniques ! Mode d'emploi du forum ; Règles ; Pensez à la balise code ; Pas de SMS !
    Votez pour les messages qui vous ont aidés...

  3. #3
    Nouveau membre du Club
    Inscrit en
    octobre 2006
    Messages
    49
    Détails du profil
    Informations forums :
    Inscription : octobre 2006
    Messages : 49
    Points : 31
    Points
    31
    Par défaut
    salut

    merci pour cette réponse. Je sens que je vais devoir acheter une nouvelle boite d'aspirines
    J'ai regardé les liens que tu as cité. Je vois par exemple qu'on évoque un certain fichier 'httpd.conf', mais où puis-je trouver ce fichier? J'ai uniquement accès à mes fichiers dans la racine de mon site. Pas de trace de ce fichier conf.
    Le support tech avait pourtant l'air de dire que des utilisateurs le faisaient eux-mêmes. Je suis certainement plus novice qu'eux.
    J'ai fais un fichier test avec un .htaccess trouvé dans un autre tuto sensé vérifier l'activation du url rewriting et voici ce qu'il me donne en réponse:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    
    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    
    More information about this error may be available in the server error log.
    
    Apache/1.3.33 Server at file-hostingst506.isp.belgacom.be Port 80

  4. #4
    Nouveau membre du Club
    Inscrit en
    octobre 2006
    Messages
    49
    Détails du profil
    Informations forums :
    Inscription : octobre 2006
    Messages : 49
    Points : 31
    Points
    31
    Par défaut
    Hello

    je continue à galérer avec ce problème.
    Ils m'ont encore certifié que la fonction était possible
    Cependant je n'y suis toujours pas parvenu ;(
    Ils m'ont donné l'url d'un faq concernant l'hébergement Unix.
    accéder à phpmyadmin pourrait-il m'aider?
    en essayant de me loger avec les identifiants fournis il me retourne ce message:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    Secure Connection Failed
      
    
    www.clicmusic.be uses an invalid security certificate.
    
    The certificate is only valid for sharedhosting.skynet.be
    
    (Error code: ssl_error_bad_cert_domain)
    
    
    
        * This could be a problem with the server's configuration, or it could be someone trying to impersonate the server.
    
        * If you have connected to this server successfully in the past, the error may be temporary, and you can try again later.
    
    
              Or you can add an exception…
    et si j'ajoute une exception, la page phpmyadmin me met:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    Error
    #2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)
    Bon, ça je vais voir avec Skynet

    J'ai fais un fichier test qui ne semble pas marcher
    Je continue de chercher ...

  5. #5
    Membre à l'essai
    Profil pro
    Inscrit en
    mars 2006
    Messages
    7
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations forums :
    Inscription : mars 2006
    Messages : 7
    Points : 11
    Points
    11
    Par défaut idem
    Salut,

    Est-ce que tu as déjà trouvé une solution à ton problème ?
    ou tu as changé d'hébergeur...

    Car je suis dans le même cas...

    Ciao
    Tom

  6. #6
    Membre à l'essai
    Profil pro
    Inscrit en
    mars 2006
    Messages
    7
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations forums :
    Inscription : mars 2006
    Messages : 7
    Points : 11
    Points
    11
    Par défaut enfin...
    Bon, j'ai décidé d'obtenir la réponse de Belgacom... donc après plusieurs mails et appels...j'ai enfin ma réponse...

    Pour ceux que cela intéresse...
    Il faut mettre l'adresse complète et non un chemin relatif...

    RewriteEngine on
    RewriteRule ^(.*)/(.*)/1$ http://www.domaine.be/test.php?a=$1&b=$2 [L]
    ErrorDocument 404 http://www.domaine.be/index.php

    Cela fonctionne chez moi.
    Chose étrange, c'est qu'il retransforme l'adresse :
    Si je tappe : http://www.domaine.be/test/34/1
    j'arrive bien sur la page souhaitée, mais au lieu de laisser l'adresse (http://www.domaine.be/test/34/1), il inscrit comme adresse http://www.domaine.be/test.php?a=test&b=34

    Enfin, je suis déjà content que cela fonctionne... dans 6 mois j'aurai peut-être ma réponse du pourquoi il retransforme l'adresse...
    Suite au prochain épisode...

    Tom

  7. #7
    Nouveau Candidat au Club
    Profil pro
    Inscrit en
    janvier 2011
    Messages
    1
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations forums :
    Inscription : janvier 2011
    Messages : 1
    Points : 1
    Points
    1
    Par défaut Solution 100% fonctionnelle ...
    Bonjour,

    J'avais exactement le même problème que vous avec mon site OS Commerce qui est également hébergé chez Belgacom (Shared Unix Hosting).

    Après plusieurs jours de recherches et de tests j'ai finalement réussi à implémenter le module Ultimate SEO URL (URL Rewrite - friendly urls).

    Voici la solution pour ceux qui sont dans le même cas :

    - Il ne faut surtout pas utiliser l'Option "Options +FollowSymLinks" qui ne fonctionne pas chez Belgacom, simplement mettre cette instruction en commentaire (mettre # devant la ligne de commande) ou supprimer la ligne.
    - Il faut également définir le chemin absolu de votre hosting Unix Belgacom grâce à l'instruction RewriteBase (remplacez "users/1/web/00/00/12/34/56/" par votre chemin absolu)

    Voici le code à mettre dans le fichier .htaccess
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    # Options +FollowSymLinks
    RewriteEngine On 
    RewriteBase /users/1/web/00/00/12/34/56/
    
    RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
    .....
    J'espère que cette solution vous sera utile, je sais combien le helpdesk Belgacom est mauvais... si seulement ils avaient pu me donner ces explications je n'aurais pas perdu plusieurs jours... je suis certains que vous êtes nombreux à être dans le même cas ...

    A+
    Laurent

  8. #8
    Nouveau Candidat au Club
    Profil pro
    Inscrit en
    novembre 2012
    Messages
    1
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations forums :
    Inscription : novembre 2012
    Messages : 1
    Points : 1
    Points
    1
    Par défaut
    Un grand merci Laurent.

    Tu m'a probablement fait gagner de nombreuses heures de recherche

Discussions similaires

  1. Activer l'URL Rewriting
    Par ilyass85 dans le forum Apache
    Réponses: 4
    Dernier message: 17/09/2007, 14h51
  2. url rewriting chez OVH
    Par nolwenn dans le forum Apache
    Réponses: 1
    Dernier message: 20/08/2007, 00h16
  3. URL Rewriting chez 1&1
    Par Alamb dans le forum MVC
    Réponses: 2
    Dernier message: 08/08/2007, 21h32
  4. URL rewriting chez OVH ?
    Par titoumimi dans le forum Apache
    Réponses: 2
    Dernier message: 08/10/2006, 21h22
  5. Activer l'url rewriting
    Par Otaugames dans le forum Apache
    Réponses: 2
    Dernier message: 09/03/2005, 15h58

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo