IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Oracle Discussion :

[Oracle 10G AS Win2003] opatch apply ne fonctionne pas


Sujet :

Oracle

  1. #1
    Membre régulier
    Homme Profil pro
    Développeur Web
    Inscrit en
    octobre 2003
    Messages
    87
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Associations - ONG

    Informations forums :
    Inscription : octobre 2003
    Messages : 87
    Points : 90
    Points
    90
    Par défaut [Oracle 10G AS Win2003] opatch apply ne fonctionne pas
    Bonjour,
    Toujours aussi débutant sur Oracle, j’ai installé une instance Oracle Application Server 10G sur un Server Windows 2003.

    J’ai suivi la commande proposée par le didacticiel fournis. A savoir :
    -transférer le zip sur votre serveur d’application
    -le dezipper dans un répertoire temporaire
    -aller dans le répertoire nouvellement créé : cd 5023945
    -lancer la mise à jour : opatch apply
    Vous l’aurez compris, j’installe le patch 5023945.

    Or, quand je tape la commande opatch apply, rien ne se passe. Le message suivant apparaît :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    'opatch' n'est pas reconnu en tant que commande interne ou externe, un programme ou un fichier de commandes.
    [
    J’ai l’impression que perl n’est pas actif sur le serveur.
    Voici ma configuration :
    C:\OraHome_AS (instance Oracle AS)
    C:\OraHome_AS\OPatch (répertoire où se trouve OPatch)
    C:\OraHome_AS\perl\5.6.1\bin\MSWin32-x86\perl.exe

    Dans le forum, on renvoie vers la doc Oracle Metalink suivante : METALINK 308916.1
    Mais ce lien préconise d’installer une nouvelle fois Perl dans un autre répertoire. Est-ce utile si les fichiers Perl existent bien ?
    Par avance, je vous remercie de votre aide.

  2. #2
    Membre régulier
    Homme Profil pro
    Développeur Web
    Inscrit en
    octobre 2003
    Messages
    87
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Associations - ONG

    Informations forums :
    Inscription : octobre 2003
    Messages : 87
    Points : 90
    Points
    90
    Par défaut
    Bon, je viens de franchir une étape.
    Il manquait le chemin vers ORACLE_HOME en variable système.
    Je peux maintenant lancer la commande opatch.
    Je me place dans le répertoire c:\patches\5023945 (où le patch est décompressé) . De là, je lance :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    C:\patches>C:\OraHome_AS\perl\5.6.1\bin\MSWin32-x86\perl.exe C:\OraHome_AS\OPatch\opatch.pl apply
    Le processus se lance et renvoie :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    The patch directory area must be a number
    ERROR: OPatch failed because of problems in patch area.
    Avez-vous déjà eu ce problème ?

    Je précise que les commandes
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    C:\OraHome_AS\perl\5.6.1\bin\MSWin32-x86\perl.exe C:\OraHome_AS\OPatch\opatch.pl lsinventory
    et
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    C:\OraHome_AS\perl\5.6.1\bin\MSWin32-x86\perl.exe C:\OraHome_AS\OPatch\opatch.pl lsinventory -detail
    fonctionnent très bien.

  3. #3
    Membre régulier
    Homme Profil pro
    Développeur Web
    Inscrit en
    octobre 2003
    Messages
    87
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Associations - ONG

    Informations forums :
    Inscription : octobre 2003
    Messages : 87
    Points : 90
    Points
    90
    Par défaut
    Finalement, il manquait deux fichiers dans le répertoire du patch (surement un problème de téléchargement).
    Avec un bon zip, ça fonctionne bcp mieux

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [Oracle 10g] La console ne fonctionne pas
    Par hobotalker dans le forum Administration
    Réponses: 5
    Dernier message: 17/12/2008, 17h45
  2. appli ne fonctionne pas hors netbeans
    Par nutix2003 dans le forum NetBeans
    Réponses: 4
    Dernier message: 22/10/2006, 12h58
  3. la publication de mon appli ne fonctionne pas
    Par tchecko dans le forum Accès aux données
    Réponses: 4
    Dernier message: 07/10/2006, 12h59
  4. [Oracle DB 10G][OEM] localhost ne fonctionne pas
    Par Stessy dans le forum Oracle
    Réponses: 7
    Dernier message: 21/08/2006, 17h25
  5. Réponses: 14
    Dernier message: 17/08/2006, 11h29

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo