IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Apache Discussion :

.htaccess et erreur 404


Sujet :

Apache

  1. #1
    Membre habitué
    Avatar de Oncle_Pete
    Profil pro
    Inscrit en
    avril 2006
    Messages
    246
    Détails du profil
    Informations personnelles :
    Localisation : France, Rhône (Rhône Alpes)

    Informations forums :
    Inscription : avril 2006
    Messages : 246
    Points : 173
    Points
    173
    Par défaut .htaccess et erreur 404
    Bonjour,

    J'ai recemment telecharge easyphp 3.0 (je crois la derniere livree).
    J'ai mis a la racine de mon site, outre mes pages php, un fichier .htaccess qui contient la ligne ci-dessous.
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    ErrorDocument 404 error404.php
    Mon serveur a l'air de se moquer de mon fichier et de son contenu.
    S'agit-il d'un pb de syntaxe ou dois-je configuer quelque chose quelque part pour qu'il en tienne compte ?
    Merci a vous si vous avez des idees.

    Oncle Pete
    Experience is the best teacher !!

  2. #2
    Membre expérimenté Avatar de Lorenzo77
    Profil pro
    Inscrit en
    mai 2006
    Messages
    1 472
    Détails du profil
    Informations personnelles :
    Âge : 50
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : mai 2006
    Messages : 1 472
    Points : 1 536
    Points
    1 536
    Par défaut
    -tu es sur qu'Apache trouve ton HTACCESS ?

    normalement on utilise une URL relative ou absolue et pas seulement le nom du fichier, ex pour ton fichier placé a la racine :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    ErrorDocument 404 ./error404.php
    ou
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    ErrorDocument 404 http://www.xxxx.xxx/error404.php

    -en second faut vérifier les autorisations de apache concernant les fichiers HTACCESS


    ------------
    je déplace la discussion dans Apache qui est plus approprié que PHP vu que la question concerne uniquement le serveur
    Le plus grand arbre est né d'une graine menue, une tour de neuf étages est partie d'une poignée de terre.
    Mon blog : http://web.codeur.free.fr

  3. #3
    Membre habitué
    Avatar de Oncle_Pete
    Profil pro
    Inscrit en
    avril 2006
    Messages
    246
    Détails du profil
    Informations personnelles :
    Localisation : France, Rhône (Rhône Alpes)

    Informations forums :
    Inscription : avril 2006
    Messages : 246
    Points : 173
    Points
    173
    Par défaut
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    -tu es sur qu'Apache trouve ton HTACCESS ?
    Ben non justement : je n'en suis pas sur vu que tous mes essais de syntaxe ne marchent pas.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    -en second faut vérifier les autorisations de apache concernant les fichiers HTACCESS
    Ok mais a quel endroit ? Mon fichier httpd.conf me dit :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
     
        AllowOverride None
        Order allow,deny
        Allow from all
    puis plus bas

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    <FilesMatch "^\.ht">
        Order allow,deny
        Deny from all
        Satisfy All
    </FilesMatch>
    Est-ce satisfaisant ?
    Merci

    Oncle Pete
    Experience is the best teacher !!

  4. #4
    Membre expérimenté Avatar de Lorenzo77
    Profil pro
    Inscrit en
    mai 2006
    Messages
    1 472
    Détails du profil
    Informations personnelles :
    Âge : 50
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : mai 2006
    Messages : 1 472
    Points : 1 536
    Points
    1 536
    Par défaut
    Citation Envoyé par Oncle_Pete Voir le message
    Ok mais a quel endroit ? Mon fichier httpd.conf me dit :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
     
        AllowOverride None
        Order allow,deny
        Allow from all
    ben la faut indiquer la tag conteneur sinon on ne sait pas a quoi ces options ce rapportent ...

    Citation Envoyé par Oncle_Pete Voir le message
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    <FilesMatch "^\.ht">
        Order allow,deny
        Deny from all
        Satisfy All
    </FilesMatch>
    ceci est normal, ca bloque le droit des clients de visualiser les fichiers htaccess et htpasswd ce qui serait une ENORME faille de sécu !
    ya juste le "Satisfy All" que je ne connais pas mais si c'est par défaut sur un serveur de production alors pas touche !


    pour l'instant test ce que tu a fait au début (dans le htaccess) sans t'occuper de la config de apache mais avec une URL absolu conduisant a ton PHP !
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    ErrorDocument 404 http://localhost/error404.php
    si ca fonctionne tu sais automatiquement que ton probleme est un ciblage du fichier
    Le plus grand arbre est né d'une graine menue, une tour de neuf étages est partie d'une poignée de terre.
    Mon blog : http://web.codeur.free.fr

  5. #5
    Membre habitué
    Avatar de Oncle_Pete
    Profil pro
    Inscrit en
    avril 2006
    Messages
    246
    Détails du profil
    Informations personnelles :
    Localisation : France, Rhône (Rhône Alpes)

    Informations forums :
    Inscription : avril 2006
    Messages : 246
    Points : 173
    Points
    173
    Par défaut
    Salut Lorenzo77


    Suite a tes conseils, j'ai mis la ligne ci-dsssous dans mon fichier .htaccess
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    ErrorDocument 404 http://127.0.0.1/test/error404.php
    "test" est mon alias et cette ligne colee dans ma bare d'adresse m'ouvre bien ma page error404.php

    J'en conclu que la syntaxe est OK, mais que le pb vient de ma config.
    J'ai donc ouvert mon httpd.conf pour voir le tag conteneur dont tu parles.
    Ca semble etre
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    <Directory "${path}/www">
    Faut il ajouter une ligne, modifier une option ?
    Sinon loin de moi l'idee de toucher a quoi que ce soit dans ce fichier sauf si c'est sous la coupe d'une personne competente

    Merci

    Oncle Pete
    Experience is the best teacher !!

  6. #6
    Membre expérimenté Avatar de Lorenzo77
    Profil pro
    Inscrit en
    mai 2006
    Messages
    1 472
    Détails du profil
    Informations personnelles :
    Âge : 50
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : mai 2006
    Messages : 1 472
    Points : 1 536
    Points
    1 536
    Par défaut
    dans le conf de apache -> AllowOverride All
    SI et seulement si c'est ton propre serveur local .... mais a tester sans au cas ou ...

    ben voila, ensuite tu as juste a mettre ca dans ton htaccess :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    ErrorDocument 404 http://127.0.0.1/test/error404.php
    Le plus grand arbre est né d'une graine menue, une tour de neuf étages est partie d'une poignée de terre.
    Mon blog : http://web.codeur.free.fr

  7. #7
    Membre habitué
    Avatar de Oncle_Pete
    Profil pro
    Inscrit en
    avril 2006
    Messages
    246
    Détails du profil
    Informations personnelles :
    Localisation : France, Rhône (Rhône Alpes)

    Informations forums :
    Inscription : avril 2006
    Messages : 246
    Points : 173
    Points
    173
    Par défaut
    Merci Lorenzo77 car effectivement lorsque je met dans la section "www" de mon répertoire d'installation et que la syntaxe du fichier .htaccess fait reference au root de mon serveur local et ben, ô miracle, ca marche (http://127.0.0.1/error404.php).

    Par contre, ca ne marche toujours pas si je fais reference au repertoire de mon alias "test" (avec http://127.0.0.1/test/error404.php).

    Si vous etes possesseur de la ligne qu'il faut rajouter adns mon fichier de config, je suis preneur, sinon pour moi c'est Resolu car je peux qd meme aller plus loin dans mes travaux.

    Merci encore Lorenzo77

    Oncle Pete
    Experience is the best teacher !!

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [PHP 5.2] .htaccess et erreur 404
    Par Oncle_Pete dans le forum Langage
    Réponses: 1
    Dernier message: 11/02/2009, 15h25
  2. .htaccess erreur 404
    Par kenny_badboy dans le forum Langage
    Réponses: 8
    Dernier message: 28/12/2008, 21h22
  3. [Htaccess] Rediriger vers une page en cas d'erreur 404
    Par Alexandrebox dans le forum Apache
    Réponses: 8
    Dernier message: 12/01/2007, 08h01
  4. .htaccess pour gérer l'erreur 404 : plantage du site
    Par Thomus38 dans le forum Apache
    Réponses: 8
    Dernier message: 19/07/2006, 13h29
  5. htaccess et erreur 404 = resultat aleatoire : (
    Par NoobX dans le forum Apache
    Réponses: 7
    Dernier message: 02/10/2005, 13h52

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo