Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Discussion :

incapable d'installer PostgreSQL/PostGIS sur windows Vista


Sujet :

Installation PostgreSQL

  1. #1
    Membre habitué
    Profil pro
    Inscrit en
    janvier 2007
    Messages
    465
    Détails du profil
    Informations personnelles :
    Localisation : France, Bas Rhin (Alsace)

    Informations forums :
    Inscription : janvier 2007
    Messages : 465
    Points : 154
    Points
    154
    Par défaut incapable d'installer PostgreSQL/PostGIS sur windows Vista
    Bonjour,
    Est ce que quelqu'un connait ou je peux télécharger PostgreSQL/PostGIS pour windows vista. J'ai installé PostgreSQL 8.3, et j'ai utilisé le constructeur de la pile applicative pour installer postGIS mais lorsque j'essaye de créer une BD spatiale avec la commande , Il me demande le mot de passe, je le fournis, mais il me dit que le mot de passe incorrect malgré que je suis sur de ce mot de passe

  2. #2
    Membre confirmé
    Homme Profil pro
    Inscrit en
    janvier 2006
    Messages
    390
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Corse (Corse)

    Informations forums :
    Inscription : janvier 2006
    Messages : 390
    Points : 606
    Points
    606
    Par défaut
    bonjour essaie de preciser l'utilisateur (en general par defaut postgres)
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    createdb -U postgres madatabase

  3. #3
    Membre habitué
    Profil pro
    Inscrit en
    janvier 2007
    Messages
    465
    Détails du profil
    Informations personnelles :
    Localisation : France, Bas Rhin (Alsace)

    Informations forums :
    Inscription : janvier 2007
    Messages : 465
    Points : 154
    Points
    154
    Par défaut
    Bein ça marche pour la crétion de a base de données, mais ça marche pas pour la création de la couche spatial postgis. en fait j'utilise les instructions suivantes:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
     
    createdb madatabase
    createlang plpgsql madatabase
    psql -d madatabase -f C:\PostgreSQL\8.2.1\share\contrib\lwpostgis.sql
    psql -d madatabase -f C:\PostgreSQL\8.2.1\share\contrib\spatial_ref_sys.sql
    L'editeur de lignes de commandes me demande à chaque fois le mot de passe même pour des chemins de fichiers. Est qu'il y a un moyen pour désactiver la demande du mot de passe par l'editeur DOS?

  4. #4
    Membre confirmé
    Homme Profil pro
    Inscrit en
    janvier 2006
    Messages
    390
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Corse (Corse)

    Informations forums :
    Inscription : janvier 2006
    Messages : 390
    Points : 606
    Points
    606
    Par défaut
    bonjour tu te connectes la premiere fois
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    psql -d mabase -U postgres
    puis tu lances tes requetes
    de plus fais attention je pense qu'il ya un probleme sur les chemins de ton fichier("\PostgreSQL\ 8.2.1\...")

  5. #5
    Membre habitué
    Profil pro
    Inscrit en
    janvier 2007
    Messages
    465
    Détails du profil
    Informations personnelles :
    Localisation : France, Bas Rhin (Alsace)

    Informations forums :
    Inscription : janvier 2007
    Messages : 465
    Points : 154
    Points
    154
    Par défaut
    Meci pour tes réponses, j'ai enfin trouvé la solution en se basant sur tes réponses. J'utilise les commandes suivantes:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
    createdb -U postgres madatabase
    createlang -U postgres plpgsql madatabase
    cd C:\Program Files\PostgreSQL\8.3\share\contrib
    psql -d madatabase -f lwpostgis.sql -U postgres
    psql -d madatabase -f spatial_ref_sys.sql -U postgres
    A chaque fois, l'editeur DOS me demande le mot de passe de l'utilisateur postgres, je le fournis et l'éxécution marche parfaitement. C'est Windows Vista . Sur XP, il me demande pas ces mot de passe, et l'exécution et beaucoup plusfacile.
    Merci xavier-Pierre.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Installation Postgresql/Postgis sur Windows Server 2008 R2
    Par simolay dans le forum Installation
    Réponses: 1
    Dernier message: 15/04/2013, 00h52
  2. Probleme d'installation de tomcat sur windows vista
    Par haifa28 dans le forum Tomcat et TomEE
    Réponses: 7
    Dernier message: 11/06/2009, 17h09
  3. Impossible d'installer tout programme sur windows vista
    Par nbo dans le forum Administration
    Réponses: 10
    Dernier message: 26/05/2008, 14h09
  4. Problème d'installation sur Windows Vista
    Par MrWeb dans le forum Apache
    Réponses: 5
    Dernier message: 21/08/2007, 16h24
  5. Installer Oracle 9i sur Windows Vista
    Par DomZZZ dans le forum Oracle
    Réponses: 1
    Dernier message: 12/02/2007, 08h17

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo