IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

MATLAB Discussion :

[Bug ?] [quiver3] L'exemple de l'aide plante


Sujet :

MATLAB

  1. #1
    Expert éminent sénior
    Avatar de Caro-Line
    Profil pro
    Inscrit en
    mars 2007
    Messages
    9 458
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2007
    Messages : 9 458
    Points : 14 827
    Points
    14 827
    Par défaut [Bug ?] [quiver3] L'exemple de l'aide plante
    J'essaye donc juste de lancer l'exemple donné par le help :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    [x,y] = meshgrid(-2:.2:2,-1:.15:1);
    z = x .* exp(-x.^2 - y.^2);
    [u,v,w] = surfnorm(x,y,z);
    quiver3(x,y,z,u,v,w); hold on, surf(x,y,z), hold off
    Et là, sentence :
    ??? Error using ==> setappdata
    Invalid object handle.

    Error in ==> quiver3 at 58
    h = specgraph.quivergroup('Color',c,'LineStyle',ls,...
    Je me mets en mode Debug, le seul handle de la ligne concerné vaut alors la même valeur que gca :
    K>> cax

    cax =

    158.0063

    K>> gca

    ans =

    158.0063

    K>> gca==cax

    ans =

    1
    J'ai peur d'avoir lors de tests fait des modifications sur le default du nextplot, cela pourrait-il venir de là ? Quelqu'un d'autre peut-il tester ?

    Ma version est dans ma signature, et je n'ai que MATLAB (0 toolboxes).
    Règles du Forum

    Adepte de la maïeutique

  2. #2
    Membre émérite
    Homme Profil pro
    Inscrit en
    mai 2008
    Messages
    2 022
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : mai 2008
    Messages : 2 022
    Points : 2 810
    Points
    2 810
    Par défaut
    Salut.
    cela marche très bien, j'ai Matlab 6.5.0. 18091 3a Release 13 june 18 2002

  3. #3
    Rédacteur/Modérateur

    Avatar de Jerome Briot
    Homme Profil pro
    Freelance en conception mécanique et prototypage
    Inscrit en
    novembre 2006
    Messages
    20 162
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Freelance en conception mécanique et prototypage

    Informations forums :
    Inscription : novembre 2006
    Messages : 20 162
    Points : 54 292
    Points
    54 292
    Par défaut
    Aucun problème avec MATLAB 2007b et R2008a
    Ingénieur indépendant en conception mécanique et prototypage :
    • conception mécanique 3D (Autodesk Fusion 360)
    • impression 3D (Ultimaker)
    • développement informatique (Python, MATLAB, C)
    • programmation de microcontrôleur (Microchip PIC, Arduino…)

    « J'étais le meilleur ami que le vieux Jim avait au monde. Il fallait choisir. J'ai réfléchi un moment, puis je me suis dit : "Tant pis ! J'irai en enfer" » (Saint Huck)

  4. #4
    Rédacteur/Modérateur

    Avatar de Jerome Briot
    Homme Profil pro
    Freelance en conception mécanique et prototypage
    Inscrit en
    novembre 2006
    Messages
    20 162
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Freelance en conception mécanique et prototypage

    Informations forums :
    Inscription : novembre 2006
    Messages : 20 162
    Points : 54 292
    Points
    54 292
    Par défaut
    Citation Envoyé par Dut Voir le message
    Aucun problème avec MATLAB 2007b et R2008a
    Ni avec MATLAB R2007a
    Ingénieur indépendant en conception mécanique et prototypage :
    • conception mécanique 3D (Autodesk Fusion 360)
    • impression 3D (Ultimaker)
    • développement informatique (Python, MATLAB, C)
    • programmation de microcontrôleur (Microchip PIC, Arduino…)

    « J'étais le meilleur ami que le vieux Jim avait au monde. Il fallait choisir. J'ai réfléchi un moment, puis je me suis dit : "Tant pis ! J'irai en enfer" » (Saint Huck)

  5. #5
    Expert éminent sénior
    Avatar de Caro-Line
    Profil pro
    Inscrit en
    mars 2007
    Messages
    9 458
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2007
    Messages : 9 458
    Points : 14 827
    Points
    14 827
    Par défaut
    Ben oui mais j'ai la r2007a
    J'ai cherché sur le site de TMW, rien trouvé

    Je viens de faire un :sans y croire (et sans être sure de ce qu'il fait derrière), toujours le même problème.

    Ah ben non il m'a remis à l'ancienne le fond des axes en noir

    J'attends de voir si quelqu'un avec la même version a ou non le problème et si je suis la seule je me lancerais dans une réinstallation (aux grands maux les grands remèdes !)

    [EDIT] Viens de voir ta dernière réponse Dut, bon ben j'ai du casser quelque chose , je ferais une réinstall quand j'aurais le temps.
    Règles du Forum

    Adepte de la maïeutique

  6. #6
    Rédacteur/Modérateur

    Avatar de Jerome Briot
    Homme Profil pro
    Freelance en conception mécanique et prototypage
    Inscrit en
    novembre 2006
    Messages
    20 162
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Freelance en conception mécanique et prototypage

    Informations forums :
    Inscription : novembre 2006
    Messages : 20 162
    Points : 54 292
    Points
    54 292
    Par défaut
    Citation Envoyé par caro95470 Voir le message
    J'ai peur d'avoir lors de tests fait des modifications sur le default du nextplot
    Quelles modifications ?
    Ingénieur indépendant en conception mécanique et prototypage :
    • conception mécanique 3D (Autodesk Fusion 360)
    • impression 3D (Ultimaker)
    • développement informatique (Python, MATLAB, C)
    • programmation de microcontrôleur (Microchip PIC, Arduino…)

    « J'étais le meilleur ami que le vieux Jim avait au monde. Il fallait choisir. J'ai réfléchi un moment, puis je me suis dit : "Tant pis ! J'irai en enfer" » (Saint Huck)

  7. #7
    Expert éminent sénior
    Avatar de Caro-Line
    Profil pro
    Inscrit en
    mars 2007
    Messages
    9 458
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2007
    Messages : 9 458
    Points : 14 827
    Points
    14 827
    Par défaut
    Citation Envoyé par Dut Voir le message
    Quelles modifications ?
    Aaaaaaaaaaaaaaaah. ça fait 3 heures que je cherche le post qui m'a fait plantée (enfin je pense) mais évidemment il est tombé dans le grand trou noir du 23 juillet...
    Le problème venait de l'utilisation de cette fonction data_marker.
    Cette de fonction faisait planter son programme.
    On a réussi à résoudre le problème en commentant la ligne suivante du fichier :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    set(gcf,'Nextplot','Replace')
    Je sais que ça ne devrait pas impacter le reste mais apparemment si, enfin je crois...
    Règles du Forum

    Adepte de la maïeutique

  8. #8
    Rédacteur/Modérateur

    Avatar de Jerome Briot
    Homme Profil pro
    Freelance en conception mécanique et prototypage
    Inscrit en
    novembre 2006
    Messages
    20 162
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Freelance en conception mécanique et prototypage

    Informations forums :
    Inscription : novembre 2006
    Messages : 20 162
    Points : 54 292
    Points
    54 292
    Par défaut
    Citation Envoyé par caro95470 Voir le message
    :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    set(gcf,'Nextplot','Replace')
    En quoi ça remplace la valeur par défaut ?

    D'après la documentation, ça restaure juste la valeur par défaut, non ?

    replace — Reset all figure properties except Position to their defaults and delete all figure children before displaying graphics (equivalent to clf reset).
    Ingénieur indépendant en conception mécanique et prototypage :
    • conception mécanique 3D (Autodesk Fusion 360)
    • impression 3D (Ultimaker)
    • développement informatique (Python, MATLAB, C)
    • programmation de microcontrôleur (Microchip PIC, Arduino…)

    « J'étais le meilleur ami que le vieux Jim avait au monde. Il fallait choisir. J'ai réfléchi un moment, puis je me suis dit : "Tant pis ! J'irai en enfer" » (Saint Huck)

  9. #9
    Expert éminent sénior
    Avatar de Caro-Line
    Profil pro
    Inscrit en
    mars 2007
    Messages
    9 458
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2007
    Messages : 9 458
    Points : 14 827
    Points
    14 827
    Par défaut
    Ben écoute je n'en sais rien, j'ai résolu son problème sans même savoir comment

    Tu peux voir la discussion en cache sur Google en fait : .

    C'est juste que je ne comprends pas pourquoi quiver3 plante chez moi.
    Bon après ce n'est pas la fin du monde mais j'aime bien comprendre
    Et a priori il n'est pas normal qu'un exemple de MATLAB plante à moins qu'on ait fait une grosse bourde comme nommer une fonction avec un nom de fonction MATLAB mais je ne pense pas que ça m'arrive (vais vérifier quand même mais ce serait vraiment gros)
    Règles du Forum

    Adepte de la maïeutique

  10. #10
    Expert éminent sénior
    Avatar de Caro-Line
    Profil pro
    Inscrit en
    mars 2007
    Messages
    9 458
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2007
    Messages : 9 458
    Points : 14 827
    Points
    14 827
    Par défaut
    Bon je devais avoir changer les paramètres dans la session courante.
    De retour de WE prolongé, l'exemple fonctionne.

    J'adore ce genre de bug
    Règles du Forum

    Adepte de la maïeutique

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Bug IE8 sur exemple officiels IGN
    Par Eho47 dans le forum IGN API Géoportail
    Réponses: 3
    Dernier message: 05/03/2010, 16h25
  2. Exemple QProcess FAQ: aide compréhension
    Par Nykoo dans le forum Qt
    Réponses: 9
    Dernier message: 01/04/2008, 01h28
  3. Scanline et D7 : problème avec l'exemple de l'aide
    Par Jipété dans le forum Débuter
    Réponses: 8
    Dernier message: 31/08/2007, 17h15
  4. Réponses: 1
    Dernier message: 08/06/2007, 22h58
  5. exemple de l'aide m$
    Par pat1545 dans le forum Access
    Réponses: 4
    Dernier message: 16/08/2006, 23h50

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo