Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre à l'essai
    Inscrit en
    juin 2008
    Messages
    51
    Détails du profil
    Informations forums :
    Inscription : juin 2008
    Messages : 51
    Points : 20
    Points
    20

    Par défaut [TeXmaker] Passage PC -> MAC : accents non conservés

    Bonjour à tous,

    Je viens de me procurer un mac, j'ai donc installé MacTeX ainsi que Texmaker (que j'utilisais sous Windows d'ailleurs), et à l'ouverture de mon fichier .tex, j'ai eu la mauvaise surprise de constater que tous les accents avaient disparu de texmaker....

    Et quand j'ouvre le fichier .tex avec un simple éditeur texte sous mac, et je vois que les é sont devenus È et les è sont devenus Ë...


    Vous avez une solution?




    EDIT:

    Jai essayé de modifier l'encodage (j'avais lu quelque part que je devais me mettre en UTF-8) dans les préférences de texmaker, mais aucun ne résout le problème (les lettres accentuées sont toujours remplacées par des symboles étranges)

    Voici mon en-tête :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    \documentclass[10pt,a4paper]{article}
    \usepackage[latin1]{inputenc}%j'ai tenté utf8
    \usepackage[T1]{fontenc}
    \usepackage{lmodern}
    \usepackage[frenchb]{babel}

  2. #2
    Membre expert
    Avatar de pitipoisson
    Homme Profil pro
    Chercheur
    Inscrit en
    septembre 2006
    Messages
    1 942
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Finistère (Bretagne)

    Informations professionnelles :
    Activité : Chercheur
    Secteur : Agroalimentaire - Agriculture

    Informations forums :
    Inscription : septembre 2006
    Messages : 1 942
    Points : 3 368
    Points
    3 368

    Par défaut

    Bonjour,

    Je ne sais pas si tu avais résolu ton problème avant le récent saut dans le temps du forum... je tente le coups quand même.

    Citation Envoyé par Krillz Voir le message
    EDIT:

    Jai essayé de modifier l'encodage (j'avais lu quelque part que je devais me mettre en UTF-8) dans les préférences de texmaker,...
    Ce qu'il faut avant tout, c'est une cohérence entre les encodages des tes fichiers et de ton éditeur, puis pour la compilation, cohérence entre l'encodage des fichiers et de l'option passée à inputenc (i.e. "encodage d'entrée).

    Ce que tu devrais faire
    1. vérifier le codage de tes fichiers avec un éditeur de texte capable de l'identifier automatiquement (fichiers crées sous Win ? Ça risque fort d'être du latin1)
    2. faire la cohérence fichier/éditeur
      • en réglant l'encodage de TeXMaker sur la valeur adéquate
      • ou bien en convertissant tes fichiers vers l'utf8 (par exemple, à toi de choisir)
        Tu doit pouvoir utiliser la commande iconv (qui existe apparemment sous mac)
    3. mettre l'option correspondante pour inputenc
    Forum LaTeX : pour des réponses rapides et appropriées, pensez à poster un
    ECM = Exemple (reproduit le problème) Complet (document compilable) Minimal (ne postez pas votre thèse !)

    Une solution vous convient ? N'oubliez pas le tag


    )><))))°>

Discussions similaires

  1. Réponses: 1
    Dernier message: 14/10/2007, 21h00
  2. [ASP.NET 2.0 / C#]Cookie non conservé.
    Par maniaco_jazz dans le forum ASP.NET
    Réponses: 4
    Dernier message: 05/07/2007, 14h55
  3. Passage de PC à MAC
    Par whilecoyote dans le forum Apple
    Réponses: 7
    Dernier message: 26/01/2007, 23h03
  4. Problème de Tableau (non conservé sous ie)
    Par dj-julio dans le forum Sessions
    Réponses: 12
    Dernier message: 23/12/2005, 12h19
  5. Accents non pris en compte dans les requêtes SELECT
    Par YanK dans le forum Requêtes
    Réponses: 1
    Dernier message: 30/08/2005, 11h57

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo