IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Tomcat et TomEE Java Discussion :

Connecteur Tomcat / Apache :(


Sujet :

Tomcat et TomEE Java

  1. #1
    Futur Membre du Club
    Profil pro
    Inscrit en
    décembre 2007
    Messages
    16
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2007
    Messages : 16
    Points : 7
    Points
    7
    Par défaut Connecteur Tomcat / Apache :(
    Bonjour,

    J'ai un petit soucis sur ma liaison tomcat et apache. Déjà voila les infos sur mon système:

    - Linux Redhat ES4 SP4
    - Apache 2.2.8
    - Tomcat 5.5.26
    - Module JK 1.2.26

    Le serveur apache fonctionne en solo, donc je peux utiliser sans soucis mon port 8080, tomcat c'est sensiblement la meme chose, le port 8009 fonctionne aussi et mon application java marche sous ce port donc pas de problème apparent du coté installation et configuration de ces 2 softs.
    Donc je me dis que ca viens forcement du connecteur entre les 2. Voici mes différents fichiers de configuration.

    - Tomcat : server.xml
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
     
    <Connector
         port="8009"
         enableLookups="false"
         redirectPort="8443"
         acceptCount="100"
         debug="1"
         protocol="AJP/1.3"
         scheme="http"
         secure="false"
         connectionTimeout="20000"
         disableUploadTimeout="true"
    />
    - Apache : httpd.conf
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
     
    LoadModule jk_module modules/mod_jk.so
    <IfModule mod_jk.c>
            JkWorkersFile /usr/local/apache2/conf/workers.properties
            JkLogFile /usr/local/apache2/logs/mod_jk.log
            JkLogLevel warn
            JkLogStampFormat "[ %a %b %d %H:%M:%S %Y] "
            JkShmFile /usr/local/apache2/logs/shm
            JkMount /iht/* tomcat1
            JkOptions +ForwardKeySize +ForwardURICompat -ForwardDirectories
    </IfModule>
    - Apache : workers.properties
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
     
    worker.list=tomcat1
    worker.tomcat1.port=8009
    worker.tomcat1.host=localhost
    worker.tomcat1.type=ajp13
    J'ai bien mon fichier mod_jk.so dans mon repertoire modules de apache, je l'ai compilé avec la version source du site apache. En fait je ne vois pas mon erreur, dans les fichiers logs rien de concret et de tres informatif, d'ou ma requete vers vous pour savoir si vous ciblez un truc de choquant, ou de faux tout simplement

    Merci d'avance !

  2. #2
    Membre habitué
    Profil pro
    Inscrit en
    juillet 2007
    Messages
    143
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2007
    Messages : 143
    Points : 157
    Points
    157
    Par défaut
    Tu n'expliques pas vraiment ton problème, qu'est-ce qu'il se passe exactement? Une erreur 404 quand tu essayes d'aller sur ton appli?
    Sinon je te conseille d'utiliser plutôt mod_proxy, c'est nettement plus simple de diagnostiquer les problèmes avec ce module. A l'origine les gens préféraient mod_jk car il était le seul à faire du load balancing mais :
    1- à priori tu ne fais pas de load balancing
    2- tu es sur Apache 2.2 et donc tu peux bénéficier de mod_proxy_balancer, qui offre cette fonctionnalité
    Julien Dubois

    http://www.ippon.fr

  3. #3
    Futur Membre du Club
    Profil pro
    Inscrit en
    décembre 2007
    Messages
    16
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2007
    Messages : 16
    Points : 7
    Points
    7
    Par défaut
    Oui c'est exactement ca, j'ai une erreur 404 quand je vais sur mon apply, il ne trouve rien du tout.

    Je vais me renseigner sur le mod_proxy, mais le truc c'est que sur tout mes autres serveurs le mod_jk fonctionne bien, du coup je voulais recreer la meme chose. Donc si vous avez des idées pour le mod_jk je suis preneur, en attendant je file bosser sur le proxy

    Merci de l'info en tout cas.

    Edit : apres quelque test j'ai dans mon log file du module JK un message du mode debug, ou il est ecrit : missing uri map for [my.server] si ca vous dit quelque chose

    jvous met un log pour mieux montrer l'erreur
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
     
    jk_child_init::mod_jk.c (2740): Initialized mod_jk/1.2.26
    jk_translate::mod_jk.c (3033): missing uri map for server.xxx.xxx:/login.jsp
    jk_map_to_storage::mod_jk.c (3190): missing uri map for server.xxx.xxx:/login.jsp

  4. #4
    Futur Membre du Club
    Profil pro
    Inscrit en
    décembre 2007
    Messages
    16
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2007
    Messages : 16
    Points : 7
    Points
    7
    Par défaut
    Bon, bonne nouvelle pour moi et pour ceux qui rencontreront le meme probleme si il y a.

    J'ai la solution !!

    En fait le soucis venait de Apache, il manquait une option de configuration qui permet a apache de copier la configuration du mod_jk pour tout les <VirtualHost> du fichier de config apache.

    Pour cela il suffit d'ajouter une ligne dans la config contenue dans le httpd.conf:
    Bien sur il faut redemarrer Apache et hop ca marche, enfin chez moi ^^

    Voila 2 liens sur lesquels vous pourrez trouver des informations concernant ce problème (en Anglais):
    http://tomcat.apache.org/connectors-...ce/apache.html
    http://marc.info/?l=tomcat-user&m=120164756115289&w=2

    Voila voila je peux donc mettre un zouli tag "Résolu"

  5. #5
    Futur Membre du Club
    Profil pro
    Inscrit en
    octobre 2007
    Messages
    6
    Détails du profil
    Informations personnelles :
    Âge : 48
    Localisation : France

    Informations forums :
    Inscription : octobre 2007
    Messages : 6
    Points : 6
    Points
    6
    Par défaut httpd.conf
    moi je veux bien, mais ce que je comprends pas, c'est que ça exist plus httpd.conf, deprecated, c'est fini, alors comment vous faites pour mettre des commandes la dedans

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [Tomcat] Apache Tomcat : redirection 404
    Par alheim dans le forum Tomcat et TomEE
    Réponses: 3
    Dernier message: 13/02/2006, 11h47
  2. [mod_jk] integration tomcat apache, error 500
    Par peppena dans le forum Tomcat et TomEE
    Réponses: 5
    Dernier message: 10/02/2006, 10h01
  3. [Tomcat]Apache et Tomcat
    Par Sherkhan dans le forum Tomcat et TomEE
    Réponses: 9
    Dernier message: 22/03/2005, 14h40
  4. [JSP] [tomcat] apache-tomcat jsp
    Par HULK dans le forum Tomcat et TomEE
    Réponses: 4
    Dernier message: 25/01/2004, 17h29
  5. Tomcat + Apache-SOAP
    Par lucho31 dans le forum Services Web
    Réponses: 3
    Dernier message: 17/10/2002, 09h55

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo