IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eclipse Platform Discussion :

Ultim Debug mode


Sujet :

Eclipse Platform

  1. #1
    Membre actif
    Profil pro
    Inscrit en
    Mars 2007
    Messages
    333
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Mars 2007
    Messages : 333
    Points : 295
    Points
    295
    Par défaut Ultim Debug mode
    Bonjour à tous,

    Face à un problème ... je cherche à poser des points d'arrêts sur l'ensemble de mon plugin ... est ce qu'il existe une méthode pour mettre des points d'arrêts dans chaque classe de mon package sans le faire 1 par 1 ?

    Merci d'avance

    PS : cela me semble impossible de mon point de vue mais on sait jamais

  2. #2
    Membre du Club
    Profil pro
    Inscrit en
    Mai 2007
    Messages
    63
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Mai 2007
    Messages : 63
    Points : 59
    Points
    59
    Par défaut
    Jpense pas sa soit possible non plus ....

  3. #3
    Membre confirmé

    Homme Profil pro
    Consultant en technologies
    Inscrit en
    Juin 2004
    Messages
    332
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Consultant en technologies

    Informations forums :
    Inscription : Juin 2004
    Messages : 332
    Points : 556
    Points
    556
    Par défaut
    Heu, que veux-tu faire au juste, car j'ai pas l'impression que ça ait un intérêt de mettre des points d'arrêt partout.... Qu'as tu besoin de "déboguer" ...?

  4. #4
    Membre confirmé Avatar de gmotw
    Profil pro
    Inscrit en
    Mars 2008
    Messages
    384
    Détails du profil
    Informations personnelles :
    Âge : 38
    Localisation : France

    Informations forums :
    Inscription : Mars 2008
    Messages : 384
    Points : 641
    Points
    641
    Par défaut
    Moui, avant de bourriner sauvagement, je te conseillerais de réduire ta zone de recherche à partir des messages d'erreur que tu récupères.
    THIS!IS!NOT!MY!COW!

    CECI!N'EST!PAS!MA!VACHE!
    (mais je persiste à dire que c'est moins classe en français )

  5. #5
    Membre actif
    Profil pro
    Inscrit en
    Mars 2007
    Messages
    333
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Mars 2007
    Messages : 333
    Points : 295
    Points
    295
    Par défaut
    Le soucis est que je ne cherche pas vraiment à "débuguer" mais plus tôt à "comprendre" l'architecture du code.

    Dans mon cas je développe un plugin se servant d'une couche de sous-plugin fournis par d'autre projet. Je cherche à mimer le code executer par un listeneur (généré automatiquement ...) donc aucune idée de où ça va tapper

    Je pense définitivement qu' eclipse ne le permet pas.


  6. #6
    Membre confirmé

    Homme Profil pro
    Consultant en technologies
    Inscrit en
    Juin 2004
    Messages
    332
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Consultant en technologies

    Informations forums :
    Inscription : Juin 2004
    Messages : 332
    Points : 556
    Points
    556
    Par défaut
    Ben tu breakes suffisamment tôt et tu fais F6 F6 F6 F6 F6 F6 autant de fois que cela te fera plaisir, non ?

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. mode debug/mode release
    Par mony84 dans le forum Visual Studio
    Réponses: 0
    Dernier message: 19/09/2008, 10h09
  2. apres avoir activé le debug mode le server ne se lance plus
    Par *alexandre* dans le forum Weblogic
    Réponses: 0
    Dernier message: 11/09/2008, 17h27
  3. [c#] tester le debug mode
    Par Husqvarna dans le forum C#
    Réponses: 4
    Dernier message: 02/11/2007, 12h03
  4. Probleme websphere mode debug/mode normal
    Par palex dans le forum Websphere
    Réponses: 1
    Dernier message: 11/09/2006, 15h47
  5. [c#] Mode debug / mode release
    Par benzouille dans le forum Windows Forms
    Réponses: 1
    Dernier message: 14/04/2006, 13h19

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo