IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Composants VCL Delphi Discussion :

Problème d'affichage dans un composant TScrollBox


Sujet :

Composants VCL Delphi

  1. #1
    Candidat au Club
    Profil pro
    Inscrit en
    novembre 2004
    Messages
    3
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : novembre 2004
    Messages : 3
    Points : 2
    Points
    2
    Par défaut Problème d'affichage dans un composant TScrollBox
    Bonjour, j'utilise une composant TScrollBox pour afficher en colonne le planning d'une 50 taine d'employés ds une journée de donnée. Pour cela je créé dynamiquement des images représentant la disponibilité ou non de chaque employé. Pour les 3 premiers employés, le traitement parvient à empiler les images dans le TScrollBox . Le problème survient au bout du 4ième employé, le traitement n'est pas capable de positionner une 4ième image au-dessus des autres. Est-ce que qq un peut m'aider ?

  2. #2
    Expert éminent
    Avatar de Lung
    Profil pro
    Analyste-programmeur
    Inscrit en
    mai 2002
    Messages
    2 619
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Analyste-programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2002
    Messages : 2 619
    Points : 6 325
    Points
    6 325
    Par défaut Re: Problème d'affichage dans un composant TScrollBox
    Citation Envoyé par erossi
    Le problème survient au bout du 4ième employé, le traitement n'est pas capable de positionner une 4ième image au-dessus des autres.
    Qu'est ce que tu veux dire par là ?

    :
    L'urgent est fait, l'impossible est en cours, pour les miracles prévoir un délai. ___ Écrivez dans un français correct !!

    C++Builder 5 - Delphi 6#2 Entreprise - Delphi 2007 Entreprise - Delphi 2010 Architecte - Delphi XE Entreprise - Delphi XE7 Entreprise - Delphi 10 Entreprise - Delphi 10.3.2 Entreprise
    OpenGL 2.1 - Oracle 10g - Interbase (7 - XE) - PostgreSQL 11.6

  3. #3
    Candidat au Club
    Profil pro
    Inscrit en
    novembre 2004
    Messages
    3
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : novembre 2004
    Messages : 3
    Points : 2
    Points
    2
    Par défaut
    une image a une hauteur de 8 pixels. Le top de la 1ière est à 8, de la seconde est à 16, de la troisième est à 24 etc... Mon traitement doit empiler une 50 taine d'images dans le composant Tscrollbox. Lorsque j'exécute pas à pas ma boucle, je vois bien le top de chaque nouvelle image créée s'incrémenter de 8. En résultat, l'affichage des images dans le TScrollbox est le suivant :
    - 1ière img, top= 8 -> affichage ok
    - 2ième img, top = 16 -> affichage ok
    - 3ième img, top = 24 -> affichage ok
    A partir de la 4ième image
    - 4ième img, top = 32 -> mais l'affichage de celle-ci est erroné. Elle vient se positionner sous la 1ière img et ainsi de suite jusqu'à la 50ième

  4. #4
    Candidat au Club
    Profil pro
    Inscrit en
    novembre 2004
    Messages
    3
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : novembre 2004
    Messages : 3
    Points : 2
    Points
    2
    Par défaut
    j'ai résolu mon problème. Il venait d'une mauvaise incrémentation du top de chaque nouvelle image

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 0
    Dernier message: 20/04/2010, 13h09
  2. Problème d'affichage dans des TScrollBox sous Windows Vista
    Par ILPlais dans le forum Composants VCL
    Réponses: 1
    Dernier message: 28/05/2008, 11h09
  3. Problème d'affichage dans un tableau
    Par claralavraie dans le forum ASP
    Réponses: 13
    Dernier message: 21/12/2005, 16h45
  4. [JSTL] Problème d'affichage dans un <c:forEach>
    Par zwck dans le forum Taglibs
    Réponses: 6
    Dernier message: 05/11/2005, 22h35
  5. [débutant]problèmes d'affichage dans un tableau
    Par Hastur dans le forum Balisage (X)HTML et validation W3C
    Réponses: 12
    Dernier message: 16/08/2005, 13h00

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo