IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Bases de données Delphi Discussion :

Problème lors du lancement de deux applications Interbase


Sujet :

Bases de données Delphi

  1. #1
    Membre du Club Avatar de Morfus
    Inscrit en
    Novembre 2006
    Messages
    93
    Détails du profil
    Informations forums :
    Inscription : Novembre 2006
    Messages : 93
    Points : 58
    Points
    58
    Par défaut Problème lors du lancement de deux applications Interbase
    bonjour
    jai un probleme au lancement de mes application de delphiquand je lance deux application qui utilise interbase 6.5 je developpe en delphi7
    le probleme c'est que que je les lance separement ça veut dir une seule elles marchent tres bien mais dés que l'une est lancé l'autre plante
    je comprend pas pourquoi ce probleme
    merci pour votre aides

  2. #2
    Expert éminent sénior
    Avatar de Cl@udius
    Homme Profil pro
    Développeur Web
    Inscrit en
    Février 2006
    Messages
    4 878
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 61
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : Février 2006
    Messages : 4 878
    Points : 10 008
    Points
    10 008
    Par défaut
    Salut

    Citation Envoyé par Morfus Voir le message
    mais dés que l'une est lancé l'autre plante
    Elle plante, oui mais encore...

    Est-ce 2 instances de la même application ou est-ce 2 applis qui utilisent la même base de données, ou encore 2 applis différentes sur 2 bases distinctes?

    Qu'est-ce tu as comme message lorsque 'ça plante'?

    @+ Claudius.

  3. #3
    Membre du Club Avatar de Morfus
    Inscrit en
    Novembre 2006
    Messages
    93
    Détails du profil
    Informations forums :
    Inscription : Novembre 2006
    Messages : 93
    Points : 58
    Points
    58
    Par défaut
    jai deux application differente utilisant deux base differente
    quand la premiere est lancé puis je tente de lancé la deuxieme ya le message windows envoyé le raport d'erreur

  4. #4
    Membre chevronné

    Profil pro
    Ingénieur développement logiciels
    Inscrit en
    Août 2002
    Messages
    1 289
    Détails du profil
    Informations personnelles :
    Âge : 43
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : Août 2002
    Messages : 1 289
    Points : 1 940
    Points
    1 940
    Par défaut
    As-tu la possibilité de lancer ton application à partir de l'IDE? (le message d'erreur sera plus clair normalement).
    Delphi 7/XE2/XE3
    C#
    Oracle 9i à 12c
    SQL Server 2008 à 2022

  5. #5
    Expert éminent sénior
    Avatar de ShaiLeTroll
    Homme Profil pro
    Développeur C++\Delphi
    Inscrit en
    Juillet 2006
    Messages
    13 549
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 43
    Localisation : France, Seine Saint Denis (Île de France)

    Informations professionnelles :
    Activité : Développeur C++\Delphi
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : Juillet 2006
    Messages : 13 549
    Points : 25 119
    Points
    25 119
    Par défaut
    Ton Server IB peut-être limité à 1 utilisateur, normal pour le développement (quoi qu'il me semblait que c'était 5 par défaut en version dev), d'ailleurs, il faut facturer les licenses au clients, ... mais maintenant il y a FireBird ...
    Aide via F1 - FAQ - Guide du développeur Delphi devant un problème - Pensez-y !
    Attention Troll Méchant !
    "Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson" Confucius
    Mieux vaut se taire et paraître idiot, Que l'ouvrir et de le confirmer !
    L'ignorance n'excuse pas la médiocrité !

    L'expérience, c'est le nom que chacun donne à ses erreurs. (Oscar Wilde)
    Il faut avoir le courage de se tromper et d'apprendre de ses erreurs

  6. #6
    Membre du Club Avatar de Morfus
    Inscrit en
    Novembre 2006
    Messages
    93
    Détails du profil
    Informations forums :
    Inscription : Novembre 2006
    Messages : 93
    Points : 58
    Points
    58
    Par défaut
    pouvez vous m'indiquer le chemin ou je peu telecharger Firebird
    je vous remercie pour ces information

  7. #7
    Expert éminent sénior
    Avatar de Cl@udius
    Homme Profil pro
    Développeur Web
    Inscrit en
    Février 2006
    Messages
    4 878
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 61
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : Février 2006
    Messages : 4 878
    Points : 10 008
    Points
    10 008
    Par défaut
    Salut

    Le dernière version finalisée de Firebird est actuellement la 2.0.3 que tu peux télécharger ici.

    Cependant il me semble bien, tout comme Shai, que la version 6.5 d'IB fournit avec Delphi 7 permet 5 utilisateurs simultanés.
    Vérifie ton type de licence...

    @+ Claudius

  8. #8
    Membre du Club Avatar de Morfus
    Inscrit en
    Novembre 2006
    Messages
    93
    Détails du profil
    Informations forums :
    Inscription : Novembre 2006
    Messages : 93
    Points : 58
    Points
    58
    Par défaut
    peut on changer le nombre de connexion au serveur ib 6.5 (il est fixé sur 5 utilisateur) si oui
    pourriez vous mindiquer comment faire
    merci

  9. #9
    Membre émérite Avatar de edam
    Homme Profil pro
    Développeur Delphi/c++/Omnis
    Inscrit en
    Décembre 2003
    Messages
    1 894
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Maroc

    Informations professionnelles :
    Activité : Développeur Delphi/c++/Omnis
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : Décembre 2003
    Messages : 1 894
    Points : 2 770
    Points
    2 770
    Par défaut
    je vais dire peut être une betise: tu as installé IB server ou embeded??
    PAS DE DESTIN, C'EST CE QUE NOUS FAISONS

Discussions similaires

  1. [Débutant] Problème lors du lancement de mon application en mode débogage - VB.NET
    Par Aiman.elmachi dans le forum VB.NET
    Réponses: 1
    Dernier message: 22/06/2014, 21h38
  2. Problème lors du lancement de mon application mobile
    Par love-part dans le forum Android
    Réponses: 6
    Dernier message: 15/10/2012, 11h42
  3. problème lors du lancement de l'application sous tomcat
    Par khayem dans le forum Servlets/JSP
    Réponses: 1
    Dernier message: 08/11/2011, 11h28
  4. Réponses: 6
    Dernier message: 06/07/2006, 18h44
  5. Réponses: 1
    Dernier message: 28/06/2006, 16h07

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo