IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Services Web Discussion :

Déploiement de Web Service avec InstallShield


Sujet :

Services Web

  1. #1
    Membre actif
    Inscrit en
    Mai 2005
    Messages
    217
    Détails du profil
    Informations personnelles :
    Âge : 42

    Informations forums :
    Inscription : Mai 2005
    Messages : 217
    Points : 220
    Points
    220
    Par défaut Déploiement de Web Service avec InstallShield
    Salut,

    Je veux déployer un ws avec un setup installshield...
    Je sais comment faire pour que ce dernier me créer mon site IIS mais le pb c'est les fichiers .asmx .vb web.config etc ! parce que la je me pose une question... il faut les deployer telle quel sur le serveur ?? car si c'est le cas ... ca craint un peu car ca veut dire qu'une personne qui a acces au serveur à accès au code source :/

    Si des personnes se sont panché la dessus je veux bien leur avis (le mieux c'est qu'on me dise que je me plante ! que je suis fou car on met pas le code source dispo comme ca sur le serveur .... ET qu'on me donne la solution biensur ...)

    PS: je sais bien que le code est "compilé" ms le fichier que le client du WS appelle est bien le mon_fichier.ASMX et pas mon_fichier.dll ....

    Merci !

  2. #2
    Débutant

    Inscrit en
    Décembre 2003
    Messages
    166
    Détails du profil
    Informations forums :
    Inscription : Décembre 2003
    Messages : 166
    Points : 120
    Points
    120
    Par défaut
    Citation Envoyé par _beber85
    Je sais comment faire pour que ce dernier me créer mon site IIS
    Et comment tu fais ?? Ca m'interresse !

  3. #3
    Membre actif
    Inscrit en
    Mai 2005
    Messages
    217
    Détails du profil
    Informations personnelles :
    Âge : 42

    Informations forums :
    Inscription : Mai 2005
    Messages : 217
    Points : 220
    Points
    220
    Par défaut
    je sais pas avec quelle version d'installshield tu travailles mais moi c'est :
    - InstallShield DevStudio 9

    Avec cette version, la procédure est la suivante :

    - Créer un Web Project

    - Il faut allez dans l'onglet installation designer (avec le project assistant, il te propose jamais la création de site IIS sinon :s )

    - Dans le dossier system configuration, tu as le point "IIS virtual directories", tu vas dedans et tu créer un nouveau site web. tu le nommes comme tu veux et tout les autres paramètres sont ok (enfin pr moi en tt cas, car il reprend les valeurs par défaut d'un site web créer directement avec IIS)

    PS : J'ai pas encore essayer d'executer le setup qd un site web portait deja le meme nom ... je sais pas si ca plante ou si il ecrase le site web ...

    voili voilou ... j'espere que ca va t'aider
    (hesite pas si tu as des pb ou d'autres questions:p )

  4. #4
    Membre actif
    Inscrit en
    Mai 2005
    Messages
    217
    Détails du profil
    Informations personnelles :
    Âge : 42

    Informations forums :
    Inscription : Mai 2005
    Messages : 217
    Points : 220
    Points
    220
    Par défaut
    :/

    Comme quoi ... il faut chercher un peu (et réfléchir un minimum avant de poser une question :s )

    cf:
    http://msdn.microsoft.com/library/fre/default.asp?url=/library/FRE/cpguide/html/cpcondeployingwebservices.asp

    en fait il suffit d'inclure le répertoire ./bin (normal quoi) et le fichier .asmx qui ne contient qu'une seul ligne (langage, nom du fichier .asmx.vb (dans ce cas la osef) , et le nom de la class (qu'il ira prendre dans le bin)

    voila... desolé d'etre con

    PS : je metterai résolu qd j'aurais répondu à la question du message précédent (si on ecrase un site web avec installshield )

  5. #5
    Expert éminent
    Avatar de neguib
    Profil pro
    Inscrit en
    Mai 2005
    Messages
    3 627
    Détails du profil
    Informations personnelles :
    Âge : 64
    Localisation : Suisse

    Informations forums :
    Inscription : Mai 2005
    Messages : 3 627
    Points : 7 879
    Points
    7 879
    Par défaut
    çà va j'ai faillit justement te balancer le lien, j'ai bien fait d'attendre, bon pour le principe je ne crois pas que tu dois compter sur le fait qu'il ecrase quoi que ce soit, il faudra une desinstalle avnt

  6. #6
    Débutant

    Inscrit en
    Décembre 2003
    Messages
    166
    Détails du profil
    Informations forums :
    Inscription : Décembre 2003
    Messages : 166
    Points : 120
    Points
    120
    Par défaut
    Merci _beber85 !

    Le lien est le bienvenu .

  7. #7
    Membre actif
    Inscrit en
    Mai 2005
    Messages
    217
    Détails du profil
    Informations personnelles :
    Âge : 42

    Informations forums :
    Inscription : Mai 2005
    Messages : 217
    Points : 220
    Points
    220
    Par défaut
    Pfff, fais chi** !!!

    tu as raison neguib ca marche pas... il faut bien désinstaller le site web avant sous peine que le setup ne créer pas l'alias demandé (enfin vu qu'il existe deja, ne le modifie pas pour le faire pointer vers le nouveau répertoire ...)

    voila ... bah maintenant je considere ce poste comme resolu meme si ce probleme m'embete bien

    PS : j'ai essayé avec InstallShield 9 et InstallShield 11 (qui au passage n'a pas beaucoup de fonctionnalités en plus :/ )

  8. #8
    Membre régulier
    Profil pro
    Inscrit en
    Janvier 2006
    Messages
    164
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations forums :
    Inscription : Janvier 2006
    Messages : 164
    Points : 92
    Points
    92
    Par défaut Installshield
    Bonjour,

    je viens de lire ce post qui est interessant ! voyant que vous connaissez installshiled ..je me dis que peut etre vous pourrez m'aiguiller un peu !

    voila je bosse avec installshield 9

    j'ai un package fait avec installshield 9 qui contient :
    un fichier .exe
    un fichier .msi
    et un tas de fichier .dll, aspx ..etc..

    je dois reduire ce package afin que quand il sort de la moulinette d'installshield, il en resulte un seul fichier avec l'extension .msi !

    ceci afin de pouvoir editer les tables avec orca !

    Quelqu'un a t il une idée sur ca ou des informations !

    j'ai beau cherche ou poser des questions sur le forum macrovision mais personne n'y repond :-( !

    Je vous remercie pour toutes vos infos !
    Christophe

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Appeler un web service avec pl/sql
    Par squalito dans le forum PL/SQL
    Réponses: 5
    Dernier message: 17/09/2012, 15h21
  2. comment developper un web service avec java et oracle
    Par kheira dans le forum Services Web
    Réponses: 4
    Dernier message: 26/04/2011, 16h29
  3. [Debutant]création de web services avec JWS
    Par Mehdi_82 dans le forum Services Web
    Réponses: 3
    Dernier message: 09/07/2008, 20h22
  4. [Debutant] Web services avec Jboss WS
    Par nesbla dans le forum Services Web
    Réponses: 1
    Dernier message: 14/08/2006, 13h52
  5. [Web Service][avec Struts]un tuto? un lien?
    Par javazer dans le forum Struts 1
    Réponses: 3
    Dernier message: 28/03/2006, 18h32

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo