IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

PHP & Base de données Discussion :

[SQL] requête un champs passe mais pas les deux autres alors que même structure


Sujet :

PHP & Base de données

  1. #1
    Membre régulier Avatar de The Molo
    Profil pro
    Inscrit en
    avril 2007
    Messages
    240
    Détails du profil
    Informations personnelles :
    Âge : 36
    Localisation : Belgique

    Informations forums :
    Inscription : avril 2007
    Messages : 240
    Points : 99
    Points
    99
    Par défaut [SQL] requête un champs passe mais pas les deux autres alors que même structure
    Bonjour !!

    J'ai un soucis avec une requête mais je ne comprends pas pourquoi...

    La voici :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    $requeteFlag= "SELECT FLAG, COMMENTAIRE FROM FLAG_PERSO WHERE ANNEE=$anneeCbx, MOIS=$moisCbx, CODE_UNIT=$codeUnit";
    $resultatFlag=mysql_query($requeteFlag) or die(mysql_error());
    Voici l'erreur affichée :

    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' MOIS=3, CODE_UNIT=112' at line 1
    Je ne vois vraiment pas pourquoi pour le champs ANNEE, ça passe mais pas pour les deux autres... Ce sont tous les 3 des VARCHAR


    Merci de m'aider pcq je m'énerve déjà depuis un petit temps
    The Molo

  2. #2
    Membre habitué
    Profil pro
    Inscrit en
    juillet 2007
    Messages
    181
    Détails du profil
    Informations personnelles :
    Âge : 45
    Localisation : France

    Informations forums :
    Inscription : juillet 2007
    Messages : 181
    Points : 187
    Points
    187
    Par défaut
    tu as essayé avec des valeurs qui existent dans ta base?
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    $requeteFlag= "SELECT FLAG, COMMENTAIRE FROM FLAG_PERSO WHERE ANNEE=$anneeCbx, MOIS='valeur de la base', CODE_UNIT='valeur de la base'";
    et perso moi je fais
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    $requeteFlag= "SELECT FLAG, COMMENTAIRE FROM FLAG_PERSO WHERE ANNEE='".$anneeCbx."', MOIS='".$moisCbx."', CODE_UNIT='".$codeUnit."'";
    on m'a appris comme ça, j'applique sans savoir si c'est vraiment nécessaire
    essaie et dis si ça donne la même erreur
    ...

  3. #3
    Membre régulier Avatar de The Molo
    Profil pro
    Inscrit en
    avril 2007
    Messages
    240
    Détails du profil
    Informations personnelles :
    Âge : 36
    Localisation : Belgique

    Informations forums :
    Inscription : avril 2007
    Messages : 240
    Points : 99
    Points
    99
    Par défaut
    Salut

    Oui j'avais déjà essayé mais toujours la même erreur...

    Ce qui me parait bizard, c'est que même en remplaçant par des valeurs de la BD, ça ne fonctionnent pas
    The Molo

  4. #4
    Membre habitué
    Profil pro
    Inscrit en
    juillet 2007
    Messages
    181
    Détails du profil
    Informations personnelles :
    Âge : 45
    Localisation : France

    Informations forums :
    Inscription : juillet 2007
    Messages : 181
    Points : 187
    Points
    187
    Par défaut
    désolé mais je vois pas ce que c'est,
    j'ai juste vu que en général ce message d'erreur sort quand la version de mysql est trop vieille pour certaines fonctionnalités sql mais pour un select je comprends pas ce qui lui prend
    fais une recherche avec ton message d'erreur et requête select tu trouveras peut être qq chose
    bon courage
    ...

  5. #5
    Membre émérite
    Avatar de yiannis
    Profil pro
    Inscrit en
    septembre 2005
    Messages
    1 494
    Détails du profil
    Informations personnelles :
    Âge : 56
    Localisation : France

    Informations forums :
    Inscription : septembre 2005
    Messages : 1 494
    Points : 2 791
    Points
    2 791
    Par défaut
    Bonjour,

    C'est quoi ces virgules qui separent tes condition?

    Essaie plutot comme ceci:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    $requeteFlag= "SELECT FLAG, COMMENTAIRE FROM FLAG_PERSO WHERE ANNEE='".$anneeCbx."' and MOIS='".$moisCbx."' and CODE_UNIT='".$codeUnit."'";
    "Ce besoin de remords qui précède le Mal, que dis-je ! qui le crée..." E. CIORAN

  6. #6
    Membre régulier Avatar de The Molo
    Profil pro
    Inscrit en
    avril 2007
    Messages
    240
    Détails du profil
    Informations personnelles :
    Âge : 36
    Localisation : Belgique

    Informations forums :
    Inscription : avril 2007
    Messages : 240
    Points : 99
    Points
    99
    Par défaut
    Merci !!!

    J'ai fait des centaines de requêtes et j'arrive encore à faire des boulettes pareilles !!! La honte !

    Merci encore !
    The Molo

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Requête INSERT mais pas les lignes qui existent
    Par zoom61 dans le forum Requêtes
    Réponses: 4
    Dernier message: 24/01/2012, 15h20
  2. Réponses: 0
    Dernier message: 08/09/2009, 18h47
  3. Réponses: 4
    Dernier message: 18/01/2006, 14h49
  4. [SQL] Requête à jointure qui ne fonctionne pas
    Par Bensor dans le forum Langage SQL
    Réponses: 2
    Dernier message: 09/12/2004, 16h10
  5. Réponses: 2
    Dernier message: 04/06/2004, 11h11

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo