Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Exécution et industrialisation Discussion :

Talend pb execution du .bat


Sujet :

Exécution et industrialisation

  1. #1
    Membre du Club
    Talend pb execution du .bat
    Bonjour,

    Lorsque j'exécute mon .bat, j'ai l'erreur :
    "Exception in thread "main" java.lang.NoClassDefFoundError: infocentre_eurica/execution_garantie/execution_garantie"

    mon job se nomme execution_garantie et dans talend est dans un répertoire
    infocentre_eurica.

    J'ai la dernière version de talend, j'uitlise la version java, et j'ai java V1.6 puisqu'il faut java1.5 minimum.
    J'exporte mon job contenant des "runJob", je dezzipe le ".zip" sur mon poste, et lorsque j'execute mon fichier ".bat", j'ai cette erreur.

    Quand j'ouvre les ficheirs ".jar" ils ne contiennent qu'un répertoire avec un fichier "MANIFEST.MF". ets ce que cela est normal?


    Quelqu'un saurait m'aider?

    Mon job fonctionne très bien depuis talend, mais je veux l'automatiser sur un serveur de production.

    Merci beaucoup

    Charlotte

  2. #2
    Membre averti
    Avec quelles options exportes-tu ton job ?

  3. #3
    Membre du Club
    Bonjour,

    J'ai tout coché quand je l'exporte, et j'ai sélectionné "windows"

  4. #4
    Membre du Club
    Voici une copie d'écran de ce que je coche quand j'exporte

  5. #5
    Membre averti
    C'est étrange, lorsque je coche tout, tout fonctionne sous Windows Vista, sous Windows XP et sous Windows 2003 Server (à chaque fois avec la JVM 1.6).
    J'ai une erreur lorsque je n'exporte pas les job scripts, ce qui est logique. Je ne parviens pas à reproduire ton erreur mais je n'utilise pas la toute dernière version de Talend. J'utilise toujours la 2.0.2 car certains exports de mes jobs de la version 2.0.2 à la dernière version échouent.
    Ton problème pourrait peut-être venir de la version de Talend.
    Tente avec une version moins récente pour voir si le problème subsiste.
    Désolé de ne pas pouvoir t'aider plus.

  6. #6
    Membre du Club
    Je vais essayé avec TOS-Win32-r2928-V2.0.0RC1 et je te redis.
    Merci

  7. #7
    Membre du Club
    Je suis en V2.0.3, et je viens de voir qu'une version V2.1.0 vient de sortir.


    Je ne peux pas tester avec la RC1 car tout plante, je vais tester avec la V2.1.0 et avec la V2.0.2.

  8. #8
    Membre du Club
    TROP BIEN, ça marche en V2.0.2.
    Bon je reste comme ça, la version 2.1.0 n'a pas voulu se lancer elle disait "out of memories", j'essayerai plus tard.


    Merci beaucoup bouvda

  9. #9
    Membre du Club
    Talend V2.1.0
    Bonjour,

    Alors ça marche aussi en V2.1.0.
    Donc je vais voir, je vais peut être rester dans cette version, c'est la V2.0.3 qui devait avoir un bug.

  10. #10
    Membre averti
    Ok merci pour l'info.
    Etrange quand même la version 2.1 étant un milestone alors que la 2.0.3 est la version stable qui normalement est plus testée et éprouvée...