Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

DevIL Discussion :

[devIL] probleme d'utilisation


Sujet :

DevIL

  1. #1
    Futur Membre du Club
    [devIL] probleme d'utilisation
    Bonjour,

    j'ai besoin d'utiliser la librairie devIL dans le cadre d'un tp openGL où je dois charger des images pour les utiliser comme textures (entre autres).

    Je traveille sous visual studio 2005 pro.

    mon problème viens de cette partie de code où j'essaye de charger une image :

    //initialisations pour devIL
    ilInit();
    iluInit();
    ilutRenderer(ILUT_OPENGL);
    ilutEnable(ILUT_OPENGL_CONV);

    //chargement de l'image d'élévation :
    ilGenImages(1,&im_elev);
    ilBindImage(im_elev);
    ilLoadImage(ILstring("terrain.jpg"));

    Je pense mon code bon puisqu'il n'y a pas d'erreur de compilation. L'erreur survient (il me semble) au moment de l'édition de liens.

    voilà ce que me répond le compilateur :

    1>------ Début de la génération : Projet : tp2, Configuration : Debug Win32 ------
    1>Édition des liens en cours...
    1>tp2.obj : error LNK2019: symbole externe non résolu __imp__ilLoadImage@4 référencé dans la fonction _main
    1>tp2.obj : error LNK2019: symbole externe non résolu __imp__ilBindImage@4 référencé dans la fonction _main
    1>tp2.obj : error LNK2019: symbole externe non résolu __imp__ilGenImages@8 référencé dans la fonction _main
    1>tp2.obj : error LNK2019: symbole externe non résolu __imp__ilutEnable@4 référencé dans la fonction _main
    1>tp2.obj : error LNK2019: symbole externe non résolu __imp__ilutRenderer@4 référencé dans la fonction _main
    1>tp2.obj : error LNK2019: symbole externe non résolu __imp__iluInit@0 référencé dans la fonction _main
    1>tp2.obj : error LNK2019: symbole externe non résolu __imp__ilInit@0 référencé dans la fonction _main
    1>C:\Documents and Settings\Elise\Bureau\SDI\TP2\tp2\Debug\tp2.exe : fatal error LNK1120: 7 externes non résolus
    1>Le journal de génération a été enregistré à l'emplacement "file://c:\Documents and Settings\Elise\Bureau\SDI\TP2\tp2\tp2\Debug\BuildLog.htm"
    1>tp2 - 8 erreur(s), 0 avertissement(s)
    ========== Génération : 0 a réussi, 1 a échoué, 0 mis à jour, 0 a été ignoré ==========

    Dans le cas où il y a une erreur de compilation, il ne me met pas ces erreurs mais il signale juste l'erreur de compilation.

    Je ne sais pas d'où peut provenir le problème.

    Avez vous une idée qui pourrait m'aider à le résoudre??

    merci

  2. #2
    Rédacteur

    Bonjour,

    il faut que fasses l'édition de lien sur Devil.lib

    dans ton source tu peux mettre :

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
     
    #pragma comment (lib, "devil.lib")


    A condition que VS sache où trouver le fichier de bibliothèque. Pour cela :

    Projet > propriétés > Edition de lien > Général > Répertoire additionnel de bibliothèque

    Maintenant tu peux soit mettre le #pragma soit (ce qui est plus propre) ajouter la lib au projet :

    Projet > propriétés > Edition de lien > entrée > dépendances supplémentaires > et là tu ajoutes : devil.lib

    Là ça l'édition de lien devrait se faire sans problèmes

  3. #3
    Futur Membre du Club
    merci beaucoup !!

###raw>template_hook.ano_emploi###