1. #1
    Membre à l'essai
    Inscrit en
    août 2006
    Messages
    60
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 60
    Points : 24
    Points
    24

    Par défaut aide pour erreur rencontrée suite à l'installation du mod pseudo subforum

    Bonjour,

    Ayant un problème avec les icônes du mod pseudo subforum sur un forum phpbb on ma dit de supprimer avec cette ligne ce fichier :

    Code X : Sélectionner tout - Visualiser dans une fenêtre à part
    DELETE lang_quick_title.php file in your language directories

    Et de faire ces modifs :

    Code sql : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    RENAME TABLE phpbb_title_infos TO phpbb_attributes;
    ALTER TABLE phpbb_attributes CHANGE id attribute_id INT(11) auto_increment NOT NULL;
    ALTER TABLE phpbb_attributes CHANGE title_info attribute VARCHAR(255) DEFAULT '' NOT NULL;
    ALTER TABLE phpbb_attributes CHANGE info_color attribute_color VARCHAR(6) DEFAULT '' NOT NULL;
    ALTER TABLE phpbb_attributes CHANGE date_format attribute_date_format VARCHAR(25) NOT NULL;
    ALTER TABLE phpbb_attributes CHANGE title_pos attribute_position TINYINT(1) DEFAULT '0' NOT NULL;
    ALTER TABLE phpbb_attributes CHANGE admin_auth attribute_administrator TINYINT(1) DEFAULT '0';
    ALTER TABLE phpbb_attributes CHANGE mod_auth attribute_moderator TINYINT(1) DEFAULT '0';
    ALTER TABLE phpbb_attributes CHANGE poster_auth attribute_author TINYINT(1) DEFAULT '0';
    ALTER TABLE phpbb_attributes DROP INDEX id, ADD PRIMARY KEY (attribute_id);
     
    ALTER TABLE phpbb_topics CHANGE title_compl_infos topic_attribute VARCHAR(255);
    ALTER TABLE phpbb_topics CHANGE title_compl_color topic_attribute_color VARCHAR(6) DEFAULT '' NOT NULL;
    ALTER TABLE phpbb_topics CHANGE title_pos topic_attribute_position TINYINT(1) DEFAULT '0' NOT NULL;
     
    ALTER TABLE phpbb_topics ADD topic_attribute_username VARCHAR(25) DEFAULT '' NOT NULL;
    ALTER TABLE phpbb_topics ADD topic_attribute_date VARCHAR(25) DEFAULT '0' NOT NULL;

    J'ai cette erreur maintenant quand je clique sur un message donc je voudrais savoir comment je pourrais faire pour remettre mon forum en fonction.

    Erreur:
    Code X : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    Could not obtain topic information
    
    DEBUG MODE
    
    SQL Error : 1054 Unknown column 't.title_compl_infos' in 'field list'
    
    SELECT t.topic_id, t.topic_title, t.topic_status, t.topic_replies, t.topic_time, t.topic_type, t.topic_vote, t.topic_last_post_id, t.title_compl_infos, t.title_compl_color, t.title_pos, f.forum_name, f.forum_status, f.forum_id, f.auth_view, f.auth_read, f.auth_post, f.auth_reply, f.auth_edit, f.auth_delete, f.auth_sticky, f.auth_announce, f.auth_pollcreate, f.auth_vote, f.auth_attachments, f.attached_forum_id FROM phpbb_topics t, phpbb_forums f WHERE t.topic_id = 444 AND f.forum_id = t.forum_id
    
    Line : 162
    File : viewtopic.php

    Merci d'avance.

  2. #2
    Membre confirmé Avatar de goodpz
    Profil pro
    Inscrit en
    février 2007
    Messages
    475
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2007
    Messages : 475
    Points : 514
    Points
    514

    Par défaut

    Apparemment la série de ALTER TABLE va changer le champ 'title_compl_infos' pour 'topic_attribute' dans la table phpbb_topics.
    Ensuite le SELECT échoue car la requête fait toujours référence à 't.title_compl_infos'. Donc met plutôt 't.topic_attribute'

  3. #3
    Membre à l'essai
    Inscrit en
    août 2006
    Messages
    60
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 60
    Points : 24
    Points
    24

    Par défaut

    Je ne comprend pas ce que je dois changer désoler , sinon il n'y a pas possibilité de remettre tout a zéro comme avant les changement , je ne peux récupérer ce que j'ai supprimer c'est ca .

  4. #4
    Membre confirmé Avatar de goodpz
    Profil pro
    Inscrit en
    février 2007
    Messages
    475
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2007
    Messages : 475
    Points : 514
    Points
    514

    Par défaut

    Line : 162
    File : viewtopic.php

    Dans la requête SQL, change 't.title_compl_infos' par 't.topic_attribute'

    Ca devrait corriger le problème, du moins par rapport à ce que tu as copié/collé dans ton premier post. Mais bon, ce problème n'est peut être que le premier d'une longue série. Je ne connais pas phpbb, je ne sais pas du tout si la solution qu'on t'a indiquée est la bonne...

    Faudra peut être que tu réinstalles tout à partir de zero..
    De plus, je pense que tu trouveras plus d'info et d'aide sur le site officiel de phpbb plutôt que ici

  5. #5
    Membre à l'essai
    Inscrit en
    août 2006
    Messages
    60
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 60
    Points : 24
    Points
    24

    Par défaut

    Hélas je n'ai pas de réponse dans le forum phpbb pour l'instant , merci de m'aider je viens de faire la modif maintenant j'obtiens cela :

    Code X : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    Could not obtain topic information
    
    DEBUG MODE
    
    SQL Error : 1054 Unknown column 't.title_compl_color' in 'field list'
    
    SELECT t.topic_id, t.topic_title, t.topic_status, t.topic_replies, t.topic_time, t.topic_type, t.topic_vote, t.topic_last_post_id, t.topic_attribute, t.title_compl_color, t.title_pos, f.forum_name, f.forum_status, f.forum_id, f.auth_view, f.auth_read, f.auth_post, f.auth_reply, f.auth_edit, f.auth_delete, f.auth_sticky, f.auth_announce, f.auth_pollcreate, f.auth_vote, f.auth_attachments, f.attached_forum_id FROM phpbb_topics t, phpbb_forums f WHERE t.topic_id = 600 AND f.forum_id = t.forum_id
    
    Line : 162
    File : viewtopic.php

  6. #6
    Membre confirmé Avatar de goodpz
    Profil pro
    Inscrit en
    février 2007
    Messages
    475
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2007
    Messages : 475
    Points : 514
    Points
    514

    Par défaut

    Pareil, dans les ALTER TABLE, on voit que 'title_compl_color' est changé pour 'topic_attribute_color'. Il faut que tu réédites comme tu as fait précédemment.

    Bonne chance pour les fix... je sens que la série va être longue

  7. #7
    Membre à l'essai
    Inscrit en
    août 2006
    Messages
    60
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 60
    Points : 24
    Points
    24

    Par défaut

    Ca avance les erreurs change lol.
    Code X : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    Could not obtain topic information
    
    DEBUG MODE
    
    SQL Error : 1054 Unknown column 't.title_pos' in 'field list'
    
    SELECT t.topic_id, t.topic_title, t.topic_status, t.topic_replies, t.topic_time, t.topic_type, t.topic_vote, t.topic_last_post_id, t.topic_attribute, t.topic_attribute_color, t.title_pos, f.forum_name, f.forum_status, f.forum_id, f.auth_view, f.auth_read, f.auth_post, f.auth_reply, f.auth_edit, f.auth_delete, f.auth_sticky, f.auth_announce, f.auth_pollcreate, f.auth_vote, f.auth_attachments, f.attached_forum_id FROM phpbb_topics t, phpbb_forums f WHERE t.topic_id = 2 AND f.forum_id = t.forum_id
    
    Line : 162
    File : viewtopic.php

Discussions similaires

  1. [XL-2007] Besoin d'aide pour erreur d'exécution VBA
    Par DarkBoon dans le forum Macros et VBA Excel
    Réponses: 0
    Dernier message: 11/08/2011, 10h51
  2. [XL-2003] Aide pour erreur dans un code Vba Excel
    Par NEC14 dans le forum Macros et VBA Excel
    Réponses: 10
    Dernier message: 25/05/2009, 07h48
  3. [JpGraph] Besoin d'aide pour son installation
    Par kcizth dans le forum JpGraph
    Réponses: 1
    Dernier message: 30/01/2006, 11h05
  4. [JpGraph] Besoin d'aide pour l'installation de jpgraph
    Par lapinou33 dans le forum JpGraph
    Réponses: 6
    Dernier message: 29/01/2006, 12h59
  5. [Kylix] besoin d'aide pour installer kylix3
    Par Sph@x dans le forum EDI
    Réponses: 3
    Dernier message: 11/02/2004, 13h53

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo