Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

GTK+ Discussion :

[gtkmm] Probleme d include


Sujet :

GTK+

  1. #1
    Futur Membre du Club
    [gtkmm] Probleme d include
    Bonjour tt le monde,

    J'ai un projet à réaliser en C++ et je dois coder une interface graphique pour ce dernier, j ai donc choisi GTK+ il y a une semaine.
    J'ai pu coder mon interface comme voulu mais quand j ai voulu inclure les .h de mes classes C++, le compilateur me met une erreur comme quoi il ne trouve pas le .h (exemple : <string.h> qui est une lib C est reconnue mais pas <string>).
    J ai donc cherché sur le net et vu que gtkmm etait mieux pour le C++ mais ayant déjà toute mon interface de faite j aurai aimé savoir s'il n'avait pas un moyen de faire accepté les librairies C++ à mon interface GTK+.
    Merci d avance.


    En attendant, les réponses, j ai installé gtkmm via un apt-get, les librairies de dev. En faisant un pkg-config --modversion gtkmm-2.4 il trouve bien la version 2.8.8 mais quand je tente de compiler un programme gtkmm, il me dit gtkmm.h : aucun fichier ou répertoire de ce type trouvé. Je ne comprends pas...

  2. #2
    Futur Membre du Club
    Citation Envoyé par Valistar
    Bonjour tt le monde,

    J'ai un projet à réaliser en C++ et je dois coder une interface graphique pour ce dernier, j ai donc choisi GTK+ il y a une semaine.
    J'ai pu coder mon interface comme voulu mais quand j ai voulu inclure les .h de mes classes C++, le compilateur me met une erreur comme quoi il ne trouve pas le .h (exemple : <string.h> qui est une lib C est reconnue mais pas <string>).
    J ai donc cherché sur le net et vu que gtkmm etait mieux pour le C++ mais ayant déjà toute mon interface de faite j aurai aimé savoir s'il n'avait pas un moyen de faire accepté les librairies C++ à mon interface GTK+.
    Merci d avance.


    En attendant, les réponses, j ai installé gtkmm via un apt-get, les librairies de dev. En faisant un pkg-config --modversion gtkmm-2.4 il trouve bien la version 2.8.8 mais quand je tente de compiler un programme gtkmm, il me dit gtkmm.h : aucun fichier ou répertoire de ce type trouvé. Je ne comprends pas...

    slt, j'ai aussi eu le meme probleme.
    je t'invite à vérifier ton makefile, si tu passe les bons parametres de compilation. et aussi vérifie bien dans /usr/include/gtkmm-2.4/ si le fichier gtkmm.h y est attention chez moi c'est la version 2.4 sous debian. sit out est OK ya pas de raison que ça marche pas.

###raw>template_hook.ano_emploi###