IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Windows Presentation Foundation Discussion :

[Blend beta 1][VS Extension WPF CTP 11/06] VS ne lit pas le code généré par Blend


Sujet :

Windows Presentation Foundation

  1. #1
    Membre expérimenté
    Avatar de FRED.G
    Profil pro
    Inscrit en
    novembre 2002
    Messages
    1 032
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France

    Informations forums :
    Inscription : novembre 2002
    Messages : 1 032
    Points : 1 505
    Points
    1 505
    Par défaut [Blend beta 1][VS Extension WPF CTP 11/06] VS ne lit pas le code généré par Blend
    Lorsque je design une fenêtre Window1 sous Blend (beta 1), j'ai un mappage à l'espace de nom de mon asembly principal (WPFApplication1) qui est généré comme ceci :
    Code xml : Sélectionner tout - Visualiser dans une fenêtre à part
    mc:Ignorable="d" xmlns:WPFApplication1="clr-namespace:WPFApplication1"

    Le problème, c'est que lorsque je veux ouvrir mon fichier Window1.xaml sous VS, VS me sort l'erreur suivante :
    Assembly '' was not found. The 'clr-namespace' URI refers to an assembly that is not referenced by the project.
    Et aussi l'avertissement suivant :
    L'attribut 'http://schemas.openxmlformats.org/markup-compatibility/2006:Ignorable' n'est pas déclaré.
    Comment faire ?
    (\ _ /)
    (='.'=)
    (")-(")

  2. #2
    Membre expérimenté
    Avatar de FRED.G
    Profil pro
    Inscrit en
    novembre 2002
    Messages
    1 032
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France

    Informations forums :
    Inscription : novembre 2002
    Messages : 1 032
    Points : 1 505
    Points
    1 505
    Par défaut
    J'ai l'impression que le problème concerne l'extension de VS car le code XAML compile bien dans Blend.

    Pour le namespace, dans le doute, j'ai ajouté la référence à l'assembly en plus du namespace.
    Avec le sample CollectionViewSource_VB du SDK, ça donne :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    xmlns:src="clr-namespace:CollectionViewSource_VB;assembly=CollectionViewSource_VB"
    Le pb de VS est qu'il ne reconnait pas la classe Places dans :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    <src:Places x:Key="places"/>
    Cette ligne est soulignée avec le commentaire suivant :
    L'élément 'Window.Resources' dans l'espace de noms 'http://schemas.microsoft.com/winfx/2006/xaml/presentation' a un élément enfant non valide 'Places' dans l'espace de noms 'clr-namespace:CollectionViewSource_VB;assembly=CollectionViewSource_VB'. Liste d'éléments possibles attendue : 'ResourceDictionary.MergedDictionaries, ResourceDictionary.Source, ResourceDictionary.IsReadOnly, ResourceDictionary.Keys, ResourceDictionary.Values, sgObject, sgValueType, Point, Size, Vector, Rect, Matrix, Int32Rect, Duration, FontStyle, FontStretch, FontWeight, KeyTime, RepeatBehavior, Color, PixelFormat, Matrix3D, Point3D, Point4D, Quaternion, Rect3D, Size3D, Vector3D, CornerRadius, FigureLength, GridLength, Thickness, DependencyProperty, sgDispatcherObject, sgDependencyObject, sgFreezable, sgAnimatable, TextDecoration, TextDecorationCollection, sgTimeline, sgAnimationTimeline, sgDoubleAnimationBase, DoubleAnimationUsingPath, DoubleAnimation, DoubleAnimationUsingKeyFrames, sgBooleanAnimationBase, BooleanAnimationUsingKeyFrames, sgByteAnimationBase, ByteAnimation, ByteAnimationUsingKeyFrames, sgCharAnimationBase, CharAnimationUsingKeyFrames, sgColorAnimationBase, ColorAnimation, ColorAnimationUsingKeyFrames, sgDecimalAnimationBase, DecimalAnimation, DecimalAnimationUsingKeyFrames, sgInt16AnimationBase, ....

    Donc pour aller droit au but :

    Comment faites-vous pour déclarer une instance de classe comme ressource d'une <Window/> ?
    (\ _ /)
    (='.'=)
    (")-(")

  3. #3
    Rédacteur
    Avatar de Thomas Lebrun
    Profil pro
    Inscrit en
    octobre 2002
    Messages
    9 161
    Détails du profil
    Informations personnelles :
    Âge : 39
    Localisation : France

    Informations forums :
    Inscription : octobre 2002
    Messages : 9 161
    Points : 19 434
    Points
    19 434
    Par défaut
    Normalement, il ne devrait pas y avoir de pb: il faut juste que tu t'assures que la classePlace est bien dans le namespace CollectionViewSource_VB

  4. #4
    Membre expérimenté
    Avatar de FRED.G
    Profil pro
    Inscrit en
    novembre 2002
    Messages
    1 032
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France

    Informations forums :
    Inscription : novembre 2002
    Messages : 1 032
    Points : 1 505
    Points
    1 505
    Par défaut
    il faut juste que tu t'assures que la classePlace est bien dans le namespace CollectionViewSource_VB
    C'est le cas, il s'agit du projet issu du SDK. Et j'ai le même souci avec un projet perso où j'ai bien vérifié les NameSpace.


    Peut-être que c'est du au fait que mon Visual Studio est en version française et que l'extension est mal adaptée ?
    (\ _ /)
    (='.'=)
    (")-(")

  5. #5
    Rédacteur
    Avatar de Thomas Lebrun
    Profil pro
    Inscrit en
    octobre 2002
    Messages
    9 161
    Détails du profil
    Informations personnelles :
    Âge : 39
    Localisation : France

    Informations forums :
    Inscription : octobre 2002
    Messages : 9 161
    Points : 19 434
    Points
    19 434
    Par défaut
    Hum.. je doute que ce soit la cause du problème...

Discussions similaires

  1. Réponses: 0
    Dernier message: 21/11/2013, 17h35
  2. [WPF 3.5] - Application ne se lance pas
    Par Anto03 dans le forum Framework .NET
    Réponses: 0
    Dernier message: 04/07/2011, 16h54
  3. WPF ListBox : comment itérer dans les ListBoxItem dans le "code behind"
    Par jmnicolas dans le forum Windows Presentation Foundation
    Réponses: 2
    Dernier message: 07/10/2010, 15h24
  4. Contrôle WPF dans Winforms. Les boutons ne sont pas cliquables.
    Par mathdu57 dans le forum Windows Forms
    Réponses: 0
    Dernier message: 03/03/2010, 16h04
  5. Extension par défaut d'un fichier généré par un spool
    Par lcloatre dans le forum Sql*Plus
    Réponses: 1
    Dernier message: 10/10/2007, 15h30

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo