IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

ASP Discussion :

[Microsoft][ODBC SQL Server] 6 + ASP


Sujet :

ASP

  1. #1
    Opo
    Opo est déconnecté
    Nouveau membre du Club
    Inscrit en
    juillet 2002
    Messages
    35
    Détails du profil
    Informations forums :
    Inscription : juillet 2002
    Messages : 35
    Points : 36
    Points
    36
    Par défaut [Microsoft][ODBC SQL Server] 6 + ASP
    Bonjour,

    A l'intérieur de mon script ASP, j'utilise une commande permettant l'exécution d'une proc stock sous SQL Server 2000 :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    		Set cmd = Server.CreateObject("ADODB.Command")
      		cmd.ActiveConnection = cnx
    	  	cmd.CommandText = "P_GET_SUIVI_ACTIVITE"
      		cmd.CommandType = adCmdStoredProc
     
    	  	cmd.Parameters.Refresh
    		' Parametres dans l'ordre procedure  
    	  	cmd.Parameters(1).Value = session("AgentID")
    	  	cmd.Parameters(2).Value = ANNEE_DEBUT_ENCOURS
    		cmd.Parameters(3).Value = MOIS_DEBUT_ENCOURS
    	  	cmd.Parameters(4).Value = ANNEE_FIN_ENCOURS
    	  	cmd.Parameters(5).Value = MOIS_FIN_ENCOURS	  	 	
      		Set Requete = cmd.execute
    Et "souvent" (mais pas toujours) à la 1ere exécution, j'ai l'erreur suivante :

    Microsoft OLE DB Provider for ODBC Drivers: [Microsoft][ODBC SQL Server
    Driver][SQL Server]6

    et si je relance le script derrière, tout est OK.
    Est ce que qqn saurait me dire comment me débarrasser de ce truc là ?
    D'avance merci

  2. #2
    Expert éminent
    Avatar de Immobilis
    Homme Profil pro
    Développeur .NET
    Inscrit en
    mars 2004
    Messages
    6 559
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : mars 2004
    Messages : 6 559
    Points : 9 512
    Points
    9 512
    Par défaut
    Salut,

    C'est quoi ta chaine de connection?

    A+
    "Winter is coming" (ma nouvelle page d'accueil)

  3. #3
    Opo
    Opo est déconnecté
    Nouveau membre du Club
    Inscrit en
    juillet 2002
    Messages
    35
    Détails du profil
    Informations forums :
    Inscription : juillet 2002
    Messages : 35
    Points : 36
    Points
    36
    Par défaut
    J'ai trouvé !!
    En fait l'erreur 6.... C'est que j'essaye de supprimer une table qui n'existe pas ! (sans controle avant ds le catalogue !!)
    Merci pour vos réponses !

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 4
    Dernier message: 29/02/2012, 20h53
  2. Réponses: 1
    Dernier message: 30/12/2010, 17h50
  3. Réponses: 1
    Dernier message: 23/07/2010, 17h09
  4. Réponses: 3
    Dernier message: 08/07/2010, 10h35
  5. Réponses: 0
    Dernier message: 20/03/2008, 15h05

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo