IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre expert

    Profil pro
    Développeur informatique
    Inscrit en
    janvier 2003
    Messages
    1 737
    Détails du profil
    Informations personnelles :
    Âge : 39
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : janvier 2003
    Messages : 1 737
    Points : 3 068
    Points
    3 068
    Par défaut Gros Problème avec DirectShow et la méthode RELEASE
    je suis en train de créer un appli qui utilise direct show et quand j'appelle la méthode release, ca plante, alors que si je ne l'appelle pas, tout se passe correctement. de plus dans tous les exemples que j'i pu voir, il n'y a aucun problème avec cette méthode ??? est-ce que quelqu'un pourrait éclairer ma lanterne ???

    merci d'avace à tous

  2. #2
    mat.M
    Invité(e)
    Par défaut
    je suis en train de créer un appli qui utilise direct show et quand j'appelle la méthode release
    Quel méthode , quelle interface ??
    Attention quand on ajoute des interfaces à IGraphBuilder par exemple , il faut les effacer dans l'ordre où elles ont été empilées .

  3. #3
    Membre expert

    Profil pro
    Développeur informatique
    Inscrit en
    janvier 2003
    Messages
    1 737
    Détails du profil
    Informations personnelles :
    Âge : 39
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : janvier 2003
    Messages : 1 737
    Points : 3 068
    Points
    3 068
    Par défaut
    par exemple, je crée un graphbuilder puis un media control puis un media event et quand j'appelle la methode release de chacun d'eux problème

    mais ca marche mieux comme tu m'as dit

    j'ai un autre problème.

    quand je lance une video, je perd le control sur l'appli. je ne vois pas d'ou ca vien

  4. #4
    mat.M
    Invité(e)
    Par défaut
    Une astuce : utiliser une macro du genre SAFE_RELEASE:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
    #define SAFE_RELEASE(a )  {if(a!=NULL)a->Release();a=NULL}
     
     
    SAFE_RELEASE(pMediaControl);
    SAFE_RELEASE(pGraphBuilder);

    quand je lance une video, je perd le control sur l'appli. je ne vois pas d'ou ca vien
    merci de détailler plus

Discussions similaires

  1. Gros problème avec regexp
    Par dmbsys dans le forum ASP
    Réponses: 6
    Dernier message: 29/04/2006, 16h23
  2. Gros problème avec J2SE
    Par StreamEarth dans le forum Général Java
    Réponses: 13
    Dernier message: 23/04/2006, 22h06
  3. Gros problème avec les colations
    Par scaleo dans le forum MS SQL Server
    Réponses: 3
    Dernier message: 15/11/2005, 09h36
  4. [Custom Tags] Problème avec une surcharge de méthode
    Par Strab dans le forum Taglibs
    Réponses: 19
    Dernier message: 26/08/2005, 16h34
  5. Gros problème avec la facturation de Tiscali
    Par Harry dans le forum Dépannage et Assistance
    Réponses: 5
    Dernier message: 21/10/2004, 18h55

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo