IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Réseau Discussion :

Resolv.conf change au reboot


Sujet :

Réseau

  1. #1
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 799
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 799
    Points : 499 035
    Points
    499 035
    Par défaut Resolv.conf change au reboot
    Salut à tous,
    question bete, j'ai voulu changer mon resolv.conf qui ressemblé à ça :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    search domaine1
    nameserver 192.168.100.10
    en

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    search domaine1 domaine2
    nameserver 192.168.100.10
    nameserver 192.168.103.10
    probleme, quand je redemarre le serveur, il me remet l'ancien resolv.conf, ou ai je oublié une étape?

    Merci

  2. #2
    Membre chevronné

    Profil pro
    Inscrit en
    mars 2004
    Messages
    1 296
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2004
    Messages : 1 296
    Points : 1 774
    Points
    1 774
    Par défaut
    Tu as surement une adresse ip dynamique (via dhcp) , hors dhcp par defaut remplace le resolv.conf .... il te faut modifier les options de ton dhcp client pour ne pas mettre a jours le resolv.conf.
    Marc
    Slackware for ever ......
    BASH - KSH ( http://marcg.developpez.com/ksh/ )

  3. #3
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 799
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 799
    Points : 499 035
    Points
    499 035
    Par défaut
    Le fichier de configuration /etc/resolv.conf contient les informations sur les requêtes DNS et j'ai cru comprendre qu'il est généré automatiquement à chaque requête DHCP. comment faire pour qu'il ma génére comme je le souhaite?

  4. #4
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 799
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 799
    Points : 499 035
    Points
    499 035
    Par défaut
    Citation Envoyé par MarcG
    Tu as surement une adresse ip dynamique (via dhcp) , hors dhcp par defaut remplace le resolv.conf .... il te faut modifier les options de ton dhcp client pour ne pas mettre a jours le resolv.conf.
    Oui, 192.168.100.10 est generé par un dhcp du reseau centrale.
    dans mon cluster, je genere sur eth0 une adresse fixe 192.168.103.10. ce serveur possede son DNS et comme je souhaite gerer les resolution de nom, j'ai donc installé bind, cree le domaine domaine2.
    seulement tout est ok si je modifie à la main le resolv.conf et fais
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    /etc/init.d/bind9 reload
    pour ajouter le domaine que j'ai cree, je sais pas comment faire pour qu'il ne soit pas regenere ou bien pour qu'il le genere comme je le souhaite

    Merci

  5. #5
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 799
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 799
    Points : 499 035
    Points
    499 035
    Par défaut
    Bon je viens de résoudre le souci d'une autre façon. J'aurais pu otper pour l'ecriture d'un script qui modifie le fichier au démarrage, mais j'ai pas trouvé cela tres propre. Alors Sous Debian, il existe un paquet s'appellant resolvconf
    En fonction du type de connexion utilisé, il est parfois nécessaire de faire appel à différents serveurs de noms (DNS). Par exemple, lors d’une connexion à son lieu de travail, il faut utiliser le serveur DNS de son réseau, mais lors d’une connexion à internet, il faut utiliser les serveurs DNS de son fournisseur d’accès. Dans ce cas, le paquet « resolvconf » sous Debian permet de résoudre ces problèmes.

    Présentation et installation de resolvconf

    Le paquet « resolvconf » permet de gérer très finement le contenu du fichier « /etc/resolv.conf » servant à la résolution des noms en fonction du type de connexion utilisé et en récupérant les informations à différents endroits statiques ou dynamiques (clients ppp, dhcp ou autres).

    # aptitude install resolvconf
    ATTENTION : Pour que ce paquet fonctionne correctement, j’ai dû redémarrer l’ordinateur.

    Une fois le paquet « resolvconf » installé, il ne faut plus modifier le fichier « /etc/resolv.conf », car le contenu de celui-ci sera automatiquement géré et remplacé par « resolvconf ».
    J'ai ensuite modifié mon fichier /etc/network/interfaces
    qui ressemblé à ceci :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
     
     auto lo
     iface lo inet loopback
     
     auto eth1
     iface eth1 inet dhcp
     
     auto eth0
     iface eth0 inet static
     address 192.168.103.10
     netmask 255.255.255.0
    par ceci
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
     
     auto lo
     iface lo inet loopback
     
     auto eth1
     iface eth1 inet dhcp
     
     auto eth0
     iface eth0 inet static
     address 192.168.103.10
     netmask 255.255.255.0
     dns-search domaine2
     dns-nameservers 192.168.103.10
    j'ai rebooté mon serveur, et mon resolv.conf a maintenant cette tête
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
     
     # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvc        onf(8)
     #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
     nameserver 127.0.0.1
     nameserver 192.168.103.10
     nameserver 192.168.100.10
     search domaine2 domaine1
    Voilà, si quelqu'un à une meilleur solution, je suis preneur. Sinon j'espère que ça aidera certaines personnes (voici le lien référant).

  6. #6
    Membre éprouvé
    Profil pro
    Inscrit en
    mai 2004
    Messages
    792
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations forums :
    Inscription : mai 2004
    Messages : 792
    Points : 1 206
    Points
    1 206
    Par défaut
    J'ai un problème similaire. Mais d'abord, le contexte qui a son intérêt.

    Dans mon lan domestique j'ai installé un serveur qui fait, entre-autre, la résolution de nom (DNSmasq). Ceci m'évite de devoir changer tous les fichiers hosts des machines du lan (7 machines)

    Cette machine n'étant pas up toute la journée le service DHCP est fourni par le router du réseau.

    Le premier nameserver du resolv.conf est l'IP du serveur DNSmasq. Suivi de nameserver externes (de mon FAI). Si mon serveur DNSmasq n'est pas allumé, une demande de résolution de nom (navigateur, par exemple) attendra le timeout par défaut (5 secondes) avant de passer aux suivants. Et 5 secondes, c'est long pour un navigateur!

    Solution: rajouter une option timeout dans le resolv.conf:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    options timeout:1
    # serveur DNS primaire (DNSmasq local)
    nameserver 192.168.0.158
    # autres (FAI - publics)
    nameserver 195.238.2.22
    nameserver 195.238.2.21
    Comme l'a signalé djibril, à chaque fois que le dhclient d'une machine du lan envoie sa demande au serveur DHCP (un router dans mon cas) le resolv.conf est écrasé.
    • Solution partielle
      Il est possible de rajouter un nameserver en utilisant l'instruction prepend dans le fichier dhclient.conf:
      Code : Sélectionner tout - Visualiser dans une fenêtre à part
      prepend domain-name-servers 192.168.0.158
      Mais, impossible d'y mettre l'option timeout pour la recherche de nom de domaines.

    • Solution radicale
      Créer un hook qui s'exécutera au démarrage du dhclient. Chez Debian il se trouvera dans /etc/dhcp3/dhclient-enter-hooks.d/. Je l'ai appellé monHook et il contient simplement ceci:
      Code : Sélectionner tout - Visualiser dans une fenêtre à part
      1
      2
      3
      make_resolv_conf() {
              echo "doing nothing to resolv.conf"
      }
      Un petit ifdown/ifup pour vérifier et ça doit fonctionner.


    Plus de détails dans man resolv.conf et man dhclient-script
    :q :q! :wq :w :w! :wq! :quit :quit! :help help helpquit quit quithelp
    :quitplease :quitnow :leave :shit ^X^C ^C ^D ^Z ^Q QUITDAMMIT
    Jabber: ripat at im.apinc.org

  7. #7
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 799
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 799
    Points : 499 035
    Points
    499 035
    Par défaut
    bon, encore cette merde qui recommence.
    Sur le même serveur, j'ai été amané à changer les disques dur, donc tout reinstaller.
    Le souci actuel est que dans mon fichier resolv.conf, j'ai ceci :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
     # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvc        onf(8)
     #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
     nameserver 127.0.0.1
     search domaine2 domaine1
    au lieu d'avoir ceci
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvc onf(8)
    # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    nameserver 192.168.103.10
    nameserver 192.168.100.10
    search domaine2 domaine1
    resolvconf ne m'affiche pas les adresses IP des nameserver et je ne sais pas pourquoi, pourtant, j'ai fait exactement la même chose.

  8. #8
    Membre actif

    Inscrit en
    mars 2003
    Messages
    241
    Détails du profil
    Informations forums :
    Inscription : mars 2003
    Messages : 241
    Points : 235
    Points
    235
    Par défaut
    Justement le paquet resolvconf peut t'aider comme tu l'as signalé...

    Tu peux forcer son comportement en éditant les fichiers dans le dossier de mémoire :
    /etc/resolvconf/resolv.conf.d/
    Il y a différents fichiers qui permettent de modifier le /etc/resolv.conf comme tu le souhaite notamment dans ton cas les fichiers base ou head...

  9. #9
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 799
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 799
    Points : 499 035
    Points
    499 035
    Par défaut
    j'ai essayé, certe ça met bien les nameserver dans le resolf.conf, mais je ne trouve pas ça propre, je n'avais pas besoin de faire ça avant.
    A partir du fichier /etc/netxork/interface, il me le faisait.
    De plus, même quand il le rajoute, je trouve que c hyper hyper long si je fais un ping de 192.168.100.10 et je ne comprends pas, j'avais pas ces soucis avant

  10. #10
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 799
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 799
    Points : 499 035
    Points
    499 035
    Par défaut
    souvi résolu.
    J'avais oublié de rajouter dans le fichier /etc/bind/named.conf.options mon forwarder (IP vers mon DNS principal).
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    cat /etc/bind/named.conf.options
    options {
            directory "/var/cache/bind";
    
            // If there is a firewall between you and nameservers you want
            // to talk to, you might need to uncomment the query-source
            // directive below.  Previous versions of BIND always asked
            // questions using port 53, but BIND 8.1 and later use an unprivileged
            // port by default.
    
            // query-source address * port 53;
    
            // If your ISP provided one or more IP addresses for stable
            // nameservers, you probably want to use them as forwarders.
            // Uncomment the following block, and insert the addresses replacing
            // the all-0's placeholder.
    
             forwarders {
                    192.168.100.10;
             };
    
            auth-nxdomain no;    # conform to RFC1035
            listen-on-v6 { any; };
    };
    
    du coup, dans resolv.conf, j'ai toujours 
    
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    12
    nameserver 127.0.0.1
     search domaine2 domaine1
    Mais mon réseau fonctionne correctement et sans souci

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 6
    Dernier message: 28/02/2009, 16h57
  2. ajout de plusieurs DNS dans /etc/resolv.conf
    Par Ohemeg dans le forum Unix
    Réponses: 3
    Dernier message: 13/11/2008, 16h18
  3. Explication named.conf et resolv.conf
    Par mat777 dans le forum Réseau
    Réponses: 1
    Dernier message: 17/12/2007, 18h23
  4. [fedora] resolv.conf, comment modifier
    Par djibril dans le forum Réseau
    Réponses: 15
    Dernier message: 16/04/2007, 16h04
  5. Réponses: 4
    Dernier message: 19/03/2004, 12h48

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo