IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

HyperFileSQL Discussion :

plusieurs dossier en HFSQL client serveur ? [HF20]


Sujet :

HyperFileSQL

  1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    Août 2017
    Messages
    82
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : Algérie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : Août 2017
    Messages : 82
    Points : 0
    Points
    0
    Par défaut plusieurs dossier en HFSQL client serveur ?
    bonjour tout le monde . Jai réaliser un logiciel qui fonctionne très bien en HFSQL classique une application qui j'aire plusieurs exercice

    mais Jai décide de rendre le projet en mode HFSQL client serveur

    code de la fenêtre déclaration globale

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    ROCEDURE MaFenêtre()
    sRepertoirte1 est une chaîne
    sRepertoirte1=ComplèteRep("C:\Ordre de facturation\Societes\")
    UnRépertoire, ResListeRépertoire sont des chaînes
    ResListeRépertoire = fListeRépertoire(sRepertoirte1)
     
    POUR TOUTE CHAÎNE UnRépertoire DE ResListeRépertoire SEPAREE PAR RC
     
    xSoss est un numérique
    xSoss=ChaîneOccurrence(UnRépertoire,"\") +1
     
    sOs est une chaîne
    sOs=ExtraitChaîne(UnRépertoire,xSoss,"\")
     
    TableAjoute(TABLE_liste_fichiers,sOs)
    FIN


    mais e mode HFSQL client serveur

    Jai utiliser le code :
    maConnexion est une Connexion

  2. #2
    Nouveau Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    Août 2017
    Messages
    82
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : Algérie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : Août 2017
    Messages : 82
    Points : 0
    Points
    0
    Par défaut
    et pour le code du bouton création

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    SI SAI_CREE_UNE_SOCIETE~~"" ALORS
    	RepriseSaisie(SAI_CREE_UNE_SOCIETE)
    FIN
    SI fRépertoireExiste(SAI_CREE_UNE_SOCIETE)=Vrai ALORS 
    	Info("Le répertoire "+SAI_CREE_UNE_SOCIETE +" existe déja")
    	RepriseSaisie(SAI_CREE_UNE_SOCIETE)
    FIN
    SI fRepCrée("C:\Ordre de facturation\Societes\"+SAI_CREE_UNE_SOCIETE)= Vrai ALORS //Info("Le répertoire a été créé")
    	RepINI est une chaîne
    	SI fRepDonnées() <> "" ALORS
    		RepINI = fRepDonnées() + ["\"] + "Fichier.INI"
    	SINON
    		RepINI = "Fichier.INI"     
    	FIN
    	INIEcrit("Parametre", "Chemin", fRepDonnées() + ["\"] +SAI_CREE_UNE_SOCIETE , RepINI)
    	SI ErreurDétectée ALORS
    		Erreur()
    		RETOUR
    	FIN
    FIN
    TableAjoute(TABLE_liste_fichiers,SAI_CREE_UNE_SOCIETE)
    MaFenêtre..ValeurRenvoyée = Vrai
    code bouton selection
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    sLerep est une chaîne
    sLerep=TABLE_liste_fichiers.COL_Liste_des_fichiers
    HFerme("*")
    HChangeRep("*","C:\Ordre de facturation\"+"\Societes\" + sLerep )
    TitreSuivant("MENUE be" +" | "+ sLerep)
    Utilise(FEN_MENUE)

  3. #3
    Membre expérimenté
    Profil pro
    Inscrit en
    Avril 2010
    Messages
    917
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Avril 2010
    Messages : 917
    Points : 1 499
    Points
    1 499
    Par défaut
    Bonsoir
    Quelle est la question ?

  4. #4
    Nouveau Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    Août 2017
    Messages
    82
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : Algérie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : Août 2017
    Messages : 82
    Points : 0
    Points
    0
    Par défaut
    je veux quand j'exécute le programme Jai la possibilité de crée plusieurs dossier sur le serveur

    quand je change de metode jai utiliser le code

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    maConnexion est une Connexion
     
    // Paramètres de la connexion
    maConnexion..Provider = hAccèsHFClientServeur
    maConnexion..Utilisateur = "admin"
    maConnexion..MotDePasse = "1234"
    maConnexion..Serveur = "127.0.0.1:4900"
    maConnexion..BaseDeDonnées = "BDD_be"
    maConnexion..Cryptage = hCryptageNon

  5. #5
    Nouveau Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    Août 2017
    Messages
    82
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : Algérie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : Août 2017
    Messages : 82
    Points : 0
    Points
    0
    Par défaut
    image de la fenêtre
    Nom : fen.png
Affichages : 63
Taille : 23,4 Ko

  6. #6
    Membre expérimenté
    Profil pro
    Inscrit en
    Avril 2010
    Messages
    917
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Avril 2010
    Messages : 917
    Points : 1 499
    Points
    1 499
    Par défaut
    Suivant l'aide :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    Important
    Sous HFSQL Client/Serveur :
    
    • La fonction HSubstRep n'est pas prise en compte. En effet, cette fonction permet uniquement de substituer les répertoires des fichiers HFSQL Réseau.
    • Si la fonction HChangeRep est utilisée, il est nécessaire de spécifier un chemin relatif au répertoire de la base de données de l'application sur le serveur. Ce fonctionnement permet d'être indépendant de l'emplacement du serveur utilisé.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [WD19] Comment convertir une analyse HFSQL Client/Serveur en base
    Par koukic11 dans le forum WinDev
    Réponses: 0
    Dernier message: 02/06/2015, 14h52
  2. [WD20] Installation simple d'une application HFSQL Client Serveur
    Par lololebricoleur dans le forum WinDev
    Réponses: 7
    Dernier message: 15/12/2014, 08h04
  3. Windev V18 HFSQL Client/Serveur
    Par Thibodeau dans le forum WinDev
    Réponses: 13
    Dernier message: 20/11/2014, 16h03
  4. [WD19] Déploiement d'une application avec HFSQL client/serveur
    Par jjacques68 dans le forum WinDev
    Réponses: 1
    Dernier message: 03/11/2014, 08h39
  5. [HF18] Projet en HF classic et fichier en HFSQL Client/Serveur
    Par FRANCOISEAICM dans le forum HyperFileSQL
    Réponses: 3
    Dernier message: 04/09/2014, 16h58

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo