IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Ubuntu Discussion :

Bloquer par php 8.2 sous ubuntu server 18.04 -


Sujet :

Ubuntu

  1. #1
    Membre régulier Avatar de BXDSPORT
    Homme Profil pro
    Consultant informatique
    Inscrit en
    Mars 2002
    Messages
    353
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Mayenne (Pays de la Loire)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : Mars 2002
    Messages : 353
    Points : 96
    Points
    96
    Par défaut Bloquer par php 8.2 sous ubuntu server 18.04 -
    Bonjour
    Beaucoup de souci car erreur listé ci-dessous
    Code x : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    root@sbt53:/var/lib/apache2/conf# apt install php8.2
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l'impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n'ont pas encore
    été créés ou ne sont pas sortis d'Incoming.
    L'information suivante devrait vous aider à résoudre la situation*:
    
    Les paquets suivants contiennent des dépendances non satisfaites*:
     php8.2 : Dépend: libapache2-mod-php8.2 mais ne sera pas installé ou
                       php8.2-fpm mais ne sera pas installé ou
                       php8.2-cgi mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode «*garder en l'état*».
    root@sbt53:/var/lib/apache2/conf# apt install php8.2-cgi
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l'impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n'ont pas encore
    été créés ou ne sont pas sortis d'Incoming.
    L'information suivante devrait vous aider à résoudre la situation*:
    
    Les paquets suivants contiennent des dépendances non satisfaites*:
     php8.2-cgi : Dépend: php8.2-cli mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode «*garder en l'état*».
    root@sbt53:/var/lib/apache2/conf# apt install php8.2-cli
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l'impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n'ont pas encore
    été créés ou ne sont pas sortis d'Incoming.
    L'information suivante devrait vous aider à résoudre la situation*:
    
    Les paquets suivants contiennent des dépendances non satisfaites*:
     php8.2-cli : Dépend: php8.2-readline mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode «*garder en l'état*».
    root@sbt53:/var/lib/apache2/conf# apt install php8.2-readline
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l'impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n'ont pas encore
    été créés ou ne sont pas sortis d'Incoming.
    L'information suivante devrait vous aider à résoudre la situation*:
    
    Les paquets suivants contiennent des dépendances non satisfaites*:
     php8.2-readline : Dépend: libncurses6 (>= 6) mais il n'est pas installable
                       Dépend: libtinfo6 (>= 6) mais il n'est pas installable
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode «*garder en l'état*».

    Pouvez vous me donner une solution pour pouvoir mettre à jour mon système.
    Cordialement à vous tous
    Cordialement à tous

    Votre savoir devient mon savoir qui deviendra votre savoir, telle est la connaissance qui appartient à tous

  2. #2
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    Février 2008
    Messages
    7 549
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Février 2008
    Messages : 7 549
    Points : 19 375
    Points
    19 375
    Par défaut
    Bonjour,

    tu as fait un update avant de faire l'install ?
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

  3. #3
    Membre régulier Avatar de BXDSPORT
    Homme Profil pro
    Consultant informatique
    Inscrit en
    Mars 2002
    Messages
    353
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Mayenne (Pays de la Loire)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : Mars 2002
    Messages : 353
    Points : 96
    Points
    96
    Par défaut
    Oui
    Cordialement à tous

    Votre savoir devient mon savoir qui deviendra votre savoir, telle est la connaissance qui appartient à tous

  4. #4
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    Février 2008
    Messages
    7 549
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Février 2008
    Messages : 7 549
    Points : 19 375
    Points
    19 375
    Par défaut
    Ubuntu 18 est en fin de vie, non ?
    tu ne peux pas upgrader vers une version plus récente ?
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

  5. #5
    Membre régulier Avatar de BXDSPORT
    Homme Profil pro
    Consultant informatique
    Inscrit en
    Mars 2002
    Messages
    353
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Mayenne (Pays de la Loire)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : Mars 2002
    Messages : 353
    Points : 96
    Points
    96
    Par défaut
    Car justement ce message me bloque upgrade.
    Cordialement à tous

    Votre savoir devient mon savoir qui deviendra votre savoir, telle est la connaissance qui appartient à tous

  6. #6
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    Février 2008
    Messages
    7 549
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Février 2008
    Messages : 7 549
    Points : 19 375
    Points
    19 375
    Par défaut
    je parle d'upgrader la distribution.
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

  7. #7
    Membre régulier Avatar de BXDSPORT
    Homme Profil pro
    Consultant informatique
    Inscrit en
    Mars 2002
    Messages
    353
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Mayenne (Pays de la Loire)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : Mars 2002
    Messages : 353
    Points : 96
    Points
    96
    Par défaut
    Oui, do-release upgrade me retourne le message de mettre à jour upgrader et puis relancer.
    Cordialement à tous

    Votre savoir devient mon savoir qui deviendra votre savoir, telle est la connaissance qui appartient à tous

  8. #8
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    Février 2008
    Messages
    7 549
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Février 2008
    Messages : 7 549
    Points : 19 375
    Points
    19 375
    Par défaut
    après avoir mis à jour /etc/apt/source.list,
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    # apt update && apt upgrade
    te renvoie le même message bloquant que pour l'install ?
    sinon tu peux nous faire un copier/coller, stp ?
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

  9. #9
    Membre régulier Avatar de BXDSPORT
    Homme Profil pro
    Consultant informatique
    Inscrit en
    Mars 2002
    Messages
    353
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Mayenne (Pays de la Loire)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : Mars 2002
    Messages : 353
    Points : 96
    Points
    96
    Par défaut
    Voici le code pour ugrader n'oubliez pas c'est un ubuntu server
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    Atteint*:1 http://fr.archive.ubuntu.com/ubuntu bionic InRelease
    Réception de*:3 http://fr.archive.ubuntu.com/ubuntu bionic-backports InRelease [83,3 kB]
    Atteint*:4 http://ppa.launchpad.net/certbot/certbot/ubuntu bionic InRelease
    Atteint*:5 http://nightly.odoo.com/8.0/nightly/deb ./ InRelease
    Atteint*:7 http://ppa.launchpad.net/iconnor/zoneminder-1.34/ubuntu bionic InRelease
    Atteint*:8 http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease
    Réception de*:9 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
    Réception de*:10 https://packages.sury.org/php buster InRelease [8663 B]
    Ign*:11 https://packages.sury.org/php bionic InRelease
    Atteint*:2 https://downloads.mariadb.com/MariaDB/mariadb-10.3/repo/ubuntu bionic InRelease
    Err*:12 https://packages.sury.org/php bionic Release
      404  Not Found [IP*: 2400:52e0:1e02::1073:1 443]
    Atteint*:6 https://downloads.mariadb.com/Tools/ubuntu bionic InRelease
    Atteint*:13 http://nginx.org/packages/mainline/ubuntu bionic InRelease
    E: Le dépôt «*https://packages.sury.org/php buster InRelease*» a modifié sa valeur «*Suite*» de «*buster/snapshots/1686920437*» à «*buster*»
    N: Ceci doit être pleinement accepté avant que les mises à jour depuis ce dépôt puissent être appliquées. Veuillez vous référer aux pages de manuel «*apt-secure(8)*» pour plus de détails.
    Souhaitez-vous accepter ces modifications et continuer à mettre à jour depuis ce dépôt*? [o/N]
    Ign*:14 https://download.webmin.com/download/repository sarge InRelease
    Atteint*:15 https://download.webmin.com/download/repository sarge Release
    Lecture des listes de paquets... Fait
    E: Le dépôt https://packages.sury.org/php bionic Release n'a pas de fichier Release.
    N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
    N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
    N: Le fichier configuré «*main/binary-i386/Packages*» ne sera pas pris en compte car le dépôt «*http://downloads.mariadb.com/MariaDB/mariadb-10.3/repo/ubuntu bionic InRelease*» ne prend pas en charge l'architecture «*i386*»
    root@sbt53:/home/antonin# apt upgrade
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Calcul de la mise à jour... Fait
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
    Vous avez du nouveau courrier dans /var/mail/root
    root@sbt53:/home/antonin# do-release-upgrade
    Checking for a new Ubuntu release
    Please install all available updates for your release before upgrading.
    root@sbt53:/home/antonin# apt full-upgrade
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Calcul de la mise à jour... Fait
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
    Et le fichier sources.list
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    cat sources.list
    #
     
    # deb cdrom:[Ubuntu-Server 16.04.6 LTS _Xenial Xerus_ - Release amd64 (20190226)]/ xenial main restricted universe multiverse restricted universe multiverse restricted universe multiverse restricted
     
    # deb cdrom:[Ubuntu-Server 16.04.6 LTS _Xenial Xerus_ - Release amd64 (20190226)]/ xenial main restricted universe multiverse restricted universe multiverse restricted universe multiverse restricted
     
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    deb http://fr.archive.ubuntu.com/ubuntu/ bionic main restricted universe multiverse restricted universe multiverse
    # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted universe multiverse restricted universe multiverse restricted universe multiverse restricted
     
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    # deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates main restricted universe multiverse restricted universe multiverse
    # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted universe multiverse restricted universe multiverse restricted universe multiverse restricted
     
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    #deb http://fr.archive.ubuntu.com/ubuntu/ bionic universe
    # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
    # deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates universe
    # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
     
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    # deb http://fr.archive.ubuntu.com/ubuntu/ bionic multiverse
    # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
    # deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
    # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
     
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main restricted universe multiverse restricted universe multiverse restricted universe multiverse release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    deb http://fr.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
    # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse restricted universe multiverse restricted universe multiverse restricted universe multiverse
     
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    # deb http://archive.canonical.com/ubuntu xenial partner
    # deb-src http://archive.canonical.com/ubuntu xenial partner
     
    deb http://security.ubuntu.com/ubuntu bionic-security main restricted universe multiverse
    # deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted universe multiverse restricted universe multiverse restricted universe multiverse restricted
    # deb http://security.ubuntu.com/ubuntu bionic-security universe
    # deb-src http://security.ubuntu.com/ubuntu xenial-security universe
    # deb http://security.ubuntu.com/ubuntu bionic-security multiverse
    # deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
    # installation webmin
    # deb http://download.webmin.com/download/repository sarge contrib # désactivé pour la mise à niveau vers bionic
    #installation odoo 8 dans le dossier python 2.7
    deb http://nightly.odoo.com/8.0/nightly/deb/ ./ # désactivé pour la mise à niveau vers bionic
     
     
    # deb http://software.virtualmin.com/vm/6/gpl/apt virtualmin-xenial main restricted universe multiverse restricted universe multiverse restricted universe multiverse # désactivé pour la mise à niveau vers bionic
    # deb http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal main restricted universe multiverse restricted universe multiverse restricted universe multiverse # désactivé pour la mise à niveau vers bionic
    # deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse restricted universe multiverse
    # deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse restricted universe multiverse
    # deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
    deb https://packages.sury.org/php/ buster main
    # deb-src https://packages.sury.org/php/ buster main
    Nota j'ai un message disant que j'ai un mail root où il n'y a rien dedans
    Merci de vos lumières
    Cordialement à tous

    Votre savoir devient mon savoir qui deviendra votre savoir, telle est la connaissance qui appartient à tous

  10. #10
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    Février 2008
    Messages
    7 549
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Février 2008
    Messages : 7 549
    Points : 19 375
    Points
    19 375
    Par défaut
    il me semble voir un début d'indice : deb https://packages.sury.org/php/ buster main. Et je vois (dans la sortie de l'upgrade) des références à sarge aussi.

    c'est toi qui a créé cette "FrankenUbuntu" ( ) ?

    sur une FocalFossa qui traîne en VM sur mon système, la version de PHP disponible n'est que 7.4.
    je ne sais pas si la dernière version d'Ubuntu propose la version 8...

    en tout cas, je crois que tu as du ménage à faire dans tes sources.list pour pouvoir faire un upgrade.
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

  11. #11
    Membre régulier Avatar de BXDSPORT
    Homme Profil pro
    Consultant informatique
    Inscrit en
    Mars 2002
    Messages
    353
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Mayenne (Pays de la Loire)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : Mars 2002
    Messages : 353
    Points : 96
    Points
    96
    Par défaut
    Concernant Ubuntu server 18 accepte le php 8.2.
    Je vais essayer de repérer les lignes signaler.
    Cordialement à tous

    Votre savoir devient mon savoir qui deviendra votre savoir, telle est la connaissance qui appartient à tous

  12. #12
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    Février 2008
    Messages
    7 549
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Février 2008
    Messages : 7 549
    Points : 19 375
    Points
    19 375
    Par défaut
    Concernant Ubuntu server 18 accepte le php 8.2.
    d'origine par défaut, ou après ajout de dépôts externes dans les sources.list ?

    j'ai installé Lunar Lobster sous lxc, PHP est à 8.1
    et je n'ai pas de version server, c'est pourquoi je pose la question.
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

  13. #13
    Membre confirmé Avatar de 01001111
    Homme Profil pro
    Développeur Web
    Inscrit en
    Janvier 2009
    Messages
    319
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Loire (Auvergne)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : Janvier 2009
    Messages : 319
    Points : 509
    Points
    509
    Par défaut
    je vois que tu as les packages de debian pour les sources sury qui sont à l'origine de ton install php...
    Pour Ubuntu il faut passer par le dépôt ppa de Ondrej Sury...

    exemple :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    nano /etc/apt/sources.list.d/php-sury.list
     // puis coller dedans :
    deb http://ppa.launchpad.net/ondrej/php/ubuntu bionic main
    deb-src http://ppa.launchpad.net/ondrej/php/ubuntu bionic main
    ou bien
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    add-apt-repository ppa:ondrej/php
    et enfin supprimer la source sury existante actuellement.
    Une fois le système dans un état correct, tu peux mettre à jour le système, puis mettre à jour aussi les sources sury vers de plus récentes.
    0x4F

Discussions similaires

  1. Bloquer par PHP les sous-titres automatiques
    Par JPBruneau dans le forum Langage
    Réponses: 1
    Dernier message: 13/07/2021, 14h26
  2. [9.5] Accès via phpgadmin impossible par internet sous ubuntu server 16
    Par BXDSPORT dans le forum Administration
    Réponses: 0
    Dernier message: 01/04/2019, 09h16
  3. [PostgreSQL] Création base de données avec postgresql 8.4 sous Ubuntu server 9.10
    Par cyreel dans le forum PHP & Base de données
    Réponses: 10
    Dernier message: 07/12/2009, 18h10
  4. Installation de Manta sous Ubuntu Server 8.10
    Par LilKami dans le forum Ubuntu
    Réponses: 0
    Dernier message: 30/03/2009, 09h10
  5. Installation PHP/Java Bridge sous Ubuntu
    Par cmasset dans le forum Bibliothèques et frameworks
    Réponses: 2
    Dernier message: 10/12/2008, 09h10

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo