IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

EDI/RAD Python Discussion :

Erreur sur installation Jupiter dans Pycharm [Python 3.X]


Sujet :

EDI/RAD Python

  1. #1
    Community Manager

    Avatar de Malick
    Homme Profil pro
    Community Manager
    Inscrit en
    juillet 2012
    Messages
    8 935
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Sénégal

    Informations professionnelles :
    Activité : Community Manager
    Secteur : Conseil

    Informations forums :
    Inscription : juillet 2012
    Messages : 8 935
    Points : 82 805
    Points
    82 805
    Billets dans le blog
    15
    Par défaut Erreur sur installation Jupiter dans Pycharm
    Bonjour,

    Merci d'avance pour votre aide.

    Une idée sur comment résoudre ce problème ?

    J'essaie d'installer Jupiter sur Pycharm, mais j'ai ce message d'erreur :

    Version python 3.10.4

    Microsoft Windows [version 10.0.22621.963]
    (c) Microsoft Corporation. Tous droits réservés.

    C:\Users\Malick>C:\Users\Malick\Python_Malick\Automatisation_Timesheets_Pycharm\venv\Scripts\activate.bat

    (venv) C:\Users\Malick>pip install Jupiter
    ERROR: Could not find a version that satisfies the requirement Jupiter (from versions: none)
    ERROR: No matching distribution found for Jupiter

    (venv) C:\Users\Malick>
    La capture :

    Nom : Capture d’écran 2023-01-06 155541.png
Affichages : 46
Taille : 116,5 Ko
    Vous avez envie de contribuer au sein du Club Developpez.com ? Contactez-nous maintenant !
    Vous êtes passionné, vous souhaitez partager vos connaissances en informatique, vous souhaitez faire partie de la rédaction.
    Il suffit de vous porter volontaire et de nous faire part de vos envies de contributions :
    Rédaction d'articles/cours/tutoriels, Traduction, Contribution dans la FAQ, Rédaction de news, interviews et témoignages, Organisation de défis, de débats et de sondages, Relecture technique, Modération, Correction orthographique, etc.
    Vous avez d'autres propositions de contributions à nous faire ? Vous souhaitez en savoir davantage ? N'hésitez pas à nous approcher.

  2. #2
    Expert éminent sénior
    Homme Profil pro
    Architecte technique retraité
    Inscrit en
    juin 2008
    Messages
    20 135
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Architecte technique retraité
    Secteur : Industrie

    Informations forums :
    Inscription : juin 2008
    Messages : 20 135
    Points : 34 830
    Points
    34 830
    Par défaut
    Citation Envoyé par Malick Voir le message
    Une idée sur comment résoudre ce problème ?
    Le message d'erreur vous dit que le package n'existe pas pour votre version de Python.
    Allez sur PyPI et vérifiez que vous voulez bien installer ce package là et que l'information remontée par pip est cohérente avec les distributions disponibles....

    - W
    Architectures post-modernes.
    Python sur DVP c'est aussi des FAQs, des cours et tutoriels

  3. #3
    Community Manager

    Avatar de Malick
    Homme Profil pro
    Community Manager
    Inscrit en
    juillet 2012
    Messages
    8 935
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Sénégal

    Informations professionnelles :
    Activité : Community Manager
    Secteur : Conseil

    Informations forums :
    Inscription : juillet 2012
    Messages : 8 935
    Points : 82 805
    Points
    82 805
    Billets dans le blog
    15
    Par défaut
    Salut,

    Merci wiztricks

    Apparement le package jupiter que propose ma version de Pycharm est très ancienne (date de 2012 ). Après vérification sur Pypi : https://pypi.org/project/Jupiter/

    Et pourtant j'ai la dernière version de Pycharm.

    Nom : Capture d’écran 2023-01-06 161902.png
Affichages : 33
Taille : 38,2 Ko
    Vous avez envie de contribuer au sein du Club Developpez.com ? Contactez-nous maintenant !
    Vous êtes passionné, vous souhaitez partager vos connaissances en informatique, vous souhaitez faire partie de la rédaction.
    Il suffit de vous porter volontaire et de nous faire part de vos envies de contributions :
    Rédaction d'articles/cours/tutoriels, Traduction, Contribution dans la FAQ, Rédaction de news, interviews et témoignages, Organisation de défis, de débats et de sondages, Relecture technique, Modération, Correction orthographique, etc.
    Vous avez d'autres propositions de contributions à nous faire ? Vous souhaitez en savoir davantage ? N'hésitez pas à nous approcher.

  4. #4
    Community Manager

    Avatar de Malick
    Homme Profil pro
    Community Manager
    Inscrit en
    juillet 2012
    Messages
    8 935
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Sénégal

    Informations professionnelles :
    Activité : Community Manager
    Secteur : Conseil

    Informations forums :
    Inscription : juillet 2012
    Messages : 8 935
    Points : 82 805
    Points
    82 805
    Billets dans le blog
    15
    Par défaut
    C'est bon maintenant, le problème était lié apparement à l'interpréteur 3.10. En choisissant Python 3.9, Jupyter est installé avec succès.

    Merci encore pour ton aide

    Nom : jupiter1.0.png
Affichages : 33
Taille : 55,3 Ko
    Vous avez envie de contribuer au sein du Club Developpez.com ? Contactez-nous maintenant !
    Vous êtes passionné, vous souhaitez partager vos connaissances en informatique, vous souhaitez faire partie de la rédaction.
    Il suffit de vous porter volontaire et de nous faire part de vos envies de contributions :
    Rédaction d'articles/cours/tutoriels, Traduction, Contribution dans la FAQ, Rédaction de news, interviews et témoignages, Organisation de défis, de débats et de sondages, Relecture technique, Modération, Correction orthographique, etc.
    Vous avez d'autres propositions de contributions à nous faire ? Vous souhaitez en savoir davantage ? N'hésitez pas à nous approcher.

  5. #5
    Expert éminent sénior
    Homme Profil pro
    Architecte technique retraité
    Inscrit en
    juin 2008
    Messages
    20 135
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Architecte technique retraité
    Secteur : Industrie

    Informations forums :
    Inscription : juin 2008
    Messages : 20 135
    Points : 34 830
    Points
    34 830
    Par défaut
    Citation Envoyé par Malick Voir le message
    C'est bon maintenant, le problème était lié apparement à l'interpréteur 3.10. En choisissant Python 3.9, Jupyter est installé avec succès.
    Ce que je constate c'est que vous aviez essayé d'installer un package nommé "Jupiter" sans succès alors qu'avec celui nommé "Jupyter" (notez le y à la place du i) ça marche mieux. Après l'important est que çà tombe en marche...

    - W
    Architectures post-modernes.
    Python sur DVP c'est aussi des FAQs, des cours et tutoriels

  6. #6
    Community Manager

    Avatar de Malick
    Homme Profil pro
    Community Manager
    Inscrit en
    juillet 2012
    Messages
    8 935
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Sénégal

    Informations professionnelles :
    Activité : Community Manager
    Secteur : Conseil

    Informations forums :
    Inscription : juillet 2012
    Messages : 8 935
    Points : 82 805
    Points
    82 805
    Billets dans le blog
    15
    Par défaut
    Bien vu également

    et bon week-end

    Malick
    Vous avez envie de contribuer au sein du Club Developpez.com ? Contactez-nous maintenant !
    Vous êtes passionné, vous souhaitez partager vos connaissances en informatique, vous souhaitez faire partie de la rédaction.
    Il suffit de vous porter volontaire et de nous faire part de vos envies de contributions :
    Rédaction d'articles/cours/tutoriels, Traduction, Contribution dans la FAQ, Rédaction de news, interviews et témoignages, Organisation de défis, de débats et de sondages, Relecture technique, Modération, Correction orthographique, etc.
    Vous avez d'autres propositions de contributions à nous faire ? Vous souhaitez en savoir davantage ? N'hésitez pas à nous approcher.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. RED HAT 7.3 : erreur sur installation en VMWare
    Par Arnard dans le forum VMware
    Réponses: 1
    Dernier message: 02/09/2008, 10h22
  2. Erreur sur suppression Record dans SS form
    Par Maxsen dans le forum VBA Access
    Réponses: 4
    Dernier message: 29/02/2008, 22h45
  3. Message erreur sur méthode Update dans une gridview
    Par zefog dans le forum Général Dotnet
    Réponses: 1
    Dernier message: 22/02/2008, 13h00
  4. Messages d'erreur sur install Runtime
    Par curt dans le forum Runtime
    Réponses: 6
    Dernier message: 01/12/2007, 00h41
  5. [SPRING MVC]Erreur sur un Integer dans un Validator
    Par manuzinho dans le forum Spring Web
    Réponses: 2
    Dernier message: 31/08/2007, 16h58

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo