IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eclipse Java Discussion :

3 erreurs sur test JUnit - problème avec JRE?


Sujet :

Eclipse Java

  1. #1
    Nouveau Candidat au Club
    Femme Profil pro
    Développeur Java
    Inscrit en
    octobre 2022
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 30
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur Java

    Informations forums :
    Inscription : octobre 2022
    Messages : 2
    Points : 1
    Points
    1
    Par défaut 3 erreurs sur test JUnit - problème avec JRE?
    Bonjour à tous et merci de m'accueillir sur ce forum.
    Je rencontre 3 problèmes, sans doute liés, alors que j'écris un petit test sur Eclipse (qui date de 2011, il est vrai...) : http://www.junit.fr/2011/11/20/tutor...t-automatique/

    -1)En faisant Run as - JUnit test j'obtiens une fenêtre pop up "Error : Could not create the Java Virtual Machine. A fatal exception has occured. Program will exit. Ce n'est pas un problème de mémoire, j'ai créé une variable JAVA_OPTIONS et mis l'allocation de mémoire vive à 1024 Mo.

    -2)En même temps apparaît en rouge à la console : Unrecognized option: --add-opens
    J'utilise JUnit 5, la version 18 du JDK et 1.8 du JRE
    Après je ne sais pas exactement ce qu'Eclipse utilise mais j'ai eclipse 2022-06.
    (Sur invite de commande j'obtiens :
    Picked up _JAVA_OPTIONS: -Xmx1024M
    java version "1.8.0_341"
    Java(TM) SE Runtime Environment (build 1.8.0_341-b10)
    Java HotSpot(TM) Client VM (build 25.341-b10, mixed mode))

    Par contre en faisant Help -> About Eclipse IDE ->installation details ->configuration
    je trouve ceci pour le JRE : C:/Users/esthe/.p2/pool/plugins/org.eclipse.justj.openjdk.hotspot.jre.full.win32.x86_64_17.0.3.v20220515-1416/jre/bin\server\jvm.dll,
    cela ne me rassure juste pas de voir "win32" mais je ne sais pas exploiter cette ligne.

    3)Si je fais Run as -> Run configurations j'obtiens comme erreur : [JRE]: JRE not compatible with project .class file compatibility: 17 (mais si je change pour 18 ou 16 le problème reste identique).

    4)Et si je clique-droit sur moi test et fait "properties" et ensuite que je veux m'orienter sur "java compiler" ou autre j'obtiens cette erreur :
    An error has occurred. See error log for more details.
    class org.eclipse.core.internal.resources.File cannot be cast to class org.eclipse.core.resources.IProject (org.eclipse.core.internal.resources.File and org.eclipse.core.resources.IProject are in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @2bc426f0)

    Pour l'instant d'après mes recherches j'hésite à réinstaller Eclipse ou à voir dans ces différentes erreurs un problème de compatibilité au niveau du JRE mais je ne vois pas pourquoi étant donné les versions que j'utilise.

    Est-ce que quelqu'un serait susceptible de m'aider à ce stade?
    Merci à vous.

  2. #2
    Nouveau Candidat au Club
    Femme Profil pro
    Développeur Java
    Inscrit en
    octobre 2022
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 30
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur Java

    Informations forums :
    Inscription : octobre 2022
    Messages : 2
    Points : 1
    Points
    1
    Par défaut
    Bonjour,
    Peut-être cela vaut-il le coup de commencer par cette erreur, qui semble due à Eclipse, et qui est toujours dans la version 2022-09 que j'ai à présent : https://bugs.eclipse.org/bugs/show_bug.cgi?id=579428
    Alors il n'est pas possible d'aller sur "properties" à partir d'une classe et de chercher, par exemple, "java compiler" sans faire surgir cette erreur.
    Je ne sais pas si cela vaut la peine de charger une ancienne version d'eclipse, pour l'instant je crains plutôt de me retrouver avec d'autres problèmes de versions entre JUnit 5, le JRE ou autre.

Discussions similaires

  1. Réponses: 2
    Dernier message: 22/10/2009, 19h44
  2. erreur sur dans Qt source avec C++ sous linux
    Par chochatown dans le forum Qt
    Réponses: 2
    Dernier message: 28/05/2009, 20h35
  3. [Xcopy et batch sur un réseau] Problème avec /d
    Par Oliv92120 dans le forum Scripts/Batch
    Réponses: 0
    Dernier message: 17/07/2008, 11h13
  4. Erreur sur inclusion types.h avec cygwin
    Par Bayard dans le forum Réseau
    Réponses: 12
    Dernier message: 12/11/2006, 17h48
  5. message d'erreur sur test module
    Par Daniel MOREAU dans le forum Access
    Réponses: 5
    Dernier message: 23/11/2005, 21h19

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo